Page MenuHomePhabricator

Unexpected linebreaks added to edits
Closed, ResolvedPublic

Event Timeline

TheDJ created this task.Oct 9 2017, 10:37 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptOct 9 2017, 10:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Elitre added a subscriber: Elitre.Oct 10 2017, 9:11 AM

I can't even get syntax highlighting to work. I enabled both the "New wikitext mode" beta feature. Neither the "Wikitext syntax highlighting" beta feature or the "Syntax highlighting" gadget actually highlighted any syntax. More detailed steps to reproduce are needed.

@Ryasmeen Could you take a look at this? I have no idea what's happening.

Ryasmeen added a comment.EditedOct 11 2017, 1:28 AM

@Deskana: Tried to fiddle with it. The following things happen for me.

  1. The gadget for Syntax highlighter does not work for me at all.
  2. The Beta feature "Wikitext Syntax Highlighting" works but does show weird cursor behavior after pressing space bar thrice at the end of any line.
  3. Also, after saving I could see the next line appears indented inside the editor. But I don't see the second line to be treated as <pre>...</pre> in the read mode.

4.This issue does not happen when the Beta feature of syntax highlighting is turned off.

  1. This issue happens even if the first line ends with an alphabet.

Here is the screenshot showing that for the first two cases there is no indentation, it only appears after I pressed space bar three times.

I have also added the video capture here to show the weird cursoring behavior. Hope this helps to spot the issue.

Some possibilities, based on the comments at enwiki's VPT:

  • Try double-spacing after the end of a sentence.
  • The connection with Syntax Highlighting seems to be a red herring.
  • This is happening in a variety of wikitext editing environments:
    • Chrome 61.0.3163.98 on Android 7.0 (Samsung Galaxy S6), using the mobile editor
    • Chrome on MacOS X, using the 2010 WikiEditor
    • Chome on a Mac, using an unspecified wikitext editor.
Restricted Application added a project: Community-Tech. · View Herald TranscriptNov 6 2017, 11:38 PM
  • Try double-spacing after the end of a sentence.

Urgh. No, please no.

I can't even get syntax highlighting to work. I enabled both the "New wikitext mode" beta feature. Neither the "Wikitext syntax highlighting" beta feature or the "Syntax highlighting" gadget actually highlighted any syntax. More detailed steps to reproduce are needed.

To use syntax highlighting, you need to enable it from the Options menu in NWE.

It's very possible that Syntax highlighting is causing this but one comment on VPT says -

" Update – I've run for a week or so without syntax highlighting (either version), as requested, and it's still happening, under the same conditions as initially reported. And additional one (or a variant, really) is that it often happens when double-spacing after a . (i.e., another case of a space after a non-alphanum character). I find that re-sizing the browser window can make it go away, and sometimes doing "Show preview" will as well."

so maybe not? I'll do some testing on my end.

@Deskana: Tried to fiddle with it. The following things happen for me.

  1. The gadget for Syntax highlighter does not work for me at all.
  2. The Beta feature "Wikitext Syntax Highlighting" works but does show weird cursor behavior after pressing space bar thrice at the end of any line.
  3. Also, after saving I could see the next line appears indented inside the editor. But I don't see the second line to be treated as <pre>...</pre> in the read mode.

4.This issue does not happen when the Beta feature of syntax highlighting is turned off.

  1. This issue happens even if the first line ends with an alphabet.

Here is the screenshot showing that for the first two cases there is no indentation, it only appears after I pressed space bar three times.


I have also added the video capture here to show the weird cursoring behavior. Hope this helps to spot the issue.

That's very helpful. Thanks, @Ryasmeen. Can you tell me what browser that was on? I couldn't reproduce this on Chrome.

@Deskana: Tried to fiddle with it. The following things happen for me.

  1. The gadget for Syntax highlighter does not work for me at all.
  2. The Beta feature "Wikitext Syntax Highlighting" works but does show weird cursor behavior after pressing space bar thrice at the end of any line.
  3. Also, after saving I could see the next line appears indented inside the editor. But I don't see the second line to be treated as <pre>...</pre> in the read mode.

4.This issue does not happen when the Beta feature of syntax highlighting is turned off.

  1. This issue happens even if the first line ends with an alphabet.

Here is the screenshot showing that for the first two cases there is no indentation, it only appears after I pressed space bar three times.


I have also added the video capture here to show the weird cursoring behavior. Hope this helps to spot the issue.

That's very helpful. Thanks, @Ryasmeen. Can you tell me what browser that was on? I couldn't reproduce this on Chrome.

@Niharika: This was on Chrome. To reproduce this, make sure the last word at the end of a line reaches the edge of the window. In my example screen capture, the window was resized down to make the word "magna" to be at the edge of the window.

I was able to reproduce the issue of cursor being offset few characters again today and this specific part of the problem only happens when Syntax Highlighting is enabled on NWE.

Thanks, that helps.

TBolliger added a subscriber: TBolliger.

Needs product investigation before estimation.

After determining the severity of this, please decide if it is a requirement for T185030: Graduate Syntax Highlighting (CodeMirror) out of beta for non-RTL wikis on the 2010 wikitext editor or not.

Niharika closed this task as Resolved.Mar 21 2018, 6:33 PM
Niharika moved this task from Product backlog to Archive on the Community-Tech board.

I tested this again today with @Ryasmeen's example and it seems to have been fixed now. Probably through one of the multiple fixes Ed made to improve CodeMirror experience on NWE. :)
Thanks all. Feel free to reopen if it happens again.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 21 2018, 6:33 PM