Page MenuHomePhabricator

Remove 'Expand all section' toggle on tablet and desktop mode
Closed, ResolvedPublic2 Story Points

Description

Issue

Tablets/desktop layout is set to expanding all sections by default on MinervaNeue. this creates a little bit of problem when a setting to enable/disable this feature is introduced on tablets. as a result, if you turn off "expand all sections" on tablets, it won't actually collapse all section which is the expected behaviour.

Expected behaviour

  • on tablets+desktop this particular toggle should not appear in the settings page

Developer notes

Favor JavaScript use M.require( 'mobile.startup/Browser' ).isWideScreen() instead of CSS.

AC

  • On a small screen device, the expand all sections beta option is displayed on Special:MobileOptions.
  • On a large screen device, the expand all sections beta option is hidden on Special:MobileOptions and the Barack Obama page appears with all sections initially expanded.

Event Timeline

Nirzar triaged this task as Normal priority.Dec 21 2017, 7:34 PM
Nirzar created this task.
bmansurov moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.EditedDec 22 2017, 2:19 PM
bmansurov added a subscriber: bmansurov.

How about we hide "Expand all sections" on tablets? As far as I know tablets never had the section toggling feature.

@Nirzar what do you think of baha's suggestion? This was only ever designed for mobile (where many users complained that sections were collapsed making find all on page difficult) and I'd argue not very useful on tablet devices. What is the use case there?

I'd suggest that if we do hide this on tablet devices, we'd change the label to say "Expand all sections on mobile"

Pulling into sprint for visibility since it blocks T169257

Nirzar added a comment.Jan 2 2018, 7:18 PM

Let's remove this option from tablets for now. no change in the label.

we can rename this task to remove the setting to 'expand all sections' on tablets

Jdlrobson renamed this task from 'Expand all section' toggle should work on tablets and desktops to Remove 'Expand all section' toggle on tablet and desktop mode.Jan 2 2018, 7:20 PM
Jdlrobson updated the task description. (Show Details)
Niedzielski set the point value for this task to 2.
Jdlrobson removed Nirzar as the assignee of this task.Jan 3 2018, 6:03 PM
Jdlrobson updated the task description. (Show Details)
Niedzielski moved this task from To Do to Doing on the Readers-Web-Kanbanana-Board-Old board.
Niedzielski updated the task description. (Show Details)

Change 402082 had a related patch set uploaded (by Niedzielski; owner: Sniedzielski):
[mediawiki/extensions/MobileFrontend@master] Update: hide section expansion option on large displays

https://gerrit.wikimedia.org/r/402082

@Jdlrobson, I didn't apply your recommendation to use isTabletDevice() since this is a PHP function and it seems that the toggle option display logic should match the initial collapse state logic in toggle.js. Please let me know if you disagree.

Change 402113 had a related patch set uploaded (by Jdlrobson; owner: Sniedzielski):
[mediawiki/extensions/MobileFrontend@specialpages] Update: hide section expansion option on large displays

https://gerrit.wikimedia.org/r/402113

Change 402113 abandoned by Jdlrobson:
Update: hide section expansion option on large displays

https://gerrit.wikimedia.org/r/402113

Change 402116 had a related patch set uploaded (by Niedzielski; owner: Sniedzielski):
[mediawiki/extensions/MobileFrontend@specialpages] Update: hide section expansion option on large displays

https://gerrit.wikimedia.org/r/402116

Change 402082 abandoned by Niedzielski:
Update: hide section expansion option on large displays

Reason:
Moved to https://gerrit.wikimedia.org/r/#/c/402116/.

https://gerrit.wikimedia.org/r/402082

Change 402116 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@specialpages] Update: hide section expansion option on large displays

https://gerrit.wikimedia.org/r/402116

Nirzar closed this task as Resolved.Jan 7 2018, 9:44 PM

Macro votecat: looks good