Promote expand all sections feature from beta (in feature branch)
Closed, ResolvedPublic1 Story Points

Description

https://en.m.wikipedia.org/wiki/Special:MobileOptions?mobileaction=beta
A feature "expand all sections" allows users to always keep sections open. It works for anonymous users.

Acceptance criteria

Promote "expand all sections" to stable:

  • remove from list of beta features and display expand all sections within list of settings

Developer notes

The MFExpandAllSectionsUserOption controls this. Current value is:

"MFExpandAllSectionsUserOption": {
        "base": false,
        "beta": true
},

base must be flipped to true either via change inside repo or SWAT

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 29 2017, 6:10 PM
ovasileva triaged this task as Normal priority.Jun 30 2017, 9:39 AM
ovasileva added subscribers: Nirzar, ovasileva.

Did we make a decision? Are we moving this to stable? The description hasn't been updated...

ovasileva updated the task description. (Show Details)Dec 4 2017, 3:26 PM

Does this deploy to all wikis? Do we need any extra logging? Will this trigger existing expand / collapse logging for all sections on a page?

Jdlrobson updated the task description. (Show Details)Dec 7 2017, 10:16 PM
Jdlrobson set the point value for this task to 1.

Being bold and assigning 1 since this is essentially a swat deploy.

Change 396284 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@specialpages] Promote expand all sections and fontchanger to stable

https://gerrit.wikimedia.org/r/396284

ovasileva renamed this task from Promote expand all sections feature from beta to Promote expand all sections feature from beta (in feature branch).Dec 11 2017, 3:36 PM

Change 396284 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@specialpages] Promote expand all sections and fontchanger to stable

https://gerrit.wikimedia.org/r/396284

pmiazga assigned this task to Nirzar.Dec 20 2017, 6:09 PM

Overall settings work seems to be working as expected! yay!

but one minor issue on this card.... kind of a bug to "expand al sections" feature so let me know if we want to create a follow up card or fix it as part of this card

Issue

Tablets/desktop layout is set to expanding all sections by default on MinervaNeue. this creates a little bit of problem when a setting to enable/disable this feature is introduced on tablets. as a result, if you turn off "expand all sections" on tablets, it won't actually collapse all section which is the expected behaviour.

what should happen

  • on tablets, this particular toggle should be switched 'ON' by default
  • on tablets, turning off this toggle in settings should collapse all sections on tablets
Nirzar added a subscriber: pmiazga.Dec 21 2017, 7:36 PM

as per @pmiazga created a subtask to this for the above issue -

T183493: Remove 'Expand all section' toggle on tablet and desktop mode

cc @ovasileva if T183493 should be a blocker to promote this feature to stable

pmiazga moved this task from Ready for Signoff to Blocked on the Readers-Web-Kanban-Board board.EditedDec 21 2017, 9:04 PM

I'll be bold, we have an UI glitch, we cannot promote to stable something that is broken. Moving to blocked, as it's blocked on T183493.

@Jdlrobson it would be amazing if you can verify the T183493 and propose a fix.

Since https://gerrit.wikimedia.org/r/396284 has been merged and we have T183493 and the deploy task this particular task can be considered done. Maybe Nirzar should sign off?

Nirzar closed this task as Resolved.Wed, Jan 3, 9:53 PM

Macro votecat: looks good