Page MenuHomePhabricator

On the desktop site, editing the lead section of a page under MinervaNeue skin directs a user to one of desktop WikiEditors
Closed, ResolvedPublic

Description

Problem

Depending on User Preferences settings, when I'm using a desktop web browser the desktop site, if I were to edit just the lead section (i.e. introduction) of an article or a page, I would be directed to one of desktop WikiEditors.

In my case, for months I have disabled toolbar(s), so I can switch to the default/2003 WikiEditor, one w/o the toolbars.

Then I switch to "MinervaNeue" skin in the Apperances setup to test out the editing under it. When I clicked the "Edit"/pencil icon, I was directed not to the mobile WikiEditor, which has been used for the rest of a page. Instead, I was directed to the 2003 WikiEditor.

Same results apply whenever I enable a toolbar.

Then I re-enabled the 2017 WikiEditor (beta) to retest it in this skin. I clicked the "Edit"/pencil icon and was redirected to the 2017 WE (or NWE). Worse is that the left and right ends of the NWE's toolbars are edged out of the screen, i.e. cut off from screen.

Expected results

At desktop site, under MinervaNeue skin, if I were to edit the first/lead section, I should have been directed to the mobile-like WikiEditor rather than a desktop WikiEditor.

Event Timeline

gh87 created this task.Mar 29 2018, 7:00 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 29 2018, 7:00 AM
gh87 renamed this task from Editing the lead section of a page under MinervaNeue skin directs a user to one of desktop WikiEditors to On a desktop web browser, editing the lead section of a page under MinervaNeue skin directs a user to one of desktop WikiEditors.Mar 29 2018, 7:00 AM
Jdlrobson added subscribers: Esanders, Jdlrobson.

Im not sure how editor gets chosen on desktop but Minerva doesnt do anything specific. @Esanders any idea what might be happening here?

As of T198765, the desktop wikitext editor (or desktop visual editor) is used on desktop Minerva skin. As of T208102, the problems with the visual editor toolbar should be fixed.

Can you explain why your expected result would be opening the mobile editor?

gh87 added a comment.Mar 26 2019, 9:27 PM

I now realize that the "Add an [edit] link for the lead section of a page" option is not part of the MediaWiki software. Rather it's a local gadget.

@matmarex I shall clarify... Well, I meant to say that, if wanting to edit just the lead section, I expected the Skin to be just MinervaNeue (if selected as the Skin), not any other skin.

Nevertheless, after recently re-testing a page by using the MinervaNeue skin, the issue is already fixed (or nearly fixed). Well, if the 2017/Newer Wikitext beta editor is not enabled, the gadget (if enabled) and one of the pencil icons would result the same. Nevertheless, the word "edit" button would appear next to the article title.

However, if the 2017/Newer Wikitext editor is enabled, clicking on the pencil icon would direct me to the mobile-looking (or MinervaNeue-skinned) editor. On the contrary, clicking on the local gadget's "edit" button would lead me to the 2017/Newer Wikitext editor, but that's just an issue when using the local gadget (not part of the MW software).

JTannerWMF moved this task from To Triage to Freezer on the VisualEditor board.Apr 9 2019, 4:00 PM

Nevertheless, after recently re-testing a page by using the MinervaNeue skin, the issue is already fixed (or nearly fixed). Well, if the 2017/Newer Wikitext beta editor is not enabled, the gadget (if enabled) and one of the pencil icons would result the same. Nevertheless, the word "edit" button would appear next to the article title.

To be clear, is the only remaining issue that the lead-section-edit-link on desktop Minerva skin is the word "Edit" rather than an icon ?

(If you have "Show me both editor tabs" enabled in preferences, the two edit links are also a bit broken, this is known and I have a patch pending to fix it: https://gerrit.wikimedia.org/r/c/mediawiki/extensions/VisualEditor/+/499321)

I proposed a fix to the gadget: https://en.wikipedia.org/wiki/MediaWiki_talk:Gadget-edittop.css

However, if the 2017/Newer Wikitext editor is enabled, clicking on the pencil icon would direct me to the mobile-looking (or MinervaNeue-skinned) editor. On the contrary, clicking on the local gadget's "edit" button would lead me to the 2017/Newer Wikitext editor, but that's just an issue when using the local gadget (not part of the MW software).

I'm having a hard time understanding which editors you're talking about. There are surprisingly many edit interfaces… I have found that screenshots help in this, so:

These are the interfaces you should see (when using any edit link):

When you're using the mobile site:

Reading modeWikitext editorVisual editor

The mobile site reading mode has collapsible sections. Both mobile editors are full-screen (the menu bar is hidden). Mobile wikitext editor is completely different from both the old and new desktop wikitext editors. Mobile visual editor has reduced number of tools on the toolbar.

When you're using the desktop site:

Reading modeOld wikitext editorNew wikitext editorVisual editor

The desktop site reading mode in the Minerva skin doesn't have collapsible sections. The desktop editors in the Minerva skin are not full-screen (the menu bar is shown above them). Desktop visual editor in the Minerva skin has all the tools you'd see on Vector.


Note that the interface you see doesn't depend on whether you're using a browser on a mobile or desktop device – only on whether you're looking at the mobile or desktop site (https://en.m.wikipedia.org/ vs https://en.wikipedia.org/). Looks like the lead-section-edit-link gadget is not loaded on the mobile site.

Does this match what you're seeing? If not, can you take a screenshot and attach it?

gh87 added a comment.Apr 11 2019, 5:50 AM

Oh... yeah. Sorry, I wasn't specific or clear enough.

I was referring to the desktop site using MinervaNeue skin. The screenshot of the "old wikitext editor" matches what I described while using the pencil icon, regardless of whether or not the new wikitext editor is enabled.

Nevertheless, here's the below screenshot of what I described while enabling the new wikitext editor when I clicked the "Edit" button (via local gadget), which then becomes "edit source":

gh87 renamed this task from On a desktop web browser, editing the lead section of a page under MinervaNeue skin directs a user to one of desktop WikiEditors to On the desktop site, editing the lead section of a page under MinervaNeue skin directs a user to one of desktop WikiEditors.Apr 11 2019, 6:19 AM
gh87 updated the task description. (Show Details)

Nevertheless, here's the below screenshot of what I described while enabling the new wikitext editor when I clicked the "Edit" button (via local gadget), which then becomes "edit source":

Thanks, I could reproduce that.

It looks like this is also resolved by my changes to the gadget (which were applied this morning). Can you try it again?

I was referring to the desktop site using MinervaNeue skin. The screenshot of the "old wikitext editor" matches what I described while using the pencil icon, regardless of whether or not the new wikitext editor is enabled.

I fiddled a bit with my preferences and found that I could reproduce this after disabling VE ("Temporarily disable the visual editor while it is in beta") while leaving NWE enabled. It happens inconsistently for me (I think the bug might depend on the order in which VE and the gadget load).

Looks like this is caused by the combination of these two issues:

Basically, because the initialization code doesn't run, clicking the link doesn't load the editor in-place, but rather loads the page "from scratch" as if you refreshed it.

gh87 added a comment.Apr 12 2019, 3:51 AM

I see that "Edit" changed into another pencil icon (seen next to an article title).

However, clicking that button while enabling the NWE still results the same as before.

Nevertheless, as said before, the issue with editing a lead section under the MinervaNeue skin in one of old wikitext editors seems to have been fixed (or nearly fixed) since creating this task last year. However, when clicking either of the first two pencil icons (including another one next to the star icon), I can see just the lead section in a source page.

This seems to work correctly for me now? The patch for T178976 might have fixed it.

Restricted Application added a subscriber: Masumrezarock100. · View Herald TranscriptFeb 20 2020, 9:10 PM

Can you provide some QA steps or a gif showing the workflow in production? I'm not sure how to get the 2003 WikiEditor and test this :(

gh87 added a comment.Feb 27 2020, 8:29 PM

@Jdlrobson To go to 2003 WikiEditor, which lacks a toolbar, you must first go to your Preferences settings, then go to the Editing tab, and then de-check the "Enable the editing toolbar". Finally, save your preferences. Optionally, you can click the "Enable the legacy (2006) editing toolbar" option at the Gadgets tab.

@gh87 as the creator of this task does this issue look fixed to you as of today?

gh87 added a comment.Feb 27 2020, 10:00 PM

For pre-2017 WikiEditors: Okay, I hope. Tested out; seems that everything is okay for me. Somehow, the MinervaNeue skin adjusts well with older wikitext editors. If I were to click the "Edit" button, I would edit just the lead section, not the whole article. I can't tell whether that's a separate issue or already filed separately.

However, for the newer, 2017 WikiEditor: select MinervaNeue appearance and enable the "New wikitext editor" beta feature, then test this article. Click "Edit", so you'll be directed to the source page. You'll see 2017WE in one moment. Then refresh the page, so you'll be directed to one of older wikitext editors. The "refresh the page" issue is still there just when you use the skin and enable the 2017WE beta feture.

gh87 added a comment.Feb 28 2020, 7:01 AM

Tested the VisualEditor under the MinervaNeue skin. No issues found while refreshing the page.

Per T190989#5924922 @matmarex can this be resolved? I'm not sure how 'New wikitext editor" beta feature,' relates to Minerva if at all?

gh87 added a comment.Mar 6 2020, 2:49 AM

@Jdlrobson Per T190765#5925709, the issue with NWE beta feature is no longer limited to just the Minerva skin. You can close this task as resolved if you want.

matmarex closed this task as Resolved.Oct 24 2020, 8:01 PM
matmarex claimed this task.

Sorry, I forgot about this task. We should have marked it as resolved in February. I just checked again and this still works correctly.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptOct 24 2020, 8:01 PM