Page MenuHomePhabricator

Help switch over foundation pages to donate wiki
Closed, ResolvedPublic

Description

@Pcoombe is moving these pages:
-Ways to give
-problems donating
-Matching gifts
-cancel recurring

Also check all other pages and make sure nothing is hitting the foundation site for these pages.

Details

Related Gerrit Patches:
mediawiki/extensions/DonationInterface : masterUpdate defaults for 'Ways to give' and 'Problems donating'
mediawiki/extensions/DonationInterface : masterPoint all links to foundation.wikimedia.org
mediawiki/extensions/DonationInterface : masterChange documentation variables and test to outline where changes are needed

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
mepps added a subscriber: mepps.EditedJun 4 2018, 7:44 PM
  • For thank you emails, need to change them in the wiki pages because they are hard-coded.
  • Change settings for links in donate-wiki
  • Deploy updated translations for donate-wiki
  • Look for any url settings in CiviCRM
mepps added a comment.Jun 4 2018, 7:45 PM
This comment was removed by mepps.
mepps claimed this task.Jun 4 2018, 7:52 PM
DStrine added a comment.EditedJun 4 2018, 7:54 PM

Once these pages are working and used by our systems, we need to set redirects on the foundation site to these. Should that be a separate task or can this be included here?

Change 437357 had a related patch set uploaded (by Mepps; owner: Mepps):
[mediawiki/extensions/DonationInterface@master] Change documentation variables and test to outline where changes are needed

https://gerrit.wikimedia.org/r/437357

mepps added a comment.Jun 6 2018, 5:16 PM

I notice that some of the pages in translation are missing (for example Matching Gifts in Spanish). Do we have a plan for changing those over @Pcoombe @DStrine?

mepps added a comment.Jun 6 2018, 5:27 PM

Also I emailed Greg about redirects from the new site to donate wiki.

@mepps There's quite a few which have never been translated, or are so outdated we need to drop them. You can either use the Special:LandingCheck form as currently used in README.txt, or the shorter https://donate.wikimedia.org/wiki/Special:MyLanguage/Matching_Gifts?uselang=es instead. The latter is probably what I'm going to do for the banner links. Either way the link will automatically fallback to English if a translation doesn't exist.

Re the patch: the FAQ, Tax Deductibility, and Donor Privacy Policy pages won't be moving to donatewiki. The first two will go to the new WMF Wordpress site, and the privacy policy will remain on the existing foundation wiki which is moving to foundation.wikimedia.org (T188776).

Also I'm no longer merging the "Cancel recurring" page into "Problems donating", it's going to stay separate. Will update the task description.

Pcoombe updated the task description. (Show Details)Jun 6 2018, 9:30 PM
mepps added a comment.EditedJun 7 2018, 6:11 PM

Thanks @Pcoombe! I emailed Greg to ask for the new urls for FAQ and Tax Deductibility.

mepps added a subscriber: Ejegg.Jun 11 2018, 1:12 PM

@Ejegg Let's chat today about when to deploy the settings changes for the pages that have already moved to donate wiki, and testing the new thank you page.

Change 439592 had a related patch set uploaded (by Mepps; owner: Mepps):
[mediawiki/extensions/DonationInterface@master] Also, update templates with direct links

https://gerrit.wikimedia.org/r/439592

@mepps I'm still working on some design changes to the donatewiki pages that Comms requested, so we shouldn't switch anything over just yet. Also I understand the launch of the new site has been delayed until July 30 (according to T188776#4262808) so we have a bit more time to get all this sorted out.

mepps added a comment.Jun 11 2018, 3:32 PM

Thanks @Pcoombe! Also @DStrine for your planning ^^.

mepps added a comment.Jun 11 2018, 8:42 PM

@Pcoombe Are you comfortable with us switching to the new thank you page or should we pause on that too?

@mepps Can we hold off on that for a few days please? Legal just asked for some new language on the TY pages, and it will be easier to work on adding it if there's no incoming traffic. I'll let you know when we're ready.

Okay @mepps, the new Thank You pages have been approved. Feel free to switch over to them whenever is convenient.

mepps added a comment.Jun 14 2018, 2:13 PM

Great @Pcoombe! @Ejegg let's plan for when we should do this.

TSkaff added a subscriber: TSkaff.Jun 14 2018, 3:25 PM

As @Ejegg suggested on standup today, I double checked that the centralnotice_hide_fundraising cookie is still set correctly on the new Thank You page. Confirmed it works fine in all browsers tested: Chrome, Firefox, Safari, IE11 and Edge.

Ejegg added a comment.Jun 18 2018, 9:50 PM

Great, thank you @Pcoombe! @mepps shall we switch those settings over Wednesday?

Vvjjkkii renamed this task from Help switch over foundation pages to donate wiki to srdaaaaaaa.Jul 1 2018, 1:12 AM
Vvjjkkii removed mepps as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from srdaaaaaaa to Help switch over foundation pages to donate wiki.Jul 1 2018, 8:34 AM
CommunityTechBot assigned this task to mepps.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.
CommunityTechBot raised the priority of this task from High to Needs Triage.Jul 3 2018, 2:00 AM

Once these pages are working and used by our systems, we need to set redirects on the foundation site to these.

What approach has been used in the past for redirecting between wikimediafoundation.org and donate.wikimedia.org? Wiki-redirects, Apache redirects, or some other system?

Thanks. Those could continue to work after T188776, albeit through an extra layer of redirect (wikimediafoundation.org/wiki -> newdomainforwmfwiki/wiki -> donate.wikimedia.org/wiki).

mepps added a comment.Jul 16 2018, 2:50 PM

@Pcoombe I'm noticing that the launch date is theoretically coming up. How are we feeling about switching over the other pages to donate wiki soon?

@mepps We still have some work to do to get these all aligned with Comms' preferred design. I'm hoping we will be ready to switch over by next week.

mepps added a comment.Jul 16 2018, 6:36 PM

Thanks @Pcoombe! @DStrine I'm on vacation next week so let's assign someone else before I leave.

mepps added a comment.Jul 16 2018, 6:36 PM

Also the thank you page is updated now.

Great! I confirmed the TY pages are working and closed T189664: Move fundraising thank you pages to donate.wikimedia.org.

mepps reassigned this task from mepps to jgleeson.Jul 16 2018, 8:10 PM
mepps added a subscriber: jgleeson.

@Pcoombe Awesome! As mentioned, I'll be gone next week but let @jgleeson know if the pages are ready for launch.

mepps added a comment.Jul 30 2018, 1:30 PM

@Pcoombe @jgleeson Just following up after vacation, what is the timeline to move to these new pages?

Ejegg moved this task from Backlog to Doing on the Fundraising Sprint Owls board.Jul 30 2018, 8:23 PM
mepps added a subscriber: Varnent.Jul 30 2018, 11:54 PM

@Pcoombe so it looks like the new site launched and it broke the links because there were no redirects. We are currently updating all the links to donatewiki and the foundationwiki because we don't know how to do localization links for the new site. @Varnent could we get hard links to any pages on the new site we need to link to and how to get localization? (Example: in the old site we could link with language=$language&country=$country in the url. Also, we need there to be redirects on the new site in case people have old links.

Change 437357 merged by jenkins-bot:
[mediawiki/extensions/DonationInterface@master] Change documentation variables and test to outline where changes are needed

https://gerrit.wikimedia.org/r/437357

@mepps - it was that /wiki/Special:LandingCheck did not have a redirect - the end pages did. That has been fixed. These should be working now.

We found some more broken links in the footer. We are sending all footer links to foundation wiki for now.

mepps added a comment.Jul 31 2018, 1:06 AM

@Varnent I just checked the FAQ redirect and it just goes to the generic about page. For tonight, to be consistent with donatewiki, we are sending all these pages to the foundationwiki and will be in touch in the morning to update all the links to the appropriate new pags in the morning.

mepps added a comment.Jul 31 2018, 1:07 AM

Currently, donatewiki is sending all links to foundation wiki, to clarify on my above comment.

Change 439592 merged by jenkins-bot:
[mediawiki/extensions/DonationInterface@master] Point all links to foundation.wikimedia.org

https://gerrit.wikimedia.org/r/439592

Which that should be on the new site are you having problems with? My understanding is that you did not want any of those pointing to the new site. They should all be either on Donate or Governance (foundation.wikimedia) wiki. Here is a ticket for the redirects in general on the new site: [T200754]

mepps added a comment.Jul 31 2018, 2:37 PM

I think @Pcoombe would know the specifics of which page should redirect where better than I would. But I am concerned that the FAQ is redirecting to the about page and that Tax Policy, Matching Gifts, Ways to Give, and cancel recurring have no redirects listed on that issue. Thanks for the quick follow up @Varnent!

Apologies for the confusion, I didn't realise the soft launch was going to break the existing foundationwiki links. Thanks for fixing them!

This is my understanding of where all the various things should end up pointing. @Varnent will there be a replacement for the FAQ on the new site? Or should we move that to donate.wikimedia.org as well?

I'm in the process of redirecting the existing foundation.wikimedia.org pages that have been moved to donatewiki (Problems donating, Ways to give, Cancel etc and Matching gifts). Then we can look through and update those links in any remaining code later.

Here's a Google Doc where I'm tracking the various links: https://docs.google.com/spreadsheets/d/1e9Axt32IGM-GNf4GbN0bGVBKPTZiSI5nnGvc8kj6YGs/edit#gid=0

mepps added a comment.Jul 31 2018, 3:00 PM

Thanks @Pcoombe! This looks pretty clear to me. @Ejegg Let's coordinate on updating the links on our end in the next couple of days.

The redirects are not honoring case sensitivity. I have asked the tech vendor to look into it.

@Varnent how long to do you plan to keep foundation.wikimedia.org up and running?

@DStrine - That is now Governance Wiki - which is where policies and such will be living now. So the site is not going away. However, any pages not marked for Governance Wiki will be deleted or moved to Meta-Wiki in the coming weeks.

Okay all the redirects are done, except for tax deductibility which can't be done until T200419: Interwiki entry for new Wikimedia Foundation website is resolved. I updated the tracking sheet too.

Krinkle removed a subscriber: Krinkle.Aug 2 2018, 3:40 PM
jgleeson reassigned this task from jgleeson to mepps.Aug 6 2018, 9:19 PM
DStrine moved this task from Doing to Done on the Fundraising Sprint Owls board.Aug 7 2018, 8:13 PM
DStrine moved this task from Done to Doing on the Fundraising Sprint Owls board.

Change 451191 had a related patch set uploaded (by Ejegg; owner: Ejegg):
[mediawiki/extensions/DonationInterface@master] Update defaults for 'Ways to give' and 'Problems donating'

https://gerrit.wikimedia.org/r/451191

Change 451191 merged by jenkins-bot:
[mediawiki/extensions/DonationInterface@master] Update defaults for 'Ways to give' and 'Problems donating'

https://gerrit.wikimedia.org/r/451191

Ejegg closed this task as Resolved.Aug 22 2018, 1:06 AM
Ejegg moved this task from Backlog to Done on the Fundraising Sprint Queue is pronounced GJif board.