Page MenuHomePhabricator

CX2: Show publish settings as a dialog with more detailed descriptions
Closed, ResolvedPublic

Description

Currently, publish settings just includes a very minimal menu to select the publishing destination:

As part of the larger effort to provide more detailed publish settings (T133862), the first step is to provide these settings as part of a modal dialog.

Considerations:

  • Translation title and destination options will be always in sync:
    • Changing the selection in the menu will update the article title.
    • Changing the translation title will keep the setting selection consistent.
  • The publish destination section will have a help icon ("helpNotice" icon) that will open the corresponding documentation page in a new tab/window.
  • Publish destinations will have descriptions.
  • The main namespace option will be labelled as "New page" by default, but as "Replace the existing page" if a page with such title already exists in the main namespace.
  • The option to publish in the Draft namespace, will be available only for those wikis where the draft namespace is available.
Default destinationsWhen page already exists

Text descriptions used:

Publish destination
New page / Replace the existing page
In the main namespace for everyone to read
Personal draft
Under your user namespace for you to improve
Community draft
In the draft namespace for the community to review and improve

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterChange label for main namespace in publish settings dialog when title exists
mediawiki/extensions/ContentTranslation : masterShow publish settings as a dialog

Event Timeline

Vvjjkkii renamed this task from CX2: Show publish settings as a dialog with more detailed descriptions to mnaaaaaaaa.Jul 1 2018, 1:03 AM
Vvjjkkii raised the priority of this task from Medium to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: Aklapper, gerritbot.
Petar.petkovic renamed this task from mnaaaaaaaa to CX2: Show publish settings as a dialog with more detailed descriptions.Jul 1 2018, 11:13 PM
Petar.petkovic lowered the priority of this task from High to Medium.
Petar.petkovic updated the task description. (Show Details)
Petar.petkovic added a subscriber: Aklapper.

We may want to consider to adjust the information on destinations hen an existing article exists, to make explicit that content will be overwritten.

Pginer-WMF updated the task description. (Show Details)Jan 7 2019, 2:09 PM
Pginer-WMF updated the task description. (Show Details)Jan 7 2019, 4:00 PM
Pginer-WMF removed a project: Design.

The publish destination section will have an information icon that will open the corresponding documentation page in a new tab/window.

The information icon usually opens an help context popup in OOUI. Having it open a whole new tab may be unexpected.

Pginer-WMF updated the task description. (Show Details)Jan 8 2019, 1:53 PM

The publish destination section will have an information icon that will open the corresponding documentation page in a new tab/window.

The information icon usually opens an help context popup in OOUI. Having it open a whole new tab may be unexpected.

Good catch, @Esanders. Using a popup was the original plan, but given the clarifications needed we opted to use a dedicated documentation page instead.
I think the help (?) icon may be better suited for this case. I've updated the designs. Thanks!

Minor note, the planned icon (from screenshots in task description) is the 'helpNotice' icon.

Pginer-WMF updated the task description. (Show Details)Jan 8 2019, 5:15 PM
Pginer-WMF updated the task description. (Show Details)Jan 16 2019, 11:06 AM
Pginer-WMF raised the priority of this task from Medium to High.Feb 18 2019, 9:51 AM
Petar.petkovic updated the task description. (Show Details)

Change 495162 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Show publish settings as a dialog

https://gerrit.wikimedia.org/r/495162

Change 495162 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Show publish settings as a dialog

https://gerrit.wikimedia.org/r/495162

Radio buttons should be vertically aligned to the top of their labels, as per the OOUI demo and T184526:

Radio buttons should be vertically aligned to the top of their labels, as per the OOUI demo and T184526:

I was thinking of these as compound elements (name+description) rather than one element overflowing in two lines. But it's probably not worth it to make an exception for this. Radio buttons aligned on top look good here too. I'll update the mockups to avoid confusions. Thanks for the feedback!

Pginer-WMF updated the task description. (Show Details)Apr 25 2019, 7:28 AM

On the patch, @Esanders has another question:

Should "Apply changes" be disabled if the radio hasn't been changed?

On the patch, @Esanders has another question:

Should "Apply changes" be disabled if the radio hasn't been changed?

Yes. That would be preferred. When supporting that we need to carefully check the case where the user changed the translation title to use a different namespace that is not covered by the dialog options. In that case, none of the radio buttons will be selected initially and selecting one should enable the "Apply changes" button.

Regarding the alignment, here is the comparison of the default style and overrides I did to make it look like on mock-ups:

Default styleOverridden styles

I was thinking of these as compound elements (name+description) rather than one element overflowing in two lines. But it's probably not worth it to make an exception for this. Radio buttons aligned on top look good here too. I'll update the mockups to avoid confusions. Thanks for the feedback!

Thanks, the more local style overrides we avoid the fewer regressions we get when OOUI changes :)

Change 495162 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Show publish settings as a dialog

https://gerrit.wikimedia.org/r/495162

After QA, this should be returned to In progress because

The main namespace option will be labelled as "New page" by default, but as "Replace the existing page" if a page with such title already exists in the main namespace

is still not completed.

The radio buttons look different in Chrome and FF (which I assume is ok):
Firefox:


Chrome

Returning to 'In Progress' according to @Petar.petkovic comment:

After QA, this should be returned to In progress because

The main namespace option will be labelled as "New page" by default, but as "Replace the existing page" if a page with such title already exists in the main namespace

is still not completed.

The radio buttons look different in Chrome and FF (which I assume is ok):
Firefox:


Chrome

Did you take screenshots from different wikis? There should not be difference between Chrome and Firefox on the same wiki and choosing draft namespace should only be an option for those wikis where the draft namespace is available, as the description says:

The option to publish in the Draft namespace, will be available only for those wikis where the draft namespace is available.

@Petar.petkovic - you're right! The difference that I saw in radio buttons only meant that the initial selection state (when clicked) then becomes a solid ring.

Change 507936 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Change label for main namespace in publish settings dialog when title exists

https://gerrit.wikimedia.org/r/507936

Change 507936 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Change label for main namespace in publish settings dialog when title exists

https://gerrit.wikimedia.org/r/507936

Etonkovidova closed this task as Resolved.May 7 2019, 11:24 PM

Checked in testwiki wmf.4.