Page MenuHomePhabricator

Bug: Order of some paragraphs is flipped on mobile
Closed, ResolvedPublic5 Story Points

Description

The lead paragraph transform sometimes moves content incorrectly.

Old example: Compare https://en.wikipedia.org/wiki/Arthur_Conan_Doyle and https://en.m.wikipedia.org/wiki/Arthur_Conan_Doyle. The two lead paragraphs are out of order on mobile, and the second paragraph appears above the infobox on small screens. There doesn't appear to be anything odd about the wikitext.

Report courtesy of jlebar on IRC.

New example: https://en.m.wikipedia.org/wiki/Surtsey

QA Steps

Please do all steps on beta cluster. Beta Cluster is configured to load articles from English Wikipedia when those are not present locally.

  • Please verify that Surtsey has first paragraph aligned correctly. The article should start with bold "Surtsey"

Beta cluster - fixed https://en.m.wikipedia.beta.wmflabs.org/wiki/Surtsey
Production broken: https://en.m.wikipedia.org/wiki/Surtsey
For reference - broken article on production https://en.wikipedia.org/wiki/Surtsey

QA Results

ACStatusDetails
1T201131#5374999

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 3 2018, 5:10 AM
Niedzielski renamed this task from Order of some paragraphs is flipped on mobile to Bug: Order of some paragraphs is flipped on mobile.Aug 3 2018, 4:00 PM

The two lead paragraphs are out of order on mobile

@ovasileva, this seems important. Can we pull it in soon?

ovasileva triaged this task as High priority.Aug 3 2018, 4:34 PM

agreed, this is bad.

pmiazga added a subscriber: pmiazga.Aug 3 2018, 7:51 PM

That's a bug, most probably introduced in T199282, I'm on it

Cirdan added a subscriber: Cirdan.Aug 5 2018, 12:34 PM

Change 450533 had a related patch set uploaded (by Pmiazga; owner: Pmiazga):
[mediawiki/extensions/MobileFrontend@master] When searching for lead paragraph, use context node instead of text()

https://gerrit.wikimedia.org/r/450533

Discussed this during standup today. We decided not to roll back the change currently and try to fix this. If we don't have a fix between now and Wednesday, Aug 8, it might be best to roll back the older change.

ovasileva set the point value for this task to 5.Aug 6 2018, 5:17 PM

Change 450533 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] When searching for lead paragraph, use context node instead of text()

https://gerrit.wikimedia.org/r/450533

@alexhollender, this is just a bug fix. Not sure if you want to check this out.

Unable to reproduce. Passing along to QA.

ABorbaWMF added a subscriber: ABorbaWMF.

Looks fixed to me on production.

Jdlrobson reassigned this task from Ryasmeen to ovasileva.Aug 20 2018, 11:45 PM
Jdlrobson added a subscriber: Ryasmeen.
ovasileva closed this task as Resolved.Aug 21 2018, 8:02 AM

Looks good!

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptAug 21 2018, 8:02 AM
HairyDude reopened this task as Open.May 20 2019, 1:00 AM
HairyDude added a subscriber: HairyDude.

I'm seeing this again at https://en.m.wikipedia.org/wiki/Surtsey .

Jdlrobson removed ovasileva as the assignee of this task.Jul 2 2019, 4:15 PM
Jdlrobson updated the task description. (Show Details)

Change 523301 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Lead paragraph should operate on elements which contain coordinates

https://gerrit.wikimedia.org/r/523301

Change 523301 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Lead paragraph should operate on elements which contain coordinates

https://gerrit.wikimedia.org/r/523301

Edtadros reassigned this task from Edtadros to pmiazga.Jul 24 2019, 4:25 PM
Edtadros added a subscriber: Edtadros.

@pmiazga where should I test this?

pmiazga reassigned this task from pmiazga to Edtadros.Mon, Jul 29, 5:42 PM
pmiazga updated the task description. (Show Details)
Edtadros added a comment.EditedTue, Jul 30, 12:27 AM

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

Test Artifact(s):

QA Steps

Please do all steps on beta cluster. Beta Cluster is configured to load articles from English Wikipedia when those are not present locally.

✅ AC1: Please verify that Surtsey has first paragraph aligned correctly. The article should start with bold "Surtsey"
Beta cluster - fixed https://en.m.wikipedia.beta.wmflabs.org/wiki/Surtsey

iPadiPhoneXPixel2GalaxyS5Nexus10GalaxyNote3
Edtadros updated the task description. (Show Details)Tue, Jul 30, 12:39 AM
Ryasmeen removed a subscriber: Ryasmeen.Tue, Jul 30, 2:53 PM

The changes and the QA LGTM and I'd be happy to sign this off. However, the changes will be deployed to enwiki this Thursday so I'm inclined to wait and double-check the page in production.

Jdlrobson closed this task as Resolved.Fri, Aug 2, 6:18 PM
Jdlrobson added a subscriber: Jdlrobson.

I've double checked this on production:
https://en.m.wikipedia.org/wiki/Surtsey
Paragraph order is correct.
Same goes for https://en.m.wikipedia.org/wiki/Arthur_Conan_Doyle