Page MenuHomePhabricator

Random failures for several Flow tests
Closed, ResolvedPublic

Description

Several Flow tests fail randomly, see traces below; a recheck always solves the problem.

08:42:12 1) Flow\Tests\Collection\PostCollectionTest::testGetFirstRevision
08:42:12 Failed asserting that false is true.
08:42:12 
08:42:12 /workspace/src/extensions/Flow/tests/phpunit/Collection/PostCollectionTest.php:90
08:42:12 /workspace/src/tests/phpunit/MediaWikiTestCase.php:424
08:42:12 /workspace/src/maintenance/doMaintenance.php:94
23:02:04 1) Flow\Tests\Api\ApiFlowModerateTopicTest::testModerateLockedTopic
23:02:04 Wikimedia\Rdbms\DBQueryError: A database query error has occurred. Did you forget to run your application's database schema updater after upgrading? 
23:02:04 Query: INSERT  INTO `unittest_flow_revision` (rev_id,rev_user_id,rev_user_ip,rev_user_wiki,rev_parent_id,rev_change_type,rev_type,rev_type_id,rev_content,rev_flags,rev_mod_state,rev_mod_user_id,rev_mod_user_ip,rev_mod_user_wiki,rev_mod_timestamp,rev_mod_reason,rev_last_edit_id,rev_edit_user_id,rev_edit_user_ip,rev_edit_user_wiki,rev_content_length,rev_previous_content_length) VALUES ('�z#p�4:��','1',NULL,'wikidb-unittest_','�z#p��4:��','delete-topic','post','�z#p��4:��','Hi there!','utf-8,topic-title-wikitext','delete','1',NULL,'wikidb-unittest_','20181116215905','<>&{};',NULL,NULL,NULL,NULL,'0','9')
23:02:04 Function: Flow\Data\Storage\RevisionStorage::insert
23:02:04 Error: 1062 Duplicate entry '\x05\x9Cz#p\xA3\xFE4:\x9C\xED' for key 'flow_revision_unique_parent' (/workspace/db/quibble-mysql-a08yeqot/socket)

Event Timeline

Daimona created this task.Oct 16 2018, 1:39 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 16 2018, 1:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Reedy updated the task description. (Show Details)Oct 19 2018, 12:47 PM

Flaky tests maybe, experienced this behavior today on this patch: https://gerrit.wikimedia.org/r/c/mediawiki/core/+/468553. "recheck" solved it too!

Daimona triaged this task as High priority.Oct 23 2018, 11:55 AM

Again: https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/AbuseFilter/+/469184/
This is nasty, and even if the cause may not be easy to understand, the test should at least be included in @Broken until it's fixed.

Change 469208 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/Flow@master] Mark a flaky test as broken

https://gerrit.wikimedia.org/r/469208

It can also fail on Flow\Tests\Collection\PostCollectionTest::testGetLastRevision

https://integration.wikimedia.org/ci/job/wmf-quibble-vendor-mysql-php70-docker/2588/console

Change 469208 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Mark a flaky test as broken

https://gerrit.wikimedia.org/r/469208

Change 472263 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/Flow@master] Temporarily mark flaky tests as broken

https://gerrit.wikimedia.org/r/472263

Change 472263 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Temporarily mark flaky tests as broken

https://gerrit.wikimedia.org/r/472263

Change 472456 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/Flow@REL1_32] Temporarily mark flaky tests as broken

https://gerrit.wikimedia.org/r/472456

Daimona renamed this task from Random test failures for Flow\Tests\Collection\PostCollectionTest::testGetFirstRevision to Random failures for several Flow tests.Nov 27 2018, 6:48 PM
Daimona updated the task description. (Show Details)
Daimona added subscribers: hashar, kostajh.

Change 475364 had a related patch set uploaded (by D3r1ck01; owner: Alangi Derick):
[mediawiki/extensions/Flow@master] Mark flaky PostCollectionTest::testGetLastRevision() test as broken

https://gerrit.wikimedia.org/r/475364

Change 475364 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Mark flaky PostCollectionTest::testGetLastRevision() test as broken

https://gerrit.wikimedia.org/r/475364

D3r1ck01 closed this task as Resolved.Dec 2 2018, 7:18 AM
D3r1ck01 claimed this task.

Change 472456 abandoned by Kosta Harlan:
Temporarily mark flaky tests as broken

Reason:
No comments/activity on this so I assume it's not needed anymore.

https://gerrit.wikimedia.org/r/472456

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:08 PM
Restricted Application added a project: User-D3r1ck01. · View Herald TranscriptAug 28 2019, 11:08 PM