Page MenuHomePhabricator

Create a UI for Translating title descriptions (within the App Editor Tasks list)
Closed, ResolvedPublic5 Story Points

Description

Why are we doing this?

Encourage Android app users to start editing by presenting them with more opportunities to make ‘micro-contributions’ to the app.

User story

As a Multilingual Wikipedia user: When I have proven myself as an editor of good standing, I want to be shown articles with a title description that can be translated into other languages I speak, so that I can grow my contributions to Wikipedia.

For this ticket, do "first time message for translating title descriptions" "Translate title descriptions feed" "review title description" "overflow menu"

Flows

Interactive flow chart | Download flow chart

Mocks

Unlock messageFirst time message for translating title descriptionsApp editor task with new task unlockedTranslate title descriptions feedTranslate title descriptions interfaceReview title descriptionOverflow menuContribution score card

To dos

  • Illustration for unlock message
  • Illustration for first time message for translating title descriptions
  • Copy for unlock message
  • Copy for first time message for translating title descriptions
  • Language CAPTCHA

Event Timeline

cmadeo updated the task description. (Show Details)Oct 18 2018, 6:08 PM
Charlotte triaged this task as Normal priority.Dec 5 2018, 7:07 PM
Charlotte updated the task description. (Show Details)
Charlotte set the point value for this task to 5.
Charlotte raised the priority of this task from Normal to High.Dec 5 2018, 7:26 PM
cooltey removed cooltey as the assignee of this task.Dec 7 2018, 4:47 PM
cooltey added a subscriber: cooltey.

Change 480703 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] UI for Translating title descriptions

https://gerrit.wikimedia.org/r/480703

Change 482346 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] UI updates to translations editing

https://gerrit.wikimedia.org/r/482346

Change 480703 merged by jenkins-bot:
[apps/android/wikipedia@master] UI for Translating title descriptions

https://gerrit.wikimedia.org/r/480703

Change 482346 merged by jenkins-bot:
[apps/android/wikipedia@master] UI updates to translations editing

https://gerrit.wikimedia.org/r/482346

Dbrant added a subscriber: Dbrant.Jan 8 2019, 9:36 PM

@Sharvaniharan This still seems to be missing the functionality seen in the first three "mock" images. Will you take care of them?

Change 483011 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] Updated text for first time title description editing

https://gerrit.wikimedia.org/r/483011

Change 483034 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] Updated text for first time title description editing

https://gerrit.wikimedia.org/r/483034

Change 483011 abandoned by Sharvaniharan:
Updated text for first time title description editing

https://gerrit.wikimedia.org/r/483011

Change 483037 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] [WIP] Edit Tasks Activity UI tweak

https://gerrit.wikimedia.org/r/483037

Hey @Dbrant and @Sharvaniharan; I talked to Rita and Carolyn about when to show the unlock message for translating title descriptions. Below is described what they’ve envisioned:

Behavior for the user test:

After one title description edit in any language, the “Add title descriptions” task is unlocked and the “Translate title descriptions” task is shown in the list but is locked. One more title description edit (the 2nd) will then trigger a dialog which says that “Translating title descriptions have been unlocked”. This dialog is only needed for the prototype and user test, otherwise there is no visible incentive for users that they’ve unlocked something. The previously locked task (“Translate title descriptions”) would then be unlocked as well.

Copy for this dialog, according to Missing copy for app editor tasks document is:

You can now help to improve Wikipedia by translating the captions that appear on images in articles. You can configure your languages and set a translation direction at any time.

Intended behavior at a later stage:

After 50* valid title description edits in any language, the “Add title descriptions” task is unlocked and the “Translate title descriptions” task is shown in the list but is locked. When users are tapping on “Translate title descriptions“ they will be confronted with the language test/assessment, which is defined in T207684 (work in progress). The previously locked task (“Translate title descriptions”) will then be unlocked, as soon as the language test has been completed successfully.

The dialog as described in “Behavior for the user test“ above would not exist in that sense. There will be a message after successfully completing the language test/assessment (which currently looks like this but is work in progress)

--> * Rita’s comment about the number 50 (edits) on Slack:

The proposed 50 non-reverted edits for adding title descriptions was in the [[ https://docs.google.com/presentation/d/1b7-FeIdFnDrKG1ko8SbOi_EVhYzx-LON3RdyCDlrBbA/edit#slide=id.g338789738e_0_308 | Edit Action Queue deck ]]that I put together. However I would say that was just a number I pulled from the air and should be variable.


Let me know if you have any questions or if something’s unclear.

Dbrant removed a subscriber: Dmitry89.Jan 9 2019, 4:57 PM
cmadeo added a comment.Jan 9 2019, 7:02 PM

Hi! Just wanted to drop in here to document what we discussed in stand up this morning. @schoenbaechler, if you wouldn't mind double checking this that would be awesome!

For the usability test

In the meeting we discussed having users add a new language from the edit action queue main page (see the final feature mock for users with only one app language). but perhaps it would be easier to have them add a second language in on boarding so they can automatically get the notification to translate after their second edit?


For the final feature

Users who have two or more app languages when they unlock the Edit action queue


Users will need to tap on the locked task types to trigger the language CAPTCHA. Upon successfully completing the language CAPTCHA they will be able to access any translation tasks for tasks that have already been unlocked (eg. under 50 edits they will only have access to title description and title description translation, when they unlock image captions they will also unlock image caption translation).

Users who only have one app language when they unlock the Edit action queue


Users who only have one app language will see this screen. Adding a new language will add the language to their app languages and they will then be prompted to complete the language CAPTCHA

schoenbaechler added a subscriber: dchen.EditedJan 10 2019, 11:28 AM

Thanks @cmadeo for summarizing. The described concept sounds good. In regards to your question and the usability test:

(...) but perhaps it would be easier to have them add a second language in on boarding so they can automatically get the notification to translate after their second edit?

Agreed, it makes sense to instruct users to set a second language in on boarding so the dialog below can be triggered after the second edit (CC @dchen)

You can now help to improve Wikipedia by translating the captions that appear on images in articles. You can configure your languages and set a translation direction at any time.


@Sharvaniharan:

You mentioned that some assets are missing in standup yesterday, I added an additional screen to Zeplin which contains them:

https://app.zeplin.io/project/57a120b91998d8977642a238/screen/5c371efa13f68729797cef01

In regards to the missing copy, here are my suggestions:

First time message for adding title descriptions
You can now help to improve Wikipedia by adding descriptions that appear below titles in articles. You can configure your languages at any time.

First time message for adding caption translations
You can now help to improve Wikipedia by adding the captions that appear on images in articles. You can configure your languages at any time.

Also added it in the Missing copy for app editor tasks document.

Change 483037 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] Edit Tasks Activity UI tweak

https://gerrit.wikimedia.org/r/483037

Change 483822 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] Dialog images updated

https://gerrit.wikimedia.org/r/483822

Change 483034 merged by jenkins-bot:
[apps/android/wikipedia@master] Updated text for first time title description editing

https://gerrit.wikimedia.org/r/483034

Change 483822 merged by jenkins-bot:
[apps/android/wikipedia@master] Dialog images updated

https://gerrit.wikimedia.org/r/483822

Change 483872 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] Higher priority to editing unlocked dialog than toc tooltip

https://gerrit.wikimedia.org/r/483872

Change 483037 merged by jenkins-bot:
[apps/android/wikipedia@master] Edit Tasks Activity UI tweak

https://gerrit.wikimedia.org/r/483037

Change 483913 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] Translation unlock logic

https://gerrit.wikimedia.org/r/483913

Change 483872 merged by jenkins-bot:
[apps/android/wikipedia@master] Higher priority to editing unlocked dialog than toc tooltip

https://gerrit.wikimedia.org/r/483872

Change 483913 merged by jenkins-bot:
[apps/android/wikipedia@master] Translation unlock logic

https://gerrit.wikimedia.org/r/483913

The translation unlock logic is solely based on the number of user edits being more than 1 [2 or more], which causes these conflicts:
"1. What happens if the user unlocks the edit feed by making the very first edit, sees unlock dialog, hits ‘Maybe later’ and goes on to read few more articles and along the way makes description edits? Let us say user made 3 edits.
Now the indicator dot is seen, the user visits the edit feed page,
A. Should both title and translate description options be unlocked and available now?
B. If user hits on ‘Add Title Descriptions’ , both first time title edit dialog and translate unlock dialog are now waiting to be shown. Should they both be shown one after the other? Should the translate unlock not appear? Should translate unlocked dialog have appeared anywhere wherever the 2nd edit was made?
C. What happens if the user enters the edit feed, chooses not to hit 'Add Title Descriptions’ , but hits ‘Translate Title Descriptions’ which will now be unlocked. When they next visit 'Add Title Descriptions’ obviously the translate unlock dialog doesn't make sense, so should we include logic to track that and not show translation unlock dialog?"

these questions need to be answered and rectified before production release.

Change 486437 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] Remove unused preference

https://gerrit.wikimedia.org/r/486437

Change 486438 had a related patch set uploaded (by Sharvaniharan; owner: Sharvaniharan):
[apps/android/wikipedia@master] [WIP] Update edit feed logic

https://gerrit.wikimedia.org/r/486438

Moving this back to the “Needs Design/Design doing“ column since there will be modifications to the flow/screens based on feedback from usability testing.

Change 486437 merged by jenkins-bot:
[apps/android/wikipedia@master] Remove unused preference

https://gerrit.wikimedia.org/r/486437

Change 486438 abandoned by Sharvaniharan:
Update edit feed logic

Reason:
Moved to github

https://gerrit.wikimedia.org/r/486438

This is a legacy task for “Editor tasks“ prototype. All changes will be addressed in T215630. Moving this to “Ready for signoff“.

Dbrant closed this task as Resolved.Mar 6 2019, 7:12 PM