Page MenuHomePhabricator

Log spam: "User account is not global"
Closed, ResolvedPublic

Description

Error

Request ID: AWmgsnYsNBo9dX1koRDW

message
User account is not global
trace
#0 /srv/mediawiki/php-1.33.0-wmf.22/extensions/ContentTranslation/api/ApiQueryTranslatorStats.php(27): ContentTranslation\Translator->getGlobalUserId()
#1 /srv/mediawiki/php-1.33.0-wmf.22/includes/api/ApiQuery.php(249): ApiQueryTranslatorStats->execute()
#2 /srv/mediawiki/php-1.33.0-wmf.22/includes/api/ApiMain.php(1595): ApiQuery->execute()
#3 /srv/mediawiki/php-1.33.0-wmf.22/includes/api/ApiMain.php(531): ApiMain->executeAction()
#4 /srv/mediawiki/php-1.33.0-wmf.22/includes/api/ApiMain.php(502): ApiMain->executeActionWithErrorHandling()
#5 /srv/mediawiki/php-1.33.0-wmf.22/api.php(87): ApiMain->execute()
#6 /srv/mediawiki/w/api.php(3): include(string)
#7 {main}

Impact

Logspam

Notes

Missing checks in action=query&list=(contenttranslationsuggestions|cxtranslatorstats)

Event Timeline

zeljkofilipin triaged this task as Unbreak Now! priority.
Restricted Application added subscribers: Liuxinyu970226, TerraCodes, Aklapper. · View Herald TranscriptMar 21 2019, 2:46 PM

I'm not sure if this is a new problem, but I could not find it in Phabricator (https://phabricator.wikimedia.org/search/query/90yLC89nlgsb/#R). 🤔

ApiQueryTranslatorStats.php(27) was last changed in 2017 by @Legoktm (https://phabricator.wikimedia.org/diffusion/ECTX/browse/master/api/ApiQueryTranslatorStats.php$27), but it was just a whitespace cleanup (https://phabricator.wikimedia.org/rECTX8f41719471d52cd172de65fbc393e4e85b9d9ac6)

It seems this affects list=cxtranslatorstats for logged out users and causes logspam, but likely no other impact. Likely caused by bot activity as there is no referrer and the API params make no sense.

Nikerabbit renamed this task from User account is not global to Log spam: "User account is not global" .Mar 21 2019, 3:58 PM
Nikerabbit updated the task description. (Show Details)

Change 498151 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Catch "User account is not global" error

https://gerrit.wikimedia.org/r/498151

Change 498156 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Return API error on anonymous suggestions queries

https://gerrit.wikimedia.org/r/498156

Change 498156 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Return API error on anonymous suggestions queries

https://gerrit.wikimedia.org/r/498156

Change 498151 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Catch "User account is not global" error

https://gerrit.wikimedia.org/r/498151

Worth back-porting? Logspam level looks manageable.

Given this was marked as train blocker, I would recommend backporting to avoid false alarms, but I'm leaving the decision to train drivers.

greg added a subscriber: greg.Mar 21 2019, 10:49 PM

Given this was marked as train blocker, I would recommend backporting to avoid false alarms, but I'm leaving the decision to train drivers.

let's go ahead and backport unless there's other reasons not to (iow: let's default to keeping logspam to a minimum/fix it as it comes).

Change 498259 had a related patch set uploaded (by Jforrester; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@wmf/1.33.0-wmf.22] Return API error on anonymous suggestions queries

https://gerrit.wikimedia.org/r/498259

Change 498260 had a related patch set uploaded (by Jforrester; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@wmf/1.33.0-wmf.22] Catch "User account is not global" error

https://gerrit.wikimedia.org/r/498260

Change 498259 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@wmf/1.33.0-wmf.22] Return API error on anonymous suggestions queries

https://gerrit.wikimedia.org/r/498259

Mentioned in SAL (#wikimedia-operations) [2019-03-21T23:32:24Z] <jforrester@deploy1001> Synchronized php-1.33.0-wmf.22/extensions/ContentTranslation/api/ApiQueryContentTranslationSuggestions.php: SWAT T218902 CX: Return API error on anonymous suggestions queries (duration: 00m 51s)

Change 498260 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@wmf/1.33.0-wmf.22] Catch "User account is not global" error

https://gerrit.wikimedia.org/r/498260

Jdforrester-WMF closed this task as Resolved.Mar 22 2019, 12:06 AM

Deployed.