Page MenuHomePhabricator

Getting error message when filtering by certain 'Wiki Loves Monuments' Commons categories
Closed, ResolvedPublicBUG REPORT

Description

I'm getting an error message when I try to test Category filtering without Participants for events based on certain Commons categories. (Other Commons categories work just fine, btw.)

Steps to Reproduce:

  • Go to the testing event "Images from Wiki Loves Monuments 2018 in Brazil" , which is a year-long event that uses as its filter the category by the same name.
  • Click Update
  • Expected results: get the metrics
  • Actual results: the "Something went wrong" error message comes up pretty quickly—too quickly to be about the size of the category, I think, which is about 2800 images.

I get the same result for a similarly constructed event, Images from Wiki Loves Monuments 2018 in Switzerland

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 21 2019, 4:34 PM

Technical notes for developers: this fails because it tries to get the domain of the affected wikis, but that method will only return the domain if the wiki in question is supported by Event Metrics. This is normally what we want (say when adding wikis in the Event Settings, or categories), but in this case we're trying to get pageviews of pages that use the image, so it needs to go through any and all wikis that are using that image. So basically, fixing this will require some minor refactoring.

MusikAnimal moved this task from Ready to In Development on the Community-Tech-Sprint board.

Merged. I think whatever QA is needed for this would be part of T205734. Moving to product sign-off. This ticket is about ensuring the update doesn't fail completely (an "unknown" failure that is, not a timeout). Any other bugs discovered should be bundled in with T205734.

jmatazzoni closed this task as Resolved.Mar 26 2019, 8:46 PM
jmatazzoni moved this task from Product sign-off to Q3 2018-19 on the Community-Tech-Sprint board.

I tested this on a new event that combines BOTH of the previously failing categories in one, Images from Wiki Loves Monuments 2018 in Brazil and Switzerland.

The event, with a combined total of 5,248 images, updated successfully in about 15 seconds. Brazil and Switzerland—two great countries, better together!

@dom_walden, I'm Resolving this, and we can now move on to do some exploratory testing. E.g., how close to the 50K item limit can we get before we hit a timeout...