Page MenuHomePhabricator

Homepage: link to "Guidelines for user pages" leads to desktop version
Closed, ResolvedPublic

Description

The link to "Guidelines for user pages" in the mobile start module leads to desktop version of the Wikipedia:User_pages, Should link to mobile version of the page instead.

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterHomepage guidelines link: go to desktop or mobile as appropriate

Event Timeline

SBisson created this task.Jun 12 2019, 7:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 12 2019, 7:02 PM

Change 516657 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/GrowthExperiments@master] Homepage guidelines link: go to desktop or mobile as appropriate

https://gerrit.wikimedia.org/r/516657

MMiller_WMF renamed this task from The link to "Guidelines for user pages" in the start module leads to desktop version of the Wikipedia:User_pages, Should link to mobile version of the page instead. to Homepage: link to "Guidelines for user pages" leads to desktop version.Jun 12 2019, 10:11 PM
MMiller_WMF updated the task description. (Show Details)
MMiller_WMF added subscribers: Catrope, kostajh, Cntlsn and 4 others.

I'm not able to reproduce this on betalabs.

@Etonkovidova if you reported this initially. Can you clarify what you did?

Etonkovidova closed this task as Invalid.Jun 13 2019, 5:50 PM

Checked in betalabs on iPhone - the link to "Guidelines for user pages" opens a mobile page.

Change 516657 abandoned by Sbisson:
Homepage guidelines link: go to desktop or mobile as appropriate

Reason:
Appears to work well without it in production.

https://gerrit.wikimedia.org/r/516657

@SBisson I reported it, and it's still happening on Safari iOS 10. However I can't reproduce in any other version of Safari and Safari iOS.
Here is the console output

Failed to set referrer policy: The value 'origin-when-crossorigin' is not one of 'no-referrer', 'origin', 'no-referrer-when-downgrade', or 'unsafe-url'. Defaulting to 'no-referrer'.

Wikipedia:User_pages:22
Failed to set referrer policy: The value 'origin-when-crossorigin' is not one of 'no-referrer', 'origin', 'no-referrer-when-downgrade', or 'unsafe-url'. Defaulting to 'no-referrer'.

Wikipedia:User_pages:23
Etonkovidova added a comment.EditedJun 14 2019, 7:17 AM

@Cntlsn - the errors about Referrer Policy (and Content Security Policy) are persistently displayed for betalabs environment (they've been there for a very long time). The links behavior are unaffected by them.

MMiller_WMF reopened this task as Open.EditedJun 14 2019, 6:31 PM

Re-opening because we are seeing this in a supported browser. @Cntlsn -- could you please attach a video of this happening? I am removing this from the MVP "Blocker" list and putting it in the "Desired" list because it is only in one browser.

Change 516657 restored by Sbisson:
Homepage guidelines link: go to desktop or mobile as appropriate

https://gerrit.wikimedia.org/r/516657

@Cntlsn and I tested this together and the patch above (or some other solution) is needed for the link to correctly land on the mobile version on his phone.

@Cntlsn and I tested this together and the patch above (or some other solution) is needed for the link to correctly land on the mobile version on his phone.

Correction: we tested it again and what really fixes it is not the patch but using the browser's incognito mode.

I think this situation can happen in beta but not in production.

In beta, the link navigates between 2 different sites. You start on beta enwiki and land on production enwiki where the real userpage guidelines are. If you had previously forced enwiki to be in desktop mode using the "desktop" link at the bottom of the page, it is going to render in desktop mode, even if you are coming from enwiki beta in mobile mode.

In production, the link always navigate to the same site. If you are looking at the homepage in kowiki, the link will redirect you to the userpage guidelines on kowiki, keeping the same mobile mode.

The intermediate step on wikidata doesn't seem to matter. I have tried forcing wikidata to desktop and going through it on mobile still works.

Change 516657 abandoned by Sbisson:
Homepage guidelines link: go to desktop or mobile as appropriate

https://gerrit.wikimedia.org/r/516657

nray moved this task from Needs triage to Triaged on the Mobile board.Jul 1 2019, 5:57 PM

I just tried this from my phone in Czech Wikipedia, and the link opened the desktop version. See this video: https://drive.google.com/file/d/1YhvySOw8R04IWJOwSV4xyFiJDqJygehC/view

This is an iPhone 6S with iOS 12.2 and Safari 12. Not in private browsing mode. Please let me know if any other details would be helpful.

kostajh removed SBisson as the assignee of this task.Jul 28 2019, 4:08 PM

Unassigning Stephane (although feel free to reclaim if you'll work on it)

Change 516657 restored by Kosta Harlan:
Homepage guidelines link: go to desktop or mobile as appropriate

https://gerrit.wikimedia.org/r/516657

Change 516657 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Homepage guidelines link: go to desktop or mobile as appropriate

https://gerrit.wikimedia.org/r/516657

My testing verifies what @SBisson wrote in the following comment:

If you had previously forced enwiki to be in desktop mode using the "desktop" link at the bottom of the page, it is going to render in desktop mode, even if you are coming from enwiki beta in mobile mode.

@MMiller_WMF - the link to the video is marked as unavailable. Moving to your column so that you can check the fix additionally; it could be some you specific browser setting (or some other settings) that make the link go to the page in desktop mode.

MMiller_WMF closed this task as Resolved.Aug 2 2019, 5:16 AM

This is now opening for me in mobile view. Thank you!