Page MenuHomePhabricator

[Pre-deployment bug] While trying to change label for a link in Edit card V2 the page scrolls up making the link go out of view on iOS 11
Closed, ResolvedPublic

Description

Steps to replicate:

  1. Click on a link on our prototype server.
  2. Click on the first pencil on the Edit card, and wait
  3. After few seconds, the page scrolls up making the link go out of view

Also, the selection appears on top of the toolbar at this point
Found this issue on iOS Safari on iPhone 5s.

Here is a video capture showing the issue:

Event Timeline

Ryasmeen created this task.Jul 9 2019, 10:35 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 9 2019, 10:35 PM

I could reproduce this on my iOS 9 device, but not my newer one. What version are you testing on?

It also looks like it might be related to some of @matmarex's iOS scrolling hacks?

I could reproduce this on my iOS 9 device, but not my newer one. What version are you testing on?

@Esanders: This was on iOS 11.

I can't reproduce on iPhone SE running iOS 12. So the problem is probably triggered by the different OS version, rather than screen size.

I don't have any devices running older iOS to test with…

It also looks like it might be related to some of @matmarex's iOS scrolling hacks?

Probably.

We could always disable the iOS scrolling hacks on older OS versions, if we feel that this issue is more annoying that the toolbar not always staying in view.

@Ryasmeen We just changed the label selection to be collapsed for a different task. Can you confirm this is still happening on your iOS11 device, as I can only reproduce scrolling issues on iOS9 now?

@Esanders: I am still getting this issue on iOS11.

We should just limit the iOS fixed toolbar workarounds to iOS 12+.

This means that on devices running iOS 11 or older, when you open the keyboard, our edit toolbar may not stay fixed at the top of the screen. This isn't ideal, but it's a more acceptable degradation than the weird uncontrollable scrolling that happens now, and we don't have the resources to search for workarounds for all old iOS versions.

Change 526235 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] MobileArticleTarget: Limit iOS fixed toolbar workarounds to iOS 12+

https://gerrit.wikimedia.org/r/526235

I'm not yet 100% convinced this is an iOS version issue and not a screen size issue. I've reproduced on my smaller iPod touch running iOS9, and Rumanna has on her iPhone 5s running iOS11, but I can't reproduce on crossbrowsertesting using iOS11 and a bigger iPhone.

The hacks also don’t work correctly on iOS 13: T233470

Change 526235 abandoned by Bartosz Dziewoński:
MobileArticleTarget: Limit iOS fixed toolbar workarounds to iOS 12 only

Reason:
Workarounds were fixed properly by https://gerrit.wikimedia.org/r/547365

https://gerrit.wikimedia.org/r/526235

matmarex renamed this task from [Pre-deployment bug] While trying to change label for a link in Edit card V2 the page scrolls up making the link go out of view to [Pre-deployment bug] While trying to change label for a link in Edit card V2 the page scrolls up making the link go out of view on iOS 11.Nov 5 2019, 11:09 PM

Apparently the patch for iOS 13 (T233470) fixes this too:

@ppelberg: So the device I thought was running iOS 12, is actually running iOS 11. But the good news is, it seems to be working perfectly on iOS 11 as well, just like how it behaves on iOS 13: it scrolls out of view when scrolling down the page, but it reappears (slides in) after a moment. I was under the impression (from reading @matmarex's comment) that it won't work that way on iOS 11. So that's good.

Ryasmeen edited projects, added Verified; removed Patch-For-Review.Nov 7 2019, 8:50 PM
ppelberg closed this task as Resolved.Dec 24 2019, 7:16 PM
ppelberg claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptDec 24 2019, 7:16 PM