Page MenuHomePhabricator

Homepage: Allow experienced users to claim mentees
Closed, ResolvedPublic

Description

I would like to propose to allow experienced users to claim their mentees, in additional to the random thing that's currently working. Questions from users that are participating in wiki-courses actually happened (at least https://cs.wikipedia.org/w/index.php?title=Diskuse_s_wikipedistou:Martin_Urbanec&diff=17481782&oldid=17479745), and in this particular case, the instructor/wiki ambassador for that project actually was upset that their course participant is asking somebody else. Yes, the answer should be more-or-less the same anyway, but that's not on topic here.

Draft business rules

This feature should at least:

  • Warn experienced users if they are going to change mentor for the second/third time.
  • Warm mentors that they have changed mentor
  • Log changes to prevent abuse (hiding the log to admins is fine if necessary due to Privacy)
  • ...?

Notes

@MMiller_WMF, could this be priorized, please? I believe I mentioned this on our meetings. I consider this quite important, and since what I was worrying about has actually happened, I think we should really consider to do this as a major improvement for cs.wikipedia.

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterClaimMentee: Add GENDER to a few more strings
mediawiki/extensions/GrowthExperiments : masterClaimMentee: Don't show confirm box when username is invalid
mediawiki/extensions/GrowthExperiments : masterChangeMentor: Handle cases where no previous mentor existed
mediawiki/extensions/GrowthExperiments : masterClaimMentee: Don't allow fatal errors if mentors page is misconfigured
mediawiki/extensions/GrowthExperiments : masterAllow experienced users to claim mentees

Event Timeline

Urbanecm created this task.Jul 16 2019, 8:15 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 16 2019, 8:15 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Trizek-WMF updated the task description. (Show Details)Jul 17 2019, 9:36 AM
Trizek-WMF added a subscriber: Trizek-WMF.

I've added a not about warning mentees.

Also, have a way to change mentors would be a nice way to give a new mentor to an active newcomer if their current mentor is not available anymore. This would replace a long-term mentorship program. OTOH, a newcomer able to ask for a new mentor is capable to find a way to ask for help.

Urbanecm added a comment.EditedJul 17 2019, 1:52 PM

I've added a not about warning mentees.

Your rule says "Warm (sic!) mentors that they changed mentor". Not sure what does that mean, could you explain?

Also, have a way to change mentors would be a nice way to give a new mentor to an active newcomer if their current mentor is not available anymore. This would replace a long-term mentorship program. OTOH, a newcomer able to ask for a new mentor is capable to find a way to ask for help.

+1.

kostajh added a subscriber: kostajh.

Moving to discussion/analysis; when the specifications for this are sorted out @MMiller_WMF could decide which quarter this task belongs to.

Your rule says "Warm (sic!) mentors that they changed mentor". Not sure what does that mean, could you explain?

Without typos or misses, it means "Warn mentees that they changed mentor".

@Urbanecm -- thanks for filing this. I see this idea as part of a larger idea to integrate the newcomer homepage with community programs. I think a great flow would be if a user takes the welcome survey, says they're part of a program, and then ends up looking at a newcomer homepage all about that program, including a mentor who is part of the contest. We'll think about that as the newcomer homepage gets more advanced. In particular, we want to see how newcomers interact with mentors, and whether they develop ongoing relationships with mentors, or if they just ask one question.

I'm putting this in Q2 for us to think about.

Working on this on Wikimania-Hackathon-2019 per @MMiller_WMF's suggestion.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptAug 14 2019, 10:03 AM

Change 530105 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/extensions/GrowthExperiments@master] [wip] Allow experienced users to claim mentees

https://gerrit.wikimedia.org/r/530105

Urbanecm moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.
Urbanecm added a subscriber: RHo.

I shown what I build at the hackathon to @RHo and @Trizek-WMF, and I got to the state when I got no suggestions on what to improve from that. I guess this is ready for code review then!

RHo added a comment.Aug 17 2019, 1:15 PM

Hi @Urbanecm - here's an icon for the notification (ltr and rtl versions)

Thanks a lot, @RHo!

Dyolf77_WMF added a comment.EditedOct 15 2019, 2:50 PM

Hi @RHo , I think the shield is protecting the heart so no matter if rtf or ltr, for its place, but the question mark is correct for rtl icon.

Hi @RHo , I think the shield is protecting the heart so no matter if rtf or ltr, for its place, but the question mark is correct for rtl icon.

As someone using shields time to time, I agree.

RHo added a comment.Oct 18 2019, 11:33 AM

ahh good call, I've updated it the RTL version here:

(png@2x)

I just left a review, thanks for keeping with this @Urbanecm.

Change 565243 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] ClaimMentee: Don't allow fatal errors if mentors page is misconfigured

https://gerrit.wikimedia.org/r/565243

Change 565264 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] ChangeMentor: Handle cases where no previous mentor existed

https://gerrit.wikimedia.org/r/565264

Change 565266 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] ClaimMentee: Don't show confirm box when username is invalid

https://gerrit.wikimedia.org/r/565266

Change 565293 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] ClaimMentee: Add GENDER to a few more strings

https://gerrit.wikimedia.org/r/565293

Change 530105 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Allow experienced users to claim mentees

https://gerrit.wikimedia.org/r/530105

Change 565243 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] ClaimMentee: Don't allow fatal errors if mentors page is misconfigured

https://gerrit.wikimedia.org/r/565243

Change 565264 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] ChangeMentor: Handle cases where no previous mentor existed

https://gerrit.wikimedia.org/r/565264

Change 565266 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] ClaimMentee: Don't show confirm box when username is invalid

https://gerrit.wikimedia.org/r/565266

Change 565293 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] ClaimMentee: Add GENDER to a few more strings

https://gerrit.wikimedia.org/r/565293

Etonkovidova added a subscriber: Etonkovidova.

Checked in betlabs - no issues found.

How it works:

  • If a user is a mentor (the user name is on Wikipedia:Mentors page), a user is able to see the form on Special:ClaimMentee page.


If a user is not a mentor, the Special:ClaimMentee page will inform a user that it's required to add a user name to Wikipedia:Mentors page.

  • a mentor can successfully claim a mentee and a mentee will be re-assigned.
  • both - a mentor and a new mentee will resceive echo notifications -

a mentee's echo notification


RTL version

  • it's recorded in Special:Log/growthexperiments log and displayed in RecentChanges
  • the user name validation is in place

for invalid user names "Provided mentee's username is invalid"
for claiming a user that you're already a mentor "You already mentor ET233" (should we additionally check for phrasing here?)
Note: there is no warning when a mentor claims the second/third mentees

Trizek-WMF added a comment.EditedJan 22 2020, 11:32 AM

Quick non-blocking styling question: is the bracket the best option for the CTA "say hi..."? Shouldn't UserSpeechBubbles (oo-ui-icon-userSpeechBubble) be used instead?

MMiller_WMF closed this task as Resolved.Feb 3 2020, 11:38 PM

Thank you!

@Etonkovidova Hi Elena, you write both - a mentor and a new mentee will resceive echo notifications - does that mean that both the mentor (old, or new one) and the mentee gets a notification? That's not the intended behaviour (at least as-of my code).