Page MenuHomePhabricator

Numerous people reporting issues saving edits and viewing previews/diffs
Closed, ResolvedPublic

Description

At least 3 reports on #wikimedia-tech that they're unable to save edits, view previews or diffs.

Two reports of FF 69 on 18.04 and Windows 10. One report of IE 11

Not much more information atm...

Reporters CC'd

[16:37:16] <ahecht> Anyone else having trouble creating pages on enwiki? I can browse fine, but when I hit publish i just get a very long wait followed by my browser timing out.

Event Timeline

Reedy created this task.Sep 10 2019, 3:41 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 10 2019, 3:41 PM
Reedy updated the task description. (Show Details)Sep 10 2019, 3:41 PM
jcrespo added a subscriber: jcrespo.EditedSep 10 2019, 3:44 PM

Could be related to wikidata contention? https://logstash.wikimedia.org/goto/cfd48f0d1bd1d040a0c7ce8f76ec6169

EDIT: No, it is not

Reedy triaged this task as High priority.Sep 10 2019, 3:45 PM

That last link matches this SAL entry:

11:06 urbanecm@deploy1001: Synchronized wmf-config/InitialiseSettings.php: SWAT: 6afe963: Set items term store on write both for all of Wikidata (T225055) (duration: 00m 55s)

I'm seeing ten seconds of "Sending request to en.wikipedia.org..." and no other response, not only from "publish changes" but also "show preview" and "show changes"

Ahecht added a comment.EditedSep 10 2019, 3:53 PM

This seems to affect creating and editing pages, across multiple wikis (I've tried enwiki and meta), and across multiple accounts (I've tried both my main account and my bot account), with both VE and the wikitext editors.

I was last able to edit successfully last Wednesday, and I hadn't attempted any further edits until this morning when I discovered the issue.

It does seem tied to my ISP somehow, as I can edit pages when I switch to a public WiFi network. However, I can browse pages or open the editor just fine on my primary ISP, I just can't edit from it.

Daimona renamed this task from Numerous people reporting issues saving edits to Numerous people reporting issues saving edits and viewing previes/diffs.Sep 10 2019, 4:06 PM
Daimona updated the task description. (Show Details)
Reedy renamed this task from Numerous people reporting issues saving edits and viewing previes/diffs to Numerous people reporting issues saving edits and viewing previews/diffs.Sep 10 2019, 4:06 PM
Izno added a subscriber: Izno.EditedSep 10 2019, 10:14 PM

I have issues saving in Chrome (Win10) on my work computer but no issue at home on Firefox (Win10). I use WTE2017.

Both content and non-content pages.

Work ISP is a Unitas Global according to an IP checker, home ISP is Comcast.

The actual error I get in WTE is something along the lines of "Empty response from database."

(In cases it matters, I am at work and this comment is not being blocked. :)

Addshore merged a task: Restricted Task.Sep 10 2019, 10:34 PM

Thanks for the reports, we have narrowed down the cause to a MTU issue on our side.

We have a couple possible fix in mind, one of them is blocked on new hardware to be installed Thursday (cf. T226424). But are still discussing the best plan of action.

BBlack added a comment.EditedSep 11 2019, 1:16 AM

I've made a temporary MTU-related fixup on the affected eqiad and esams cache hosts. Assuming we understand the issue correctly, it should be resolve the issue for fresh connections (worst case, restart your browser). Can any previous reporters confirm the same continued breakage, or new success?

Thank you! I've successfully previewed and edited in Firefox. I've also saved an edit in AWB, which had also been broken for a few days.

I can confirm I'm now able to save an edit, however I'm not able to test on the same internet connection where I was having issues until tomorrow.

Izno added a comment.Sep 11 2019, 1:31 PM

Can any previous reporters confirm the same continued breakage, or new success?

I have issues saving in Chrome (Win10) on my work computer but no issue at home on Firefox (Win10). I use WTE2017...

Works at work for me again.

It's working again for me as well.

It works for me too! Thank you!

Pretty sure this is resolved now...

Marostegui closed this task as Resolved.Sep 18 2019, 4:45 AM

Going to close this for now. Feel free to reopen if needed.