Page MenuHomePhabricator

Newcomer tasks: "No more suggestions" card widget
Closed, InvalidPublic

Description

  • When the user gets to the last card in the list, they can click the right arrow one more time, and then they see an area that says something like, “Change the filter settings to find more tasks.” along with a graphic. Mockup here.
  • If there is some kind of error and no edit suggestions can be displayed, the text should say, (heading) "No suggested edits are available at this time." (text) "Please try again later." These are the graphics:
    • Here is the asset as PNG@4x and SVG:

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterSuggested Edits: Adjust spacing for error/end-of-queue/no-results
mediawiki/extensions/GrowthExperiments : masterSuggested edits: Error card widget
mediawiki/extensions/GrowthExperiments : masterNewcomer tasks: "No more suggestions" card widget

Event Timeline

kostajh created this task.Oct 9 2019, 10:24 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 9 2019, 10:24 AM
MMiller_WMF renamed this task from Build out "No more suggestions" card widget to Newcomer tasks: "No more suggestions" card widget.Oct 9 2019, 5:46 PM
MMiller_WMF added subscribers: Catrope, Tgr, MMiller_WMF and 6 others.

Change 542900 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Newcomer tasks: "No more suggestions" card widget

https://gerrit.wikimedia.org/r/542900

Change 542900 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Newcomer tasks: "No more suggestions" card widget

https://gerrit.wikimedia.org/r/542900

@kostajh - is it still a work in progress? In betalabs I see Suggested edits module that looks somewhat incomplete

@Etonkovidova it's because we don't have beta labs fully configured yet. The API response is The TaskSuggester has not been configured! See StaticTaskSuggester or $wgGENewcomerTasksRemoteApiUrl.

@RHo @MMiller_WMF do we want to have a generic error card that we can show in this and other error circumstances? Maybe we could reuse the graphic from "No more suggestsions" but have wording indicating that an error occurred, and to try again later.

RHo added a comment.Oct 22 2019, 9:52 AM

@RHo @MMiller_WMF do we want to have a generic error card that we can show in this and other error circumstances? Maybe we could reuse the graphic from "No more suggestsions" but have wording indicating that an error occurred, and to try again later.

How about we use this instead as the generic error graphic:

Here is the asset as PNG@4x and SVG:

@RHo thanks! @RHo and @MMiller_WMF do you have wording I should use as well?

MMiller_WMF updated the task description. (Show Details)Oct 22 2019, 5:28 PM

@kostajh -- I added wording to the description and put the image files there, too.

Etonkovidova added a comment.EditedOct 26 2019, 12:33 AM

@kostajh - the mockup link goes to ""No more suggestions" card. So there should be two cards - one for "No more suggestions" and for a general error?

"No more suggestion card" - do not see any problems with the card itself.

mockupbetalabs implementation

There is some UI jumpiness when switching from the last card to "No more suggestions" -which also affects Impact module (click on the animated gif below):

"General error" card - any ideas how to display it?

Hey @Etonkovidova, didn’t add the general error card yet but will do that soon and ping you when it’s done.

Change 546336 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] (wip) Suggested edits: Error card widget

https://gerrit.wikimedia.org/r/546336

Change 546336 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Suggested edits: Error card widget

https://gerrit.wikimedia.org/r/546336

@kostajh The text seems to be placed too close to the filter button (can be seen in cawiki betalabs

Change 548960 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Suggested Edits: Adjust spacing for error/end-of-queue/no-results

https://gerrit.wikimedia.org/r/548960

With the patch:

Change 548960 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Suggested Edits: Adjust spacing for error/end-of-queue/no-results

https://gerrit.wikimedia.org/r/548960

Checked in betalabs - the patch fixed the placement of the label:

Moving for Design Review.

RHo added a comment.Nov 13 2019, 11:14 PM

hi @Catrope - I am unable to get this error to show up but can you please advise whether the position is as per my comment on this task T235043#5662071 ?
Happy to leave in Design-review for now but think the same feedback applies here, and for the "End of suggestions card"...
cc @MMiller_WMF in case you prefer to make all of these fit into a single SE module UI fixes card or have another suggestion on how to break this work up.

hi @Catrope @kostajh - looks like some regression has occurred?

Some new items:

  • Font-size of text should be smaller
  • There should be more spacing between image and "No suggested..." subheader text
  • There should be a light blue background-color: rgba(234, 243, 255, 0.5) on the main part of the suggested edits module
  • "Other users..." text should be in the footer.
MMiller_WMF moved this task from Inbox to Upcoming Work on the Growth-Team board.

This is what I see today, does this look alright @RHo?

RHo closed this task as Invalid.Mon, Feb 3, 4:53 PM

yes, cannot reproduce