Page MenuHomePhabricator

Newcomer tasks: include topic in copy for "no results" cards
Closed, ResolvedPublic

Description

In the following two tasks, we implemented cards that show for when the user does not have any suggestions:

The original implementation tells users to "Select other difficulty levels to find suggested edits." These should both be changed to read "Select other interests or difficulty levels to find suggested edits."

Event Timeline

MMiller_WMF edited projects, added Growth-Team; removed Growth-Team (Current Sprint).
MMiller_WMF moved this task from Inbox to Upcoming Work on the Growth-Team board.
kostajh removed MMiller_WMF as the assignee of this task.Jan 7 2020, 8:55 AM

Change 562664 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] Newcomer tasks: pass topic matching enabled flag to "no results" cards

https://gerrit.wikimedia.org/r/562664

Tgr claimed this task.Jan 8 2020, 1:03 AM

Change 562664 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Newcomer tasks: pass topic matching enabled flag to "no results" cards

https://gerrit.wikimedia.org/r/562664

Looks like this needs some style tweaks

Tgr added a comment.Jan 10 2020, 8:29 AM

It looks fine to me... some kind of browser difference maybe?

Etonkovidova moved this task from QA to Design Review on the Growth-Team (Current Sprint) board.EditedJan 10 2020, 9:35 PM

I see the same as in @Gergo comment above.

However, two points to notice

Tgr added a comment.Jan 11 2020, 3:52 AM

It looks fine to me... some kind of browser difference maybe?

Of course looking good in English does not mean that's not a problem, duh.

The thing is, the text area has a fixed height, because the whole card has a fixed height, because we want the various card types to have the same dimensions. (For the no results card that's probably not that important. The no more suggestions card takes the place of a task card during navigation though, so size changes would be jarring.) Not sure how to square that with supporting arbitrarily long interface messages in the bottom.

How did that happen? It shouldn't be possible to see the no results card and a task type description in the same time.

@Etonkovidova -- I think this question is for you.

How did that happen? It shouldn't be possible to see the no results card and a task type description in the same time.

I cannot reproduce it.

RHo added a comment.Feb 3 2020, 4:42 PM
  • a question to @RHo - when there is no results found, the footer still says - "Other users have noted these articles need work...". Since the footer refers to the article(s) displayed - should we provide a different footer for the case when there are no results have been found?

That's a good point but I think this is OK to keep the same since the default case is this module will show some articles suggestions, and it should be clear the text "Other users..." refers to the entire set suggested edits.

The thing is, the text area has a fixed height, because the whole card has a fixed height, because we want the various card types to have the same dimensions. (For the no results card that's probably not that important. The no more suggestions card takes the place of a task card during navigation though, so size changes would be jarring.) Not sure how to square that with supporting arbitrarily long interface messages in the bottom.

I see @MMiller_WMF has created a separate task T242470 for this issue, so happy to move this copy-specific task to PM review.

MMiller_WMF closed this task as Resolved.Feb 4 2020, 1:35 AM

Thank you!