Page MenuHomePhabricator

[regression wmf.25] Mentorship module shows guidance root screen
Closed, ResolvedPublicBUG REPORT

Description

Based on T244546: Newcomer tasks: guidance root screen -the guidance root screen should appear only for the Help panel. Presently, testwiki (wmf.25) shows it for Mentorship module.

The issue is reproducible in betalabs also.

Steps to Reproduce:

  1. On testwiki (wmf.25) go to Special:Homepage. Click on 'Ask your mentor a question'.
  2. The dialog box opens with buttons to direct a user to a Help desk and to Help links, instead of a mentor User talk page.

After clicking on 'Ask your mentor a question'

Expected Results:
Clicking on 'Ask your mentor a question' should present a dialog from where a question can be posted on a mentor talk page.

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : wmf/1.35.0-wmf.25Mentorship module: Update for root screen refactor
mediawiki/extensions/GrowthExperiments : masterMentorship module: Update for root screen refactor
mediawiki/extensions/GrowthExperiments : masterRevert "Help panel: Add root screen buttons"
mediawiki/extensions/GrowthExperiments : masterRevert "Help panel: Fix panel title for ask-help"
mediawiki/extensions/GrowthExperiments : masterRevert "Help panel: Add some padding between button title and subheader"
mediawiki/extensions/GrowthExperiments : masterRevert "Help panel: On mobile, use 'previous' icon for non-home panels"
mediawiki/extensions/GrowthExperiments : masterRevert "Help panel: Add suggested edit button"

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptTue, Mar 24, 9:17 PM
Catrope claimed this task.Tue, Mar 24, 9:58 PM
Catrope moved this task from Incoming to In Progress on the Growth-Team (Current Sprint) board.
Catrope added a subscriber: Catrope.

This happened because rEGREb5316d1d36cd: Help panel: Add root screen buttons (for T244546: Newcomer tasks: guidance root screen) made significant changes to HelpPanelProcessDialog, without realizing that QuestionPosterDialog is a subclass of it. In other words, the mentorship dialog (and the other "ask a question" dialogs) are implemented as some modifications on top of the help panel, so changing the structure of the help panel broke them.

IMO it doesn't make sense for QuestionPosterDialog to inherit from HelpPanelProcessDialog, it probably makes more sense the other way around (or for both to inherit from a common base class). We can explore refactoring this, or we can make changes to QuestionPosterDialog to account for the restructuring in HelpPanelProcessDialog, but since neither of these things is easy I'm going to revert rEGREb5316d1d36cd: Help panel: Add root screen buttons and its followups for now.

Change 583154 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Revert "Help panel: Add suggested edit button"

https://gerrit.wikimedia.org/r/583154

Change 583155 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Revert "Help panel: On mobile, use 'previous' icon for non-home panels"

https://gerrit.wikimedia.org/r/583155

Change 583158 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Revert "Help panel: Fix panel title for ask-help"

https://gerrit.wikimedia.org/r/583158

Change 583159 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Revert "Help panel: Add some padding between button title and subheader"

https://gerrit.wikimedia.org/r/583159

Change 583160 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Revert "Help panel: Add root screen buttons"

https://gerrit.wikimedia.org/r/583160

kostajh claimed this task.Wed, Mar 25, 8:03 AM

Claiming this one as I have a fix to avoid these reverts.

Change 583288 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Mentorship module: Update for root screen refactor

https://gerrit.wikimedia.org/r/583288

Change 583288 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Mentorship module: Update for root screen refactor

https://gerrit.wikimedia.org/r/583288

Change 583154 abandoned by Catrope:
Revert "Help panel: Add suggested edit button"

Reason:
Superseded by https://gerrit.wikimedia.org/r/c/mediawiki/extensions/GrowthExperiments/ /583288

https://gerrit.wikimedia.org/r/583154

Change 583155 abandoned by Catrope:
Revert "Help panel: On mobile, use 'previous' icon for non-home panels"

Reason:
Superseded by https://gerrit.wikimedia.org/r/c/mediawiki/extensions/GrowthExperiments/ /583288

https://gerrit.wikimedia.org/r/583155

Change 583159 abandoned by Catrope:
Revert "Help panel: Add some padding between button title and subheader"

Reason:
Superseded by https://gerrit.wikimedia.org/r/c/mediawiki/extensions/GrowthExperiments/ /583288

https://gerrit.wikimedia.org/r/583159

Change 583158 abandoned by Catrope:
Revert "Help panel: Fix panel title for ask-help"

Reason:
Superseded by https://gerrit.wikimedia.org/r/c/mediawiki/extensions/GrowthExperiments/ /583288

https://gerrit.wikimedia.org/r/583158

Change 583160 abandoned by Catrope:
Revert "Help panel: Add root screen buttons"

Reason:
Superseded by https://gerrit.wikimedia.org/r/c/mediawiki/extensions/GrowthExperiments/ /583288

https://gerrit.wikimedia.org/r/583160

Change 583393 had a related patch set uploaded (by Gergő Tisza; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@wmf/1.35.0-wmf.25] Mentorship module: Update for root screen refactor

https://gerrit.wikimedia.org/r/583393

Change 583393 merged by Gergő Tisza:
[mediawiki/extensions/GrowthExperiments@wmf/1.35.0-wmf.25] Mentorship module: Update for root screen refactor

https://gerrit.wikimedia.org/r/583393

Mentioned in SAL (#wikimedia-operations) [2020-03-25T18:13:49Z] <tgr@deploy1001> Synchronized php-1.35.0-wmf.25/extensions/GrowthExperiments/modules/homepage/: SWAT: [[gerrit:583393|Mentorship module: Update for root screen refactor (T248422)]] (duration: 03m 23s)

Jdforrester-WMF closed this task as Resolved.Wed, Mar 25, 7:24 PM
Jdforrester-WMF triaged this task as Unbreak Now! priority.

Checked in betalabs and testwiki (wmf.25) - the Mentorship dialog is back to normal. Will do additional check in target wikis.