Page MenuHomePhabricator

Provide a stand-alone interactive visual tool to create and edit EasyTimelines (not in the VisualEditor)
Closed, DeclinedPublic

Description

If we can replace the low-level perl script and Ploticus backend with code that generates SVG directly, it could be a lot easier to create a live editing tool for timeline data. This could be much more pleasant to work with than the edit-preview cycle, and encourage more usage of timelines.

See Also T45115: Create a VisualEditor plugin tool to add/edit Timelines

Details

Reference
bz27157

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 11:13 PM
bzimport added a project: EasyTimeline.
bzimport set Reference to bz27157.
bzimport added a subscriber: Unknown Object (MLST).
brion created this task.Feb 4 2011, 6:56 PM

I also said this on bug 27156 - but we already generate svg's for every timeline (don't really use them for much though) - http://upload.wikimedia.org/wikipedia/en/timeline/688dde24168b00c8abaea72a41adad6d.svg

I'm rather sure that Erik Z. will not be working on this. James, what would be the best pointers to someone willing to add VisualEditor support for EasyTimeline, or wondering whether it's in the VisualEditor team's roadmap?

"Skills: HTML / JavaScript / jQuery development is required. A good grasp of UX / Web design will make a difference."
https://www.mediawiki.org/wiki/Mentorship_programs/Possible_projects#VisualEditor_plugins

Qgil added a comment.Nov 27 2013, 4:52 PM

The Facebook Open Academy Program [1] is interested in this project, but we would need a technical mentor.

[1] http://lists.wikimedia.org/pipermail/wikitech-l/2013-November/073226.html

vladjohn2013 wrote:

Hi, this project is still listed at https://www.mediawiki.org/wiki/Mentorship_programs/Possible_projects#VisualEditor_support_for_EasyTimeline

Should this project be still listed in that page? If not, please remove it. If it still makes sense, then it could be moved to the "Featured projects" section if it has community support and mentors.

  • Bug 43115 has been marked as a duplicate of this bug. ***
Qgil added a comment.Feb 11 2015, 1:44 PM

Wikimedia will apply to Google Summer of Code and Outreachy on Tuesday, February 17. If you want this task to become a featured project idea, please follow these instructions.

Qgil lowered the priority of this task from Low to Lowest.Feb 17 2015, 9:03 PM
Jdforrester-WMF set Security to None.

Is this same as T29156?

Yurik added a subscriber: Yurik.Apr 16 2015, 3:34 PM

Will this feature be needed after launching Graph extension? Vega could represent any kinds of graphs out of data. E.g. http://trifacta.github.io/vega/editor/?spec=lifelines (and see other examples)

Will this feature be needed after launching Graph extension? Vega could represent any kinds of graphs out of data. E.g. http://trifacta.github.io/vega/editor/?spec=lifelines (and see other examples)

Possibly, but we'd need to come up with a transition plan. Killing EasyTimeline and converting all the old revisions to use the new tool wouldn't be ideal…

Yurik added a comment.Apr 16 2015, 3:44 PM

Well, unless EasyTimeline provides significant additional value (which it just might - I don't know it well enough), I think we shouldn't duplicate functionality - bigger security attack surface, more bitrot ))) But yes, we could have a gsoc project to write a converter ))

Qgil added a comment.Sep 23 2015, 9:10 AM

This is a message posted to all tasks under "Re-check in September 2015" at Possible-Tech-Projects. Outreachy-Round-11 is around the corner. If you want to propose this task as a featured project idea, we need a clear plan with community support, and two mentors willing to support it.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2015, 9:10 AM
Qgil added a comment.Sep 23 2015, 9:36 AM

This is a message sent to all Possible-Tech-Projects. The new round of Wikimedia Individual Engagement Grants is open until 29 Sep. For the first time, technical projects are within scope, thanks to the feedback received at Wikimania 2015, before, and after (T105414). If someone is interested in obtaining funds to push this task, this might be a good way.

Sumit added a subscriber: Sumit.Mar 1 2016, 5:37 PM
IMPORTANT: This is a message posted to all tasks under "Need Discussion" at Possible-Tech-Projects. Wikimedia has been accepted as a mentor organization for GSoC '16. If you want to propose this task as a featured project idea, we need a clear plan with community support, and two mentors willing to support it.
Qgil removed a subscriber: Qgil.Mar 2 2016, 10:22 AM
Niharika removed a subscriber: Niharika.Mar 2 2016, 7:00 PM
Jdforrester-WMF renamed this task from EasyTimeline: in-browser visual editing to Provide a stand-alone interactive visual tool to create and edit EasyTimelines (not in the visual editor).Jun 8 2016, 11:42 AM
Jdforrester-WMF removed a project: VisualEditor.
Jdforrester-WMF updated the task description. (Show Details)
Ricordisamoa renamed this task from Provide a stand-alone interactive visual tool to create and edit EasyTimelines (not in the visual editor) to Provide a stand-alone interactive visual tool to create and edit EasyTimelines (not in the VisualEditor).Jun 13 2016, 4:25 AM

Removing Possible-Tech - not a good candidate, and I think we should close this outright.

hashar closed this task as Resolved.Aug 24 2016, 11:24 AM
hashar claimed this task.
hashar added a subscriber: hashar.

I agree with @Jdforrester-WMF lets focus on Graph instead of EasyTimeline which is really legacy. Prior work would need to be migrated to Graph which is T137291.

Nemo_bis changed the task status from Resolved to Declined.Oct 30 2016, 9:29 PM

I agree with @Jdforrester-WMF lets focus on Graph instead of EasyTimeline which is really legacy.

Sounds like a WONTFIX. If something was produced which warrants a RESOLVED FIXED, please point out the tool in question.

hashar moved this task from Backlog to Feature request on the EasyTimeline board.Nov 15 2016, 10:11 AM