Page MenuHomePhabricator

Deploy new geoshapes work (including geopoints) to the beta cluster
Closed, ResolvedPublic3 Estimated Story Points

Description

  • Read https://wikitech.wikimedia.org/wiki/Maps/Services_deployment and learn how to deploy to beta.
  • Put the latest Kartotherian code onto the beta cluster.
  • Document what we learn by doing this, update the wiki page.
  • Enable geopoints by setting enable_geopoints to true in the deployment repo vars.yaml to render in the config.yaml template. Can be confirmed by scapping and looking at the resulting file in the beta maps server /etc directory.

WMDE Tech Wishes hasn't done this type of deployment yet, so we should be documenting and hopefully pair on the work.

Relevant beta cluster hosts:

  • Deployment server: deployment-deploy03.deployment-prep.eqiad1.wikimedia.cloud
  • Maps server: deployment-maps-master01.deployment-prep.eqiad1.wikimedia.cloud

Event Timeline

WMDE-Fisch set the point value for this task to 5.May 25 2022, 12:20 PM

"Write a changelog" should be split into a separate task.

awight changed the point value for this task from 5 to 3.

Adding @MSantos and @Jgiannelos for visibility.

I ran into a few glitches so far, and I'll proceed cautiously rather than rushing the deployment out.

  • Instructions at https://wikitech.wikimedia.org/wiki/Maps/Services_deployment are still based on the kartotherian-package repo process, which is completely deprecated to my knowledge.
  • Unclear whether there should be an npm release when we deploy? It seems this is no longer coupled to the deployment, which is nice. We could switch to a more intentional strategy of only releasing to npm when the package is very stable, like is done with MediaWiki-core releases.
  • WMDE devs don't have permissions to create a branch on the kartotherian-deploy repo. I'm assuming that a branch is the right way to test on beta, so that we don't accidentally deploy anything to production (e.g. if a hotfix is required for an unrelated issue).

Change 803475 had a related patch set uploaded (by Awight; author: Awight):

[maps/kartotherian/deploy@master] New kartotherian source; enable geopoint service

https://gerrit.wikimedia.org/r/803475

Change 803475 merged by jenkins-bot:

[maps/kartotherian/deploy@master] New kartotherian source; enable geopoint service on beta

https://gerrit.wikimedia.org/r/803475

The code is deployed, but we can't demonstrate geopoints yet due to lacking the geoshapes database. I'll create a subtask for this work.

Now there are some remaining snapshot errors, see the missing maps on https://en.wikipedia.beta.wmflabs.org/wiki/User:Adamw/sandbox

I also realized that I failed to update the node_modules in the deploy repo.

Looks like tegola.wmflabs.org was being provided by the maps-experiments cluster, and we have to reconstruct it on beta. @MSantos can I leave that on the WMF backlog?

awight removed awight as the assignee of this task.Jul 6 2022, 8:41 AM

Note: enabling geopoints includes some configuration (point to beta wikidata) and data entry (make sure we have some items in beta wikidata with coordinates, document these).

lilients_WMDE closed this task as Resolved.EditedJul 20 2022, 2:21 PM
lilients_WMDE claimed this task.
lilients_WMDE added a subscriber: lilients_WMDE.

Since there is no beta wikidata query service (see T225245) we are using the production query service. This is already working. I added some examples: https://de.wikipedia.beta.wmflabs.org/w/index.php?title=Maptests&stable=0&redirect=no There are some display issue. We should create separate tickets to fix those.