Page MenuHomePhabricator

MediaWiki needs moar NyanCat
Closed, DeclinedPublic

Description

Details

Reference
bz30112

Related Objects

StatusAssignedTask
ResolvedNone
ResolvedNone
ResolvedNone
DeclinedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
Resolvedhashar
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 11:55 PM
bzimport set Reference to bz30112.
bzimport added a subscriber: Unknown Object (MLST).
Reedy created this task.Jul 29 2011, 12:36 PM

Implement it as an easter egg on e.g. Special:Version! :P

brion added a comment.Jul 29 2011, 6:38 PM

HTML 5 video of NyanCat is WebM, so adding dependency on TimedMediaHandler for WebM player support.

Reedy added a comment.Jul 29 2011, 9:35 PM

Fixed typo in title

Also appears to be at least partially blocked by bug 28818 (InsertCat problem)

Konami Code to trigger the video player w/ nyan cat in it?

demon added a comment.Jul 31 2011, 3:19 AM

Suggest LATERing the bug until we remove all legacy skins: this sort of thing is only useful in Vector and Amethyst.

Thanks for providing this video. However, you did not specify an acceptable copyright license, and therefore we cannot use your photo until this is resolved.

One of our main goals is that anyone can copy any of our content for any reason. Therefore, it is essential that you specify the terms and conditions under which we can use your picture, and that these terms are compatible with our goals. Whatever license you choose must allow the photo to be freely copied and modified by anyone (including third parties not affiliated with Wikipedia), for any purpose (subject to applicable laws). We strongly suggest using the Creative Commons Attribution-ShareAlike 3.0 license: Please read http://creativecommons.org/licenses/by-sa/3.0/ and let us know if you agree with the terms and conditions listed there.

Please note that only the copyright holder can make such a release. Please see http://commons.wikimedia.org/wiki/Commons:Derivative_works for the three people to contact with.

  • This bug has been marked as a duplicate of bug 29079 ***

Clearly not a dup, invalid/wontfix at best.

I support having this feature being added to MediaWiki. Giving its popularity it's a bit odd to mark it as wontfix :)

If it cannot go into core, perhaps it can be added to https://www.mediawiki.org/wiki/Extension:Awesomeness which btw, really ought to be included in the MediaWiki release tarballs.

demon added a comment.Nov 20 2012, 3:25 PM

(In reply to comment #10)

If it cannot go into core, perhaps it can be added to
https://www.mediawiki.org/wiki/Extension:Awesomeness which btw, really ought to
be included in the MediaWiki release tarballs.

I can't support bundling this extension, since I want MediaWiki to be less than awesome.

Maybe we can provide a link to «Make your more awesome» to make people learn about and install extensions. :)

Going back to the cats, the license (comment 7) is still a blocker.

Oh please, could I please have one unactionable item less in the list of open tickets? If people really insist on keeping this open, I'll dump it under extension requests.

This seems unlikely; it would require the creator of Nyan Cat to explicitly release it under a free license, or at least give permission to use it here.

Why does this keep getting reopened? It would make sense to close this until the licensing is sorted out.

It would make sense to close this until the licensing is sorted out.

That is a subtask. You could create an additional ticket and list it as blocker for this one.

Krenair closed this task as Declined.Feb 14 2015, 3:40 AM
Krenair claimed this task.
Krenair removed Krenair as the assignee of this task.
Krenair set Security to None.
Krenair removed a subscriber: Unknown Object (MLST).