UW: re-upload of deleted file impossible (duplicate-archive case); should have override
Closed, ResolvedPublic

Description

Author: masatia

Description:
Hello if you try to upload the deleted file will result as a 3 different messages.I don't know 3 messages is,and it changes everytime as a real bug.You can upload it in old form.


Version: master
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=48543

Details

Reference
bz40921
bzimport set Reference to bz40921.
bzimport added a subscriber: Unknown Object (MLST).

Hi Ferry,
unfortunately this report is not very useful because it does not describe the
problem well. If you have time and can still reproduce the problem, please read
https://www.mediawiki.org/wiki/How_to_report_a_bug and add a more useful
description to this report by providing exact steps to reproduce (click by
click).
Also, which exact Mediawiki version is this about?

Downgrading to normal until we have more information.

masatia wrote:

Upload Blocker

Upload Blocker bug,which deleted files can't uploaded again by UploadWizard but works in normal upload form

Attached:

Lupo added a comment.Dec 2 2012, 9:12 PM

I can confirm this. It's hyper-annoying when testing the UploadWizard.

To reproduce, upload any file through UW. Once that's gone through, visit the file description page and delete the file. Then try to upload the same file again through UW.

It's in mw.UploadWizardUpload.js, the 'duplicate-archive' case at line 225ff. See also bug 39852 (there used to be a way to override this).

Lupo added a comment.Dec 4 2012, 7:23 AM

At least users having the appropriate rights should have a possiblity to override this. Off-hand I don't see any user right that would be 100% appropriate (I see no 'deleted-reupload' or some such), the closest existing right appears to be 'reupload'.

Since the normal upload form allows re-uploading of previously deleted files (though giving a warning about this), the override could maybe be provided for anybody irrespective of user rights.

TheDJ added a comment.May 24 2013, 4:13 PM

There already is functionality to handle this, but it was disable due to bug 39852. Seeing if we care revive it now.

Related URL: https://gerrit.wikimedia.org/r/65318 (Gerrit Change I55e3ef9b3224f7a31c8d738e75a241010ed55226)

Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:40 PM
Restricted Application added subscribers: Steinsplitter, Matanya. · View Herald TranscriptSep 4 2015, 6:40 PM
matmarex reopened this task as "Open".
matmarex added a subscriber: matmarex.

This is not a duplicate of T42893. That one is for existing files.

matmarex claimed this task.Sep 9 2015, 5:26 PM

Change 237158 had a related patch set uploaded (by Bartosz Dziewoński):
Allow reupload of deleted files ('duplicate-archive' warning)

https://gerrit.wikimedia.org/r/237158

Bug 39852 (T41852) does not seem to come back with the above patch, possibly due to my fix for T92801 or something else that happened in the last three years.

Tgr added a subscriber: Tgr.Sep 10 2015, 8:43 PM

The more generic issue is T77550 (which I merged in a somewhat stupid way as the open bug is much less general). The traditional upload form has a checkbox to ignore recoverable warnings; UW does not offer anything like that. Most of the cases where this comes up are not relevant to Commons but can be annoying on 3rd-party wikis (e.g. can't upload a file locally on an InstantCommons-using wiki because Commons already has something by that name).

MarkTraceur closed this task as "Resolved".Sep 11 2015, 4:18 PM

Fixed, thanks MatmaRex!

Change 237158 merged by jenkins-bot:
Allow reupload of deleted files ('duplicate-archive' warning)

https://gerrit.wikimedia.org/r/237158

Jdforrester-WMF moved this task from Backlog to Done on the Multimedia board.Sep 11 2015, 6:22 PM
Jdforrester-WMF set Security to None.
Jdforrester-WMF moved this task from To Triage to Announce in next Tech/News on the User-notice board.