Page MenuHomePhabricator

[TUX] Blacklisted languages are not shown as blacklisted when language was selected using the language selector
Closed, ResolvedPublic

Description

Original bug title:
When entering the URL generated by the Translate extension into my browser's address bar it says: "Translate in zh please."

But when I choose zh-hant from ULS, it allows translating into Traditional Chinese (zh-hant) and it creates the URL, I later tried to enter in my browser's address bar (which fails with "Translate in zh please.").

Here is the URL: https://commons.wikimedia.org/w/index.php?title=Special:Translate&group=page-Commons%3AVandalism&filter=&action=translate&language=zh-hant

Expected: Consistent behaviour.

See also T124013: Do not allow saving translations to blacklisted language codes

Details

Reference
bz49898
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:43 AM
bzimport set Reference to bz49898.
bzimport added a subscriber: Unknown Object (MLST).
Rillke created this task.Jun 20 2013, 6:14 PM

Note that I use that ULS that appears after clicking the dropdown in Special:Translate

You can easily reproduce this:

On the other hand, go to https://commons.wikimedia.org/w/index.php?title=Special:Translate&group=page-Commons%3AVandalism&filter=&action=translate&language=zh-hant directly and you can't

zh-hant is blacklisted, so the warning is correct. However, I was able to save a translation in zh-hant...

I guess the solution should be to hide disabled languages in Extension:Translate's ULS dialog.

Why is zh-hant blacklisted?

btw. bug 49907 spotted just now.

Nemo_bis set Security to None.
Arrbee raised the priority of this task from Normal to High.Jun 4 2015, 9:33 AM
Arrbee moved this task from Backlog to Sprint Backlog on the Language-Team board.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 11 2015, 12:22 AM

Same with "gom", it's in $wgTranslateBlacklist but language selector offers it and users manage to save https://translatewiki.net/wiki/Thread:Support/Possibility_incorrect_link_in_%27Translate_to%27_language_selector

Nikerabbit renamed this task from It's sometimes possible to save translations in a blacklisted language to [TUX] Blacklisted languages are not shown as blacklisted when language was selected using the language selector.Jan 22 2016, 3:46 PM
Nikerabbit updated the task description. (Show Details)
Liuxinyu970226 added a comment.EditedAug 10 2016, 11:10 PM

I have to invite shinjiman because he said this sentense on Portal talk:Zh of TWN which is very confusing:

By the way MediaWiki never disabled the zh-CN/zh-TW interface so those languages can be translated if the translations are different to their parent language.

I'm afraid, his so-called "can be translated" is also because of this bug

Change 306959 had a related patch set uploaded (by Glaisher):
tux: Change URL when the language is changed through language selector

https://gerrit.wikimedia.org/r/306959

Change 306959 merged by jenkins-bot:
tux: Change URL when the language is changed through language selector

https://gerrit.wikimedia.org/r/306959

Glaisher closed this task as Resolved.Aug 30 2016, 3:23 PM
Glaisher claimed this task.
Glaisher added a subscriber: Glaisher.

T124013: Do not allow saving translations to blacklisted language codes has also been fixed so it won't be possible to make these edits through normal edit page as well.

Liuxinyu970226 awarded a token.
LNDDYL added a subscriber: LNDDYL.Apr 18 2017, 2:52 AM