bzimport set Reference to bz50100.
MZMcBride created this task.Via LegacyJun 24 2013, 2:58 PM
Jdforrester-WMF added a comment.Via ConduitJul 6 2013, 11:52 PM
  • Bug 50313 has been marked as a duplicate of this bug. ***
bzimport added a comment.Via ConduitJul 16 2013, 1:28 AM

pearley wrote:

*** Bug 51417 has been marked as a duplicate of this bug. ***

Esanders added a comment.Via ConduitJul 16 2013, 3:11 PM

I'm not sure we should be deleting empty headings. The user may want to delete all the contents of a heading and replace it (or select-all then type, which would perform the same operations internally).

More generally we don't delete paragraphs when they are empty, unless the user presses backspace again, so doing so for just headings would be a confusing user experience.

Perhaps a solution would be for Parsoid to strip empty blocks (provided they weren't that way to begin with)?

Esanders added a comment.Via ConduitJul 16 2013, 3:12 PM

Or we have a system for flagging up formatting irregularities (e.g. markers in the margin), which could also flag up other violations of formatting conventions (e.g. double linebreaks).

Jdforrester-WMF added a comment.Via ConduitJul 16 2013, 3:17 PM

(In reply to comment #3)

I'm not sure we should be deleting empty headings. The user may want to
delete all the contents of a heading and replace it (or select-all then type,
which would perform the same operations internally).

Oh, yes, this was meant to be on save, rather than as they edit.

Perhaps a solution would be for Parsoid to strip empty blocks (provided they
weren't that way to begin with)?

That could also work, but feels a bit clunky; I think Parsoid should expect users to send it the HTML they actually want saved, and that it's up to clients to encourage users to indeed create such HTML.

Esanders added a comment.Via ConduitJul 16 2013, 4:02 PM

"Encourage" yes...

Catrope added a comment.Via ConduitJul 23 2013, 8:03 PM
  • Bug 51829 has been marked as a duplicate of this bug. ***
maiden_taiwan added a comment.Via ConduitJul 23 2013, 8:31 PM

Speaking as an end-user, I spent quite some time trying to figure out how to delete a heading. It was quite confusing. Bug 51829 (marked as a duplicate) describes my attempts.

VE's behavior in this regard is the opposite of (say) MS Word's. In Word, if you highlight one character beyond the heading and press Delete, you remove the heading. In VE, you have to highlight an invisible area *preceding* the heading. This is not intuitive.

Elitre added a comment.Via ConduitAug 6 2013, 12:39 PM

Since 51829 is now marked as a dupe,
should we also discuss here an issue that Dan reported as well - VE turning the next paragraph into a heading,
or that "when pressing delete on an empty heading line, if there is a template such as {{main}} on the next line, it is unexpectedly deleted", as user:WS states on enwp?

Elitre added a comment.Via ConduitAug 8 2013, 9:20 AM

<< Often, when an editor tries to remove (or accidentally removes) a section header, the result in VE is something like this: http://en.wikipedia.org/w/index.php?title=%C3%87ank%C4%B1r%C4%B1_Province&diff=567375871&oldid=542107518 . This is seldom (if ever) the intention, can VE be coded to simply remove the section header in these cases? Fram (talk) 09:32, 6 August 2013 (UTC) >>

Spinningspark added a comment.Via ConduitAug 22 2013, 8:26 PM

This editor http://en.wikipedia.org/w/index.php?title=Pound_%28mass%29&diff=569770089&oldid=569255959 removed the whole section. It could not possibly have been their intention to leave behind an empty heading line.

Thryduulf added a comment.Via ConduitAug 23 2013, 1:51 AM

en.wp user 28bytes comments:
There was an unneeded section, so I selected the section, pressed "delete" and saved. VE did this [1]; I expected it to do this. [2]

1: https://en.wikipedia.org/w/index.php?title=Degeneracy&diff=prev&oldid=569795975
2: https://en.wikipedia.org/w/index.php?title=Degeneracy&diff=569796007&oldid=567105149

gerritbot added a comment.Via ConduitSep 23 2014, 6:29 PM

Change 162310 had a related patch set uploaded by Jforrester:
MWHeading: Don't put self in output if contents are blank or whitespace

https://gerrit.wikimedia.org/r/162310

Jdforrester-WMF moved this task to Backlog on the VisualEditor workboard.Via WebNov 24 2014, 1:22 AM
Jdforrester-WMF claimed this task.Via WebDec 1 2014, 9:24 PM
Jdforrester-WMF moved this task to TR6: ???? on the VisualEditor workboard.
Jdforrester-WMF moved this task to TR5: ???? on the VisualEditor workboard.
Jdforrester-WMF moved this task to Backlog on the VisualEditor workboard.Via WebJan 15 2015, 12:09 AM
gerritbot added a subscriber: gerritbot.Via ConduitFeb 17 2015, 6:22 PM

Change 162310 had a related patch set uploaded (by Jforrester):
MWHeading: Don't put self in output if contents are blank or whitespace

https://gerrit.wikimedia.org/r/162310

Patch-For-Review

Jdforrester-WMF moved this task to TR5: ???? on the VisualEditor workboard.Via WebFeb 17 2015, 7:41 PM
gpaumier added subscribers: gpaumier, Eloquence.Via WebMar 18 2015, 8:12 PM
gerritbot added a comment.Via ConduitMar 20 2015, 11:16 PM

Change 162310 merged by jenkins-bot:
For empty / whitespace-only headings, output <p> instead of <h#>

https://gerrit.wikimedia.org/r/162310

Jdforrester-WMF moved this task to Done on the VisualEditor workboard.Via WebMar 20 2015, 11:29 PM
Etonkovidova added a subscriber: Etonkovidova.Via WebMar 23 2015, 11:39 PM

The same fix as for T51452 - verified in beta.

Elitre reopened this task as "Open".Via WebMar 31 2015, 4:43 PM

See here though?

gpaumier added a comment.Via WebMar 31 2015, 5:16 PM

If I understand correctly, the fix was deployed as part of version 1.25wmf23, which hasn't arrived to Wikipedias yet. It'll be deployed there tomorrow (April 1).

Jdforrester-WMF closed this task as "Resolved".Via WebApr 1 2015, 12:17 AM

Indeed.

Spinningspark removed a subscriber: Spinningspark.Via WebApr 5 2015, 11:07 PM
gpaumier reopened this task as "Open".Via WebApr 7 2015, 6:12 PM

It looks like this is still happening: https://en.wikipedia.org/w/index.php?diff=655361654

Liuxinyu970226 added a subscriber: Liuxinyu970226.Via WebApr 9 2015, 2:39 AM
Liuxinyu970226 removed a subscriber: Liuxinyu970226.Via WebApr 18 2015, 1:27 AM
maiden_taiwan removed a subscriber: maiden_taiwan.Via WebApr 18 2015, 4:07 AM

Add Comment