Page MenuHomePhabricator

livePreview make 'Language settings' icon disappear
Closed, ResolvedPublic

Description

The icon that allow opening the 'Language settings' dialog in 'Languages' toolbox disappear when livePreview is used.


Version: master
Severity: normal

Details

Reference
bz51029

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 2:03 AM
bzimport set Reference to bz51029.
bzimport added a subscriber: Unknown Object (MLST).
Ltrlg created this task.Jul 9 2013, 11:03 AM

Thanks for the report. Can you please provide numbered steps to reproduce and a wiki in which we can observe the reported behavior?

Ltrlg added a comment.Jul 9 2013, 11:52 AM
  1. Go to a wiki where ULS is installed (for example https://fr.wikipedia.org/, where I saw this bug)
  2. Turn on livePreview in user’s preferences (Editing/Advanced options/Use live preview)
  3. Go to an article and edit it. Yo can see this icon in the 'Languages' toolbox
  4. Click on 'Show preview' button.
  5. When the preview is complete, there is no more icon.

[edit conflict]

  1. Enable "Use live preview (requires JavaScript) (experimental)" at

https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-editing

  1. Go to

https://en.wikipedia.org/wiki/Special:Random?action=edit
and notice the icon is there.

  1. Click "Show preview" and see the icon disappear.

I'm moving this to MediaWiki core. I do not think it makes sense in ULS to support experimental features until they are more stable. In fact I believe live preview is candidate for removal in favour of visual editor.

(In reply to comment #4)

I'm moving this to MediaWiki core. I do not think it makes sense in ULS to
support experimental features until they are more stable. In fact I believe
live preview is candidate for removal in favour of visual editor.

I don't see a reason for that: if wikitext will continue to be editable directly even after VisuaEditor, why shouldn't the user be allowed to preview the change without reloading the whole page?

This depends on a core bug, but will require (very minor) changes in ULS to be fixed. Moving back.

Ltrlg closed this task as Resolved.Jan 27 2015, 5:26 PM
Ltrlg claimed this task.

The icon no longer disappears (probably since the recent rewrite of livePreview?).