VisualEditor should display formulae using the user's preferred method, not just the default PNG one
Open, NormalPublic8 Story Points

Details

Reference
bz60728
bzimport set Reference to bz60728.

The title change seems to have repurposed this bug. The original title
VisualEditor: Math formulas don't display correctly after save (until page is reloaded) was a dupe of bug 36060 a dependant of bug 51565.

The current title does not describe current behaviour:

With VisualEditor formulae editing beta feature OFF. Formula are displayed as PNG's and can't be edited.

With VisualEditor formulae editing beta feature ON. Formula are initially displayed as PNG's they can be edited. As soon as they are edited they switch to MathJax display but with very garbled output due to Bug 61497.

  • Bug 64572 has been marked as a duplicate of this bug. ***
Jdforrester-WMF lowered the priority of this task from "High" to "Normal".Jan 9 2015, 10:55 PM
Esanders closed this task as "Resolved".Sep 17 2015, 1:42 PM
Esanders claimed this task.
Esanders added a subscriber: Esanders.

MathJax is no longer supported. See T99369

Esanders changed the task status from "Resolved" to "Invalid".Sep 17 2015, 1:51 PM

Sure, but the non-MathJax rendering options are also ignored.

Jdforrester-WMF changed the title from "VisualEditor: Edited formulae display as raw LaTeX inside VisualEditor if user has MathJax switched on" to "VisualEditor should display formulae using the user's preferred method, not just the default PNG one".Sep 17 2015, 4:23 PM
Jdforrester-WMF edited the task description. (Show Details)
Jdforrester-WMF reopened this task as "Open".
Jdforrester-WMF lowered the priority of this task from "Normal" to "Low".
Jdforrester-WMF removed Esanders as the assignee of this task.
Jdforrester-WMF added a project: Math.
Jdforrester-WMF set Security to None.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2015, 4:23 PM
Physikerwelt added a subscriber: Physikerwelt.

At least this should be forward compatible and support the MathML rendering mode... maybe it's not optimal to classify this as "Low" priority.

This is a Parsoid/RESTBase issue. For caching purposes they don't serve different content based on user preferences.

Physikerwelt raised the priority of this task from "Low" to "Normal".Apr 7 2016, 3:31 PM
Physikerwelt moved this task from Backlog to VisualEditor on the Math board.Thu, May 26, 4:48 PM

Add Comment