Page MenuHomePhabricator

Convert DeleteAction.php/SpecialUndelete.php to use OOUI
Closed, ResolvedPublic

Description

BeforeAfter

Event Timeline

Jdforrester-WMF raised the priority of this task from to Normal.
Jdforrester-WMF updated the task description. (Show Details)

Partial dupe of T117794?

Change 352863 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Convert article delete to use OOUI

https://gerrit.wikimedia.org/r/352863

Change 352874 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Convert Special:Undelete search form to use OOUI

https://gerrit.wikimedia.org/r/352874

Partial dupe of T117794?

Adjusted parentage to make this work.

Change 361026 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Convert rest of Special:Undelete to OOUI

https://gerrit.wikimedia.org/r/361026

Change 352874 merged by jenkins-bot:
[mediawiki/core@master] Convert Special:Undelete search form to use OOUI

https://gerrit.wikimedia.org/r/352874

Change 352863 merged by jenkins-bot:
[mediawiki/core@master] Convert article delete to use OOUI

https://gerrit.wikimedia.org/r/352863

Change 361026 merged by jenkins-bot:
[mediawiki/core@master] Convert rest of Special:Undelete to OOUI

https://gerrit.wikimedia.org/r/361026

Let's consider RevisionDelete separately, it's an entirely different functionality (and we've done mostly everything else here, so it'd be nice not to block this task on that).

matmarex renamed this task from Convert DeleteAction.php/SpecialUndelete.php/SpecialRevisiondelete.php to use OOUI to Convert DeleteAction.php/SpecialUndelete.php to use OOUI.Jul 12 2017, 7:55 PM

After the changes here:

The button and checkboxes at the bottom of Special:Undelete are unchanged. Is that in scope? (The same kind of button and checkboxes are shown e.g. on history pages, which are not OOUI yet, so we might want to leave that for later.)

Jdforrester-WMF closed this task as Resolved.Jul 12 2017, 8:36 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF removed a project: Patch-For-Review.

The button and checkboxes at the bottom of Special:Undelete are unchanged. Is that in scope? (The same kind of button and checkboxes are shown e.g. on history pages, which are not OOUI yet, so we might want to leave that for later.)

I was thinking of doing that with history pages, yes. They're all generated by HistoryListItemFactoryClassMaker.php or whatever, right?

Looking at the code, it seems all of this is duplicated in
SpecialUndelete… I guess we might want to deal with that first.

Volker_E updated the task description. (Show Details)Jul 13 2017, 7:09 AM
matmarex updated the task description. (Show Details)Jul 13 2017, 5:34 PM

For future reference this has caused T171405. If you are working on more deletion or revdel OOUI-js conversion please do verify that all previous options still work. Thanks!

In MonoBook (using the Apex theme) the delete button looks like a lightish red on a white background, is that enough contrast to meet AA/AAA?

Change 373928 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Convert rev preview on special:undelete to OOUI

https://gerrit.wikimedia.org/r/373928

Restricted Application added a subscriber: jeblad. · View Herald TranscriptAug 25 2017, 5:14 PM

Change 373928 abandoned by Esanders:
Convert rev preview on special:undelete to OOUI

Reason:
Icb550a6ad8f90d7718441ec17a1026a2cfb9d754

https://gerrit.wikimedia.org/r/373928