Cross-wiki notifications: Links for thanks notifications point to the local wiki
Closed, ResolvedPublic

Krenair created this task.Feb 3 2016, 11:19 PM
Krenair updated the task description. (Show Details)
Krenair raised the priority of this task from to Needs Triage.
Krenair added projects: Notifications, Thanks.
Krenair added a subscriber: Krenair.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptFeb 3 2016, 11:19 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
Etonkovidova added a subscriber: Etonkovidova.EditedFeb 4 2016, 12:32 AM

I just checked it in beta - cross-wiki thanks worked correctly.

test.wikipedia.org and test2.wikipedia.org worked too.

Mattflaschen-WMF removed Mattflaschen-WMF as the assignee of this task.Feb 4 2016, 2:41 AM

I can reproduce that between he.wiki and a thank on pl.wiki.

It might be related to the fact pl.wiki didn't get cross-wiki notifications yet.

hoo added a subscriber: hoo.Feb 20 2016, 7:19 PM
Trizek-WMF triaged this task as High priority.Feb 22 2016, 8:13 AM

Triaged as Hugh, due to the important number of feedback received.

I can reproduce that between he.wiki and a thank on pl.wiki.

It might be related to the fact pl.wiki didn't get cross-wiki notifications yet.

Cross-wikis Notifications are not related to the wikis where the feature has been activated: that feature is like an inbox, where all notifications are gathered. To illustrate, I've experienced that bug on fr.wp with a thank from it.wp, and on Commons, with a thank from fr.wp.

Mattflaschen-WMF removed Mattflaschen-WMF as the assignee of this task.Feb 23 2016, 4:50 PM
Mattflaschen-WMF added a subscriber: Mattflaschen-WMF.

Change 272775 had a related patch set uploaded (by Sbisson):
Echo API returns absolute URLs in notification links

https://gerrit.wikimedia.org/r/272775

Change 272775 merged by jenkins-bot:
Echo API returns absolute URLs in notification links

https://gerrit.wikimedia.org/r/272775

Change 272780 had a related patch set uploaded (by Catrope):
Echo API returns absolute URLs in notification links

https://gerrit.wikimedia.org/r/272780

Change 272781 had a related patch set uploaded (by Catrope):
Echo API returns absolute URLs in notification links

https://gerrit.wikimedia.org/r/272781

Change 272780 merged by jenkins-bot:
Echo API returns absolute URLs in notification links

https://gerrit.wikimedia.org/r/272780

Change 272781 merged by jenkins-bot:
Echo API returns absolute URLs in notification links

https://gerrit.wikimedia.org/r/272781

Checked Mention and Thanks for cross wiki notifications on testwiki, fr.wiki, he.wiki, wikidata - seems to be fixed.

jmatazzoni closed this task as Resolved.Feb 25 2016, 12:52 AM
jmatazzoni added a subscriber: SBisson.