Page MenuHomePhabricator

Evaluate UX/Design for Performance Inspector
Closed, DeclinedPublic

Description

Work with Peter H/Ori on Performance team to determine heuristic/testing flow for performance inspector.

Event Timeline

dchen created this task.Jun 24 2016, 5:55 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 24 2016, 5:55 PM
dchen edited projects, added Design-Research; removed WMF-Design.Jun 24 2016, 5:56 PM
dchen moved this task from Backlog to In Progress on the Design-Research board.
Capt_Swing added a subscriber: Capt_Swing.

@dchen do you still want to take on this task? Is it still valid?

dchen added a comment.Sep 27 2016, 4:44 PM

@Capt_Swing no updates for a couple months. i'd say can be frozen or closed for now.

dchen added a comment.Sep 27 2016, 4:49 PM

assigning back to DR

dchen reassigned this task from dchen to aripstra.Sep 27 2016, 4:49 PM
dchen edited projects, added Design-Research-Backlog; removed Contributors-UX-Research.

@ori is there still a need for this work? I would be working on this now that Daisy is in the Editing team. Please let me know status. Thanks!

@Krinkle @Gilles Do you know what this ticket is about? If so, does Performance still want Design Research help. Thanks!

@Gilles
Design Research would like to remove itself from this ticket.

@Aklapper
If we remove Design Research (see above comment to @Gilles) that would mean that no projects would be associated with this ticket. Please help!

I believe that the issue of where the inspector is invoked from is still unresolved, but I don"t know if that's part of what this task was meant to solve. @Peter please comment.

Peter added a comment.Jan 20 2017, 2:08 PM

T129322 is for the discussion where/how the inspector should be invoked.

I am reaching out to Daisy to see if she has any documentation from the beginning of the research, and what the research question was, and what point she got to. Will update here when I hear back from her.

Also, after reading T129322 (about where the inspector should be invoked) it looks like it is not really resolved. (To be honest, I read SOME of the discussion on the task.) Is the work blocked on this decision?

I am wondering if the inspector could benefit from a basic heuristic evaluation of the UX? There is a lot of feedback in the ticket from many perspectives, and not only about where to invoke.

It might also be useful to observe some people (the people who the tool was designed and built for) using the inspector, and see what works and doesn't for them. We could ask them their opinions of where it might be invoked and if they need it on mobile, etc.

@Peter
Removing Design Research project for now. Please feel free to add us back when something for us to do. Thanks!

@Aklapper
If we remove Design Research (see above comment to @Gilles) that would mean that no projects would be associated with this ticket. Please help!

Someone needs to clarify if this is still wanted and what this task is about. Following https://www.mediawiki.org/wiki/Phabricator/Project_management#Use_plain_language.2C_define_actions_and_expected_results would help.

Peter added a comment.Feb 22 2017, 6:59 PM

Hey @aripstra let setup a meeting so we can sync, maybe that is easier.

We need to get an OK where we can place the link to start the inspector, we don't have that today and also checking the usability/look and feel would be great.

You can test out the current version of the inspector on https://en.wikipedia.beta.wmflabs.org/wiki/Chamber_music (search for Performance inspector under the Tools menu).

Krinkle renamed this task from Performance Inspector to Evaluate UX/Design for Performance Inspector.Apr 5 2017, 7:32 PM
Peter triaged this task as Medium priority.May 30 2017, 9:42 AM
Imarlier closed this task as Declined.Jun 21 2018, 9:42 AM

With the new plans for Performance Inspector, this is moot.