Page MenuHomePhabricator

Notice: Undefined index: width in /srv/mediawiki/php-1.28.0-wmf.7/includes/Linker.php
Closed, ResolvedPublic

Description

Suddenly quite a bit of log spam all from:

Notice: Undefined index: width in /srv/mediawiki/php-1.28.0-wmf.7/includes/Linker.php on line 758
Notice: Undefined index: width in /srv/mediawiki/php-1.28.0-wmf.7/includes/Linker.php on line 756

At 1.28.0-wmf.12 this is now lines 760 and 762.

At 1.28.0-wmf.14 this is now lines 754 and 752.

At 1.29.0-wmf.7 this is now lines 750 and 752.

Details

Related Gerrit Patches:
mediawiki/extensions/ParsoidBatchAPI : masterDo not generate responsive images for iconThumb
mediawiki/core : masterDebug Logging for Undefined index: width in Linker.php
mediawiki/core : wmf/1.28.0-wmf.13Debug Logging for Undefined index: width in Linker.php
mediawiki/core : wmf/1.28.0-wmf.12Debug Logging for Undefined index: width in Linker.php
operations/mediawiki-config : masterDebug logging for T138987

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 29 2016, 9:06 PM

Change 302084 had a related patch set uploaded (by Addshore):
Debug Loggin for Undefined index: width in Linker.php

https://gerrit.wikimedia.org/r/302084

Change 302085 had a related patch set uploaded (by Addshore):
Debug logging for T138987

https://gerrit.wikimedia.org/r/302085

Change 302226 had a related patch set uploaded (by Addshore):
Debug Logging for Undefined index: width in Linker.php

https://gerrit.wikimedia.org/r/302226

Change 302085 merged by jenkins-bot:
Debug logging for T138987

https://gerrit.wikimedia.org/r/302085

Mentioned in SAL [2016-08-01T15:25:25Z] <addshore@tin> Synchronized wmf-config/InitialiseSettings.php: [[gerrit:302085|Debug logging for T138987]] (duration: 00m 26s)

Change 302226 merged by jenkins-bot:
Debug Logging for Undefined index: width in Linker.php

https://gerrit.wikimedia.org/r/302226

Addshore added a subscriber: Addshore.EditedAug 1 2016, 8:59 PM

2 occurrences of:

mw1285 frwiki 1.28.0-wmf.12 T138987 INFO: Undefined index: width inLinker::processResponsiveImages {"trace":"Linker.php line 756 calls wfBacktrace()\nApiParsoidBatch.php line 211 calls Linker::processResponsiveImages()\nApiParsoidBatch.php line 89 calls ApiParsoidBatch->imageinfo()\nApiMain.php line 1435 calls ApiParsoidBatch->execute()\nApiMain.php line 508 calls ApiMain->executeAction()\nApiMain.php line 479 calls ApiMain->executeActionWithErrorHandling()\napi.php line 83 calls ApiMain->execute()\napi.php line 3 calls include()\n"}
INFO: Undefined index: width in Linker::processResponsiveImages
Linker.php line 756 calls wfBacktrace()
ApiParsoidBatch.php line 211 calls Linker::processResponsiveImages()
ApiParsoidBatch.php line 89 calls ApiParsoidBatch->imageinfo()
ApiMain.php line 1435 calls ApiParsoidBatch->execute()
ApiMain.php line 508 calls ApiMain->executeAction()
ApiMain.php line 479 calls ApiMain->executeActionWithErrorHandling()
api.php line 83 calls ApiMain->execute()
api.php line 3 calls include()
Dereckson updated the task description. (Show Details)Aug 3 2016, 12:29 AM

Change 302681 had a related patch set uploaded (by Addshore):
Debug Logging for Undefined index: width in Linker.php

https://gerrit.wikimedia.org/r/302681

Change 302681 merged by jenkins-bot:
Debug Logging for Undefined index: width in Linker.php

https://gerrit.wikimedia.org/r/302681

Dereckson updated the task description. (Show Details)Aug 11 2016, 11:38 PM

Change 302084 abandoned by Addshore:
Debug Logging for Undefined index: width in Linker.php

https://gerrit.wikimedia.org/r/302084

So the issue is the Linker::processResponsiveImages method could be called without $hp['width'] to be defined.

ssastry triaged this task as Normal priority.

This is now showing up in wmf.9:

Notice: Undefined index: width in /srv/mediawiki/php-1.29.0-wmf.9/includes/Linker.php on line 654

mmodell raised the priority of this task from Normal to High.Jan 27 2017, 9:10 PM

This is still happening and has evidently been happening since June of last year. In looking through this task it seems that we've traced it down to the ParsoidBatchApi 's imageinfo action. @tstarling have you had a chance to look at this? The Release-Engineering-Team is trying to dig out from under a mountain of accumulated logspam and this would be helpful for the cause.

https://logstash.wikimedia.org/goto/5e1b2cf98033e1a64dad89b6b75e5e72

Change 336569 had a related patch set uploaded (by Tim Starling):
Do not generate responsive images for iconThumb

https://gerrit.wikimedia.org/r/336569

Change 336569 merged by jenkins-bot:
Do not generate responsive images for iconThumb

https://gerrit.wikimedia.org/r/336569

Worth back-porting?

Addshore removed a subscriber: Addshore.Feb 9 2017, 4:47 PM

I guess not.

mmodell closed this task as Resolved.Feb 14 2017, 7:43 PM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:11 PM