Page MenuHomePhabricator

Promote the signature button to the toolbar (or somewhere else more prominent) in VE/NWE
Closed, DeclinedPublic

Description

When adding some comment on a talk page you have to click 3 times to insert your signature. People that've never used VE and used to stick to the OWE, would probably have to click more just to locate it while using NWE for the first time. So my suggestion is to take the signature button out of the "insert" dialog and put it directly on the panel so that it would become accessible in a single click.

I think this inconvenience might prevent some interested users from using the beta feature.

And please consider adding two hyphens in front of the four tildes, just like in the standard signature.

Event Timeline

Restricted Application added subscribers: Base, Aklapper. · View Herald TranscriptDec 14 2016, 9:18 PM

We try to keep the toolbar layout the same in all modes, so promoting the signature to the root toolbar (where we already have limited space, and it wouldn't have a label) would mean it should be there in article mode, but disabled.

That said I appreciate it is a very useful tool on talk pages, although I wonder how often it is actually used...

Piramidion added a comment.EditedDec 14 2016, 10:28 PM

That said I appreciate it is a very useful tool on talk pages, although I wonder how often it is actually used...

I didn't understand this part. Under "tool" you mean the signature button? Then again, I don't understand the question. Signature is used everytime someone leaves a comment. Isn't that often enough to implement the suggested change?

That said I appreciate it is a very useful tool on talk pages, although I wonder how often it is actually used...

I didn't understand this part. Under "tool" you mean the signature button? Than again, I don't understand the question. Signature is used everytime someone leaves a comment. Isn't that often enough to implement the suggested change?

The last time we measured this I believe it was very rare for people to click on the "sign" button in the existing wikitext editor. By far, people just write ~~~~.

Jdforrester-WMF renamed this task from NWE should have a signature button right on the panel on all the talk and Wikipedia namespaces to Promote the signature button to the toolbar (or somewhere else more prominent) in VE/NWE.Dec 14 2016, 10:30 PM

How about upgrading the button's priority in the "insert" dialog for talk and Wikipedia namespaces, and downgrading or completely hiding it for all the other namespaces?

The last time we measured this I believe it was very rare for people to click on the "sign" button in the existing wikitext editor. By far, people just write ~~~~.

I don't believe this is true for wikis that use cyrillic script. In most cases in Ukrainian wikis people use the signature with two hyphens. It's standard and I don't think they write all those manually. Besides, to type the ~ symbol a user needs either to use

Ctrl+Shift+`

or switch the keyboard layout to some Latin variant and type the tilde using

Shift+`

After a few edits on talk pages I must agree with Piramidion.

Please note that while the key for ~ is hard to reach on most keyboard layouts - except English. So if you did your statistics on English Wikipedia, it's probably flawed.

I do understand and appreciate the argument that the toolbar should have the same layout on every page. But content and talk pages are really different, so please reconsider whether this is really a good argument. When you switch positions for "Cite" and "Signature" on talk pages, you shouldn't run into problems with limited space (and for wikis that don't have the "Cite" button in the main toolbar, there should be room enough anyway). But at least promote it to be accessible without clicking "More".

I also agree that the signature should be preceded by to dashes. It has been that way for years now, and users are used to it to easily separate the comment from the signature.

Elitre added a subscriber: Elitre.Dec 15 2016, 4:29 PM

After I thought a bit about this, I'd like to propose a different approach:

  • Find a way to determine whether edits should be signed on a page or not. In most (though not all) cases this is equivalent to the existence of a "Add new section" tab. For a beta feature this is probably good enough, whether some tweaks are needed could be decided later.
  • When a user clicks "Save changes" on such a page, but no signature is found in his edit, show a dialog explaining the situation with three options:
    • Automatically add signature at the end (default)
    • Continue editing to add signature automatically
    • Continue saving without a signature

This would change the workflow from "Always sign your posts on talk pages" to "Only sign if you want to put your signature in some special place (e.g. inserting a comment somewhere in the middle of a thread or adding a postscriptum), and let the editor sign for you automatically otherwise". I think, all users would benefit from this:

  • New users don't have to learn about signatures, they can let the editor do all the work.
  • For experienced editors (especially those who type in the tildes via keyboard) nothing changes. But if they forget their signature (which rarely happens), they get a warning.
  • Editors still have full control over when and where to sign.
  • Manual signatures are rare enough to justify the current placement of the signature tool.

Perhaps the best reason to promote the signature button to the toolbar (on talk pages, at least), or at least to call out its existence, is for the benefit of new editors.

New users don't know that talk-page comments need to be manually signed, and they definitely won't know that they can type four tildes to do so.

It is unrealistic to assume that new editors will go digging around through the Insert menu just to see whether there might be anything useful in there.

We try to keep the toolbar layout the same in all modes, so promoting the signature to the root toolbar (where we already have limited space, and it wouldn't have a label) would mean it should be there in article mode, but disabled.

In some projects (e.g., Meta and mediawiki.org), you need signatures in the mainspace, too.

Tgr added a subscriber: Tgr.Dec 23 2016, 11:01 AM

The last time we measured this I believe it was very rare for people to click on the "sign" button in the existing wikitext editor. By far, people just write ~~~~.

I wonder if that's language-dependent. In hu.wikipedia for example, the proper signature is <en dash><nbsp>~~~~ which is a pain in the ass to type.

@Tgr, that's trivially easy on my Mac: option-hyphen, option-space, four tildes. But if that's considered the "proper" signature locally, then why don't you go to Special:Preferences and insert the en-dash and non-breaking space directly into your sig? Or even figure out if the default could be changed for everyone, so that new users and people who can't remember how to type those characters can have "proper" signatures, too?

Tgr added a comment.Dec 30 2016, 8:56 PM

@Tgr, that's trivially easy on my Mac: option-hyphen, option-space, four tildes.

OSX makes for less than 10% of desktop traffic so it's not very relevant from a usability point of view. (On Windows it's press left Alt, 0, 1, 5, 0, release left Alt, press left Alt, 0, 1, 6, 0, release left Alt; on Unix it's a jumble of various super-convoluted input methods (e.g. press left Shift, press right Alt, release left Shift, release left Alt, type two hyphens and a dot) which depend on all kinds of system settings and software choices so most of them don't work on any given machine. In any case, most users are not aware of these.)

But if that's considered the "proper" signature locally, then why don't you go to Special:Preferences and insert the en-dash and non-breaking space directly into your sig?

That would result in double dash/space in all editors which can already handle localized signatures.

Or even figure out if the default could be changed for everyone, so that new users and people who can't remember how to type those characters can have "proper" signatures, too?

That would be T154014: VE: Use message sig-text when inserting a signature. Not very useful when the signature button gets hidden, though.

  • Find a way to determine whether edits should be signed on a page or not. In most (though not all) cases this is equivalent to the existence of a "Add new section" tab. For a beta feature this is probably good enough, whether some tweaks are needed could be decided later.

This already exists, MWNamespace::wantSignatures() (a namespace "wants" signatures if it's a talk namespace or listed in $wgExtraSignatureNamespaces). This already controls whether the signature button is shown/enabled (in both VE and old wikitext editor).

  • Find a way to determine whether edits should be signed on a page or not. In most (though not all) cases this is equivalent to the existence of a "Add new section" tab. For a beta feature this is probably good enough, whether some tweaks are needed could be decided later.

This already exists, MWNamespace::wantSignatures() (a namespace "wants" signatures if it's a talk namespace or listed in $wgExtraSignatureNamespaces). This already controls whether the signature button is shown/enabled (in both VE and old wikitext editor).

The issue is that many pages in Project namespace should not be signed. While it doesn't hurt to show the signature button there, no automatic signing should happen there. OTOH, the existence of an "Add new section" tab does show whether an edit should be signed in a much more reliable way.

Hmm, good point.

I can't think of any case where the "Add new section" button would be added
on non-talk pages, so it should be an okay temporary workaround, but there
are probably cases where a page with one section only needs signatures
(e.g. on some wikis, village pumps have separate subpages for each
discussion), so we'd probably have to introduce another magic word (or
something) to define this per-page...

[...] but there are probably cases where a page with one section only needs signatures
(e.g. on some wikis, village pumps have separate subpages for each
discussion), so we'd probably have to introduce another magic word (or
something) to define this per-page...

At least all "Commons:Deletion requests/foo" pages should be signed, but don't have "Add new section" button.

[...] but there are probably cases where a page with one section only needs signatures
(e.g. on some wikis, village pumps have separate subpages for each
discussion), so we'd probably have to introduce another magic word (or
something) to define this per-page...

At least all "Commons:Deletion requests/foo" pages should be signed, but don't have "Add new section" button.

Some languages (like cswiki) RFC pages too

I've seen a Wikipedia that had an "Add new section" tab in the mainspace. It seemed like a strange idea to me, and I don't remember which one is was, but this might not be a foolproof way of identifying pages that want signatures.

clel added a subscriber: clel.May 9 2017, 9:55 AM

Is there any update on this?

Dvorapa added a comment.EditedMay 29 2017, 10:51 AM

I agree with @Schnark. Btw why not just port the current functionality from OWE, where this works like a charm? Not all OWE functionalities are wrong. Mainly for novice users are signature button presence and its highlighting among other buttons crucial in discussions.

(If this ever worked "like a charm", we wouldn't have to remind that it exists all the time, or bots that add the unsigned template everywhere.)

Jdforrester-WMF closed this task as Declined.Jun 2 2017, 1:32 AM

As described above and previously, there's no room on the toolbar to add this button as a top line item (in fact, the toolbar is already too heavy for many users' screens). It is not more important than any of the existing controls in the toolbar, so we're not going to demote anything and replace it.

I agree that legacy talk pages are disasters in usability, but the 'solution' to that is known (if unappetising to many experienced users). It is not a good idea to make the editing experience worse in a vain attempt to get total newbies to know how to participate on a page.

Does the "declining" refer only to the narrow task "Promote the signature tool to the main toolbar", or does it also refer to the more broader task (which has been discussed here, too) "Make signing easier in VE/NWE by whatever means seem appropriate"?
If it's just the former, I'll create a new task for my idea in T153255#2879829. But if no change is made to make signatures much easier in NWE, NWE can't become the default source editor for all users unless the wiki completely switched to Flow for discussions, which in my opinion is a very bad decision.

Deskana added a subscriber: Deskana.Jun 2 2017, 8:36 AM

Does the "declining" refer only to the narrow task "Promote the signature tool to the main toolbar", or does it also refer to the more broader task (which has been discussed here, too) "Make signing easier in VE/NWE by whatever means seem appropriate"?

Other ways to make signing easier can be considered, yes. :-)

clel added a comment.Jun 16 2017, 12:36 PM

@Jdforrester-WMF Well, at least for me there seems to be plenty of space. So why not detect the screen size and then add the button if there is space (responsive design)?

@Jdforrester-WMF Well, at least for me there seems to be plenty of space. So why not detect the screen size and then add the button if there is space (responsive design)?

Yes, there's space, but that's missing the point. We could add buttons and shortcuts for almost everything into dropdowns, or shrink the buttons, so there's always going to be space. The problem is, each time we do that, we increase clutter, increase cognitive overhead, and reduce the usefulness of the remaining shortcuts.

clel added a comment.Jun 16 2017, 3:13 PM

@Deskana I was referring to what @Jdforrester-WMF wrote. He was only referring to space problems he mentioned.

Referring to your point: Currently it is very hard to use conversation pages because of this lacking button, which is pretty important to most users. So I think such an important option should not be hidden inside a dropdown menu somewhere. This is simply ignoring the way how conversation pages work currently. If this is changed, the button can get removed again. Until now I think adding it would be the better solution.

Dvorapa added a comment.EditedNov 4 2018, 8:12 AM

As described above and previously, there's no room on the toolbar to add this button as a top line item (in fact, the toolbar is already too heavy for many users' screens).

I understand the result, but it seems a little bit funny to me, that there is no room in VE/NWE's toolbar, but in OWE's toolbar there is still a plenty of room to add signature button, syntax highlighting button, gadget buttons and drop-down menus etc.

It is a complete nonsense to hide the signature button in three-click depth, this decision is increasing the "cognitive overhead" and not the other way around. Anyone who ever participated in a discussion on a Village pump understands what I am talking about. Decline of this issue seems to me more of "dont bother us" than a thought based resolution.

Elitre removed a subscriber: Elitre.Nov 8 2018, 4:54 PM