Page MenuHomePhabricator

Content Translation does not publish the translation
Closed, ResolvedPublic

Description

I used Content Translation, hit the "Publish translation". But the publication did not take place. Thus appeared the inscription:"При публикации перевода произошла ошибка. Пожалуйста, попробуйте опубликовать страницу ещё раз. Ошибка: Error converting HTML to wikitext: docserver-http: HTTP 400 ". The translation is:" When you publish a translation error occurred. Please try to publish the page again. Error: Error converting HTML to wikitext: docserver-http: HTTP 400".

Event Timeline

Arbnos created this task.Dec 25 2016, 8:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 25 2016, 8:36 PM

Thank you! Works, topic can be closed.

Arbnos added a comment.EditedFeb 25 2017, 9:45 PM

Thank you! Works, topic can be closed.

Again the same thing. That is not working.

Amire80 added a subscriber: Amire80.Mar 7 2017, 6:49 AM

At which article does this happen?

Sunpriat added a subscriber: Sunpriat.EditedJun 30 2017, 6:31 PM

Several users report a similar problem arising from time to time.
https://ru.wikipedia.org/w/index.php?title=%D0%92%D0%B8%D0%BA%D0%B8%D0%BF%D0%B5%D0%B4%D0%B8%D1%8F:%D0%A4%D0%BE%D1%80%D1%83%D0%BC/%D0%A2%D0%B5%D1%85%D0%BD%D0%B8%D1%87%D0%B5%D1%81%D0%BA%D0%B8%D0%B9&oldid=86276285#.D0.A7.D1.82.D0.BE_.D1.81_.D0.B0.D0.B2.D1.82.D0.BE.D0.BF.D0.B5.D1.80.D0.B5.D0.B2.D0.BE.D0.B4.D1.87.D0.B8.D0.BA.D0.BE.D0.BC.3F

User LGB report that "https://en.wikipedia.org/wiki/Special:Redirect/revision/759901751 When you try to publish the same message is displayed
При публикации перевода произошла ошибка. Пожалуйста, попробуйте опубликовать страницу ещё раз. Ошибка: Error converting HTML to wikitext: docserver-http: HTTP 400
But two days later, when he try to publish in a user namespace instead of the main ns, everything worked fine.
In the spring there was a similar case."

User Tatewaki reports that he too received this message several times.
For now so stuck translations (Tatewaki): en:Masahide Ōta, en:Princess Pingyang, en:Martha Karua --> ruPW. And there was a problem with https://ru.wikipedia.org/wiki/%D0%A3%D1%87%D0%B0%D1%81%D1%82%D0%BD%D0%B8%D0%BA:Tatewaki/%D0%9B%D0%B0%D0%B3%D1%83,_%D0%A0%D0%B8%D0%BC%D0%B0 but resolved through publication in user ns.

Amire80 moved this task from Needs Triage to Bugs on the ContentTranslation board.Jul 2 2017, 1:10 PM
Elitre added a comment.EditedOct 6 2017, 5:03 PM

There are multiple reports at mw.org as well. I tried to point all the threads I found to this task.

Elitre added a subscriber: Arrbee.Oct 6 2017, 5:04 PM

Here is a screenshot that makes me wonder, could there be a problem with MT, Apertium in particular? The user who made https://it.wikipedia.org/wiki/Utente:Fringio/Sergio_Hern%C3%A1ndez_(actor) says he couldn't even save if he used Apertium's provided translation.

JOAN added a subscriber: JOAN.Oct 21 2017, 1:56 AM

The same thing happens to me when translating the article "Self-efficacy" from English to Spanish, I get the following

  • Error: Error: Error converting HTML to wikitext: docserver-http: HTTP 400.

What can we do?

could there be a problem with MT, Apertium in particular?

Possible, but please remember it also happens to those of us who use the Yandex translation, which is not based on Apertium as such, I believe. (see reports at mediawiki.org).

JOAN added a comment.EditedOct 21 2017, 8:51 PM

I found a partial solution, which solved my problem. Do not use Apertium, just use the Yandex translation. So I managed to publish the article: Autoeficacia.

Arrbee assigned this task to santhosh.Oct 27 2017, 8:46 AM
Arrbee triaged this task as High priority.
Arrbee added a project: Language-2017-Oct-Dec.
Arrbee moved this task from Backlog to In Progress on the Language-2017-Oct-Dec board.
Arrbee moved this task from Bugs to Oct-Dec 2017 on the ContentTranslation board.Oct 27 2017, 8:49 AM

@santhosh , it'd be useful to understand which articles you've examined so far, as there were so many reports and I can't know which links you followed.

Here's another example from mw.prg:

This error message don't allows to publish my translation

Error converting HTML to wikitext: docserver-http: HTTP 400

Translating this page from English To spanish: https://en.wikipedia.org/wiki/Disability-adjusted_life_year

the problem is when trying to translate the section "See also", it appears on the translation with unknow symbol, and I can't delete this section from the translation now.

I could reproduce the issue now. It was tricky.

The issue happens with template adaptation. Failed template adaptation causes markup like <span typeof="mw:Transclusion'> without data-mw or about parameters. Parsoid will crash on such invalid HTML and give 400. The root cause for failure was cxserver HTML sanitization in MT api blacklisting the about attribute and removing it. Without about attribute, data-mw cannot be copied from source section.

In cxserver had rectified this issue https://gerrit.wikimedia.org/r/#/c/381960/ eventhough the intention was not fixing this. Deploying cxserver master to production should fix template adaptation and publishing error.

Change 387783 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] CX1: Check for template adaptation failures before publishing

https://gerrit.wikimedia.org/r/387783

Nikerabbit added a comment.EditedNov 1 2017, 12:07 PM

Deploying cxserver master to production should fix template adaptation and publishing error.

Also for existing translations or only new ones?

Edit: I assume your patch is there for existing ones.

Change 387783 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] CX1: Check for template adaptation failures before publishing

https://gerrit.wikimedia.org/r/387783

Change 387996 had a related patch set uploaded (by KartikMistry; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@wmf/1.31.0-wmf.6] CX1: Check for template adaptation failures before publishing

https://gerrit.wikimedia.org/r/387996

Change 387996 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@wmf/1.31.0-wmf.6] CX1: Check for template adaptation failures before publishing

https://gerrit.wikimedia.org/r/387996

Mentioned in SAL (#wikimedia-operations) [2017-11-02T13:35:43Z] <zfilipin@tin> Synchronized php-1.31.0-wmf.6/extensions/ContentTranslation/modules/publish/ext.cx.publish.js: SWAT: [[gerrit:387996|CX1: Check for template adaptation failures before publishing (T154116)]] (duration: 00m 50s)

Arrbee moved this task from In Progress to Done on the Language-2017-Oct-Dec board.Nov 6 2017, 7:19 AM

Should this fix work for older articles that ended up being unloadable (grey overlay when loading, the three dots on top blinking ad nauseam, publish button greyed out)? If it should - it didn't in my case.

Should this fix work for older articles that ended up being unloadable (grey overlay when loading, the three dots on top blinking ad nauseam, publish button greyed out)? If it should - it didn't in my case.

No. that is not the issue we fixed. Do we have a ticket for the issue you mentioned? if not we should have one and investigate.

@santhosh , I just published it under a new ticket to more easily distinguish the problems. T179997

Arrbee closed this task as Resolved.Dec 4 2017, 7:23 AM