Page language variants should link to mobile view and not desktop view
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Open a random page (on cswiki) in mobile web browser on mobile
  2. Tap the page in other languages button
  3. Tap one of the language variants

Expected behavior:
Link leads to mobile view page.

Current behavior:
Link opens desktop view page instead.

Note: Sometimes it behaves correctly, it opens a different language dialog, from which mobile view is openned, but only in 1 of 10 cases (or less).

Exact steps to reproduce:

  1. Have Android 4.4.2 Sony Xperia E1 (480 × 800 screen, portrait mode) with Maxthon 5 browser installed; be logged in to Wikipedia and have Beta features switched on on mobile (previously, I assume it is stored in cookies then)
  2. Open cs.wikipedia.org
  3. As you can see in the url, you were redirected to .m. mobile version. You are seeing a mobile version, everything is as it should be.
  4. Tap hamburger icon
  5. Tap "Random" option ("Náhodně"; it works on any page, therefore this is the best option to try)
  6. Tap language icon (if possible = if there is any language variant)
  7. Tag any language (e.g. english)

Related: T107108 and T154750

Dvorapa created this task.Jan 29 2017, 10:03 AM
Dvorapa edited the task description. (Show Details)
Dvorapa edited the task description. (Show Details)

Example: Visit https://cs.m.wikipedia.org/wiki/Tosca#/languages and click on azərbaycanca and you'll be taken to https://az.wikipedia.org/wiki/Toska (Desktop site).

ovasileva triaged this task as "Normal" priority.Jan 30 2017, 3:07 PM
ovasileva moved this task from To Triage to Triaged but Future on the Reading-Web-Backlog board.
ovasileva added a subscriber: ovasileva.

@ovasileva - this might be a duplicate of previous bug. check closed/low priority to find.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptJan 30 2017, 4:31 PM
Dvorapa edited the task description. (Show Details)Feb 1 2017, 2:33 PM
ovasileva reopened this task as "Open".Feb 1 2017, 2:33 PM
Amire80 added a subscriber: Amire80.Feb 1 2017, 3:30 PM

@Dvorapa can you give a specific URL where you see this happening and tell me what you click on? Can you also tell me your browser user agent or the web browser you are using.

If you are hitting the desktop site on mobile this can only happen if your user agent is not recognised as mobile or you have previously viewed the desktop site on that device.

I'm fairly confident this is the same as T67047 - I just want to make sure I understand your problem fully as there have been confusion so far.

I'm also pretty confident that it's the same as T67047, especially as @Dvorapa's comment there says: it affects mobile users on the mobile site, which is a big audience. It happens to me all the time when I tap on the language icon at the top and then tap on one of the languages.

Dvorapa added a comment.EditedFeb 1 2017, 7:32 PM

@Dvorapa can you give a specific URL where you see this happening and tell me what you click on? Can you also tell me your browser user agent or the web browser you are using.

Exact steps to reproduce:

  1. Have Android 4.4.2 phone with Maxthon 5 browser installed; have Beta features switched on on mobile (previously, I assume it is stored in cookies then)
  2. Open cs.wikipedia.org
  3. As you can see in the url, you were redirected to .m. mobile version. You are seeing a mobile version, everything is as it should be.
  4. Tap hamburger icon
  5. Tap Random option ("Náhodně"; it works on any page, therefore this is the best option to try)
  6. Tap language icon (if possible = if there is any language variant)
  7. Tag any language (e.g. english)
Dvorapa added a comment.EditedFeb 1 2017, 7:35 PM

As I said before, sometimes when I browse through Wikipedia pages some time, it could open a different language dialog and in that all link lead to mobile links. But it is just 1 of 10 or 20 cases (rarely)

This comment was removed by Dvorapa.
ovasileva added a subscriber: ABorbaWMF.

@ABorbaWMF - do you think you could look at this and try to reproduce? There's a number of bugs around this and it seems intermittent

Unable to reproduce on the following:

Nexus 4 Android 4.2 - Maxthon 4.4 & Chrome Mobile 42
Nexus 5 Android 4.4 - Maxthon 4.3 & Chrome Mobile 44
Nexus 6P Android 7.0 - Maxthon 4.5 & Chrome Mobile 55
Galaxy S4 Android 4.2 - Maxthon 4 & Chrome Mobile 33
Galaxy S5 Android 5.0 - Maxthon 4.5 & Android 5.0

I also attempted to reproduce while logged out and logged in and with/out beta features enabled. I tried switching to various languages on a bunch of different (random) pages. I was always brought to a mobile version of the site upon switching languages, even after switching between mobile and desktop versions of various pages.

Dvorapa added a comment.EditedWed, Feb 22, 11:21 PM

@ABorbaWMF I see you tried on Maxthon 4, but I use Maxthon 5

I was using an emulator to test the various combinations of platform and browser. The emulator does not yet have Maxthon 5.

I was able to install Maxthon 5 on real Nexus 4 Android 5.1 phone. I tried the steps again, but I was unable to reproduce the bug. I am getting the right version of the site upon switching languages.

Dvorapa edited the task description. (Show Details)Thu, Feb 23, 7:02 PM
Dvorapa edited the task description. (Show Details)
Dvorapa edited the task description. (Show Details)Thu, Feb 23, 7:05 PM
Dvorapa edited the task description. (Show Details)

Testing on Galaxy S3 SPH-L710T (Android 4.4.2) and Maxthon 5. Reproduction in this environment is working as expected as I was able to switch between the Czech and Polish versions of the article page, both in mobile view:


Dvorapa edited the task description. (Show Details)Fri, Feb 24, 1:23 PM

Let's try testing again when logged in.

Testing on Samsung Galaxy Tab 4 SM‑T230NU (Android 4.4.2) and Maxthon 5. Reproduction in this environment - while logged in as shown by the below screencaps - is working as expected as I was able to switch between the Czech and Polish versions of the article page, both in mobile view:

Dvorapa closed this task as "Resolved".Wed, Mar 1, 10:40 PM
Dvorapa claimed this task.

I tested it today too and found it working. I think this issue has been fixed by accident, therefore closing for now

Dvorapa removed Dvorapa as the assignee of this task.Wed, Mar 1, 10:41 PM

Hi everyone. Saw this in the Tech news draft.
Now I see why I have a problem the last two days: When I'm in mobile, in desktop view, opening a link to other wiki, it always opens in mobile view, and I should scroll down and open the desktop view. Can't it be opened in the same view as the source?

@IKhitron thanks for the comment. I've created a task (T159526) to capture your problem. Can you comment with the name of your phone and the browser you're using? Thanks.

Thank you and no problem.

We have tried both logged in and logged out and with beta features enabled and disabled. So far we have not reproduced it. It seems very rare for @Dvorapa as well. They have only seen it about 1 out of every 10 attempts.

@MBinder_WMF actually has a Sony Xperia Z1 Compact Android 4.4.4 and Maxthon 5 browser. I roped him into to testing this for me and he was unable to reproduce it as well.

One of ten seems to me even worth - it's not deterministic. Maybe something wrong with the cookies.

Dvorapa added a comment.EditedSat, Mar 4, 2:26 PM

@ABorbaWMF No no, it was 9 of 10 times wrong, therefore not rare, but almost every time. Now everything is working as expected