Page MenuHomePhabricator

Notice: Undefined variable: stateObject in /srv/mediawiki/php-1.29.0-wmf.18/extensions/Quiz/Quiz.class.php on line 405
Closed, ResolvedPublic

Description

Notice: Undefined variable: stateObject in /srv/mediawiki/php-1.29.0-wmf.18/extensions/Quiz/Quiz.class.php on line 405

Error started when I pushed 1.29.0-wmf.18 to group1 today

Logstash link: https://logstash.wikimedia.org/goto/3e48721fe58ac74696f88af0037d63c3

#0 /srv/mediawiki/php-1.29.0-wmf.18/extensions/Quiz/Quiz.class.php(405): MWExceptionHandler::handleError(integer, string, string, integer, array, array) 
#1 /srv/mediawiki/php-1.29.0-wmf.18/extensions/Quiz/Quiz.class.php(262): Quiz->parseQuestion(array) 
#2 /srv/mediawiki/php-1.29.0-wmf.18/extensions/Quiz/Quiz.class.php(123): Quiz->parseQuestions(string) 
#3 /srv/mediawiki/php-1.29.0-wmf.18/extensions/Quiz/Quiz.hooks.php(28): Quiz->parseQuiz(string) 
#4 /srv/mediawiki/php-1.29.0-wmf.18/includes/parser/Parser.php(3887): QuizHooks::renderQuiz(string, array, Parser, PPFrame_Hash) 
#5 /srv/mediawiki/php-1.29.0-wmf.18/includes/parser/Preprocessor_Hash.php(1113): Parser->extensionSubstitution(array, PPFrame_Hash) 
#6 /srv/mediawiki/php-1.29.0-wmf.18/includes/parser/Parser.php(2947): PPFrame_Hash->expand(PPNode_Hash_Tree, integer) 
#7 /srv/mediawiki/php-1.29.0-wmf.18/includes/parser/Parser.php(1297): Parser->replaceVariables(string) 
#8 /srv/mediawiki/php-1.29.0-wmf.18/includes/parser/Parser.php(451): Parser->internalParse(string) 
#9 /srv/mediawiki/php-1.29.0-wmf.18/includes/content/WikitextContent.php(330): Parser->parse(string, Title, ParserOptions, boolean, boolean, integer) 
#10 /srv/mediawiki/php-1.29.0-wmf.18/includes/content/AbstractContent.php(497): WikitextContent->fillParserOutput(Title, integer, ParserOptions, boolean, ParserOutput) 
#11 /srv/mediawiki/php-1.29.0-wmf.18/includes/poolcounter/PoolWorkArticleView.php(140): AbstractContent->getParserOutput(Title, integer, ParserOptions) 
#12 /srv/mediawiki/php-1.29.0-wmf.18/includes/poolcounter/PoolCounterWork.php(123): PoolWorkArticleView->doWork() 
#13 /srv/mediawiki/php-1.29.0-wmf.18/includes/page/Article.php(586): PoolCounterWork->execute() 
#14 /srv/mediawiki/php-1.29.0-wmf.18/includes/actions/ViewAction.php(71): Article->view() 
#15 /srv/mediawiki/php-1.29.0-wmf.18/includes/MediaWiki.php(497): ViewAction->show() 
#16 /srv/mediawiki/php-1.29.0-wmf.18/includes/MediaWiki.php(291): MediaWiki->performAction(Article, Title) 
#17 /srv/mediawiki/php-1.29.0-wmf.18/includes/MediaWiki.php(860): MediaWiki->performRequest() 
#18 /srv/mediawiki/php-1.29.0-wmf.18/includes/MediaWiki.php(521): MediaWiki->main() 
#19 /srv/mediawiki/php-1.29.0-wmf.18/index.php(43): MediaWiki->run() 
#20 /srv/mediawiki/w/index.php(3): include(string) 
#21 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 29 2017, 7:16 PM
thcipriani triaged this task as Unbreak Now! priority.Mar 29 2017, 7:24 PM

Added as a blocker for 1.29.0-wmf.18, set UBN!

Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptMar 29 2017, 7:26 PM
thcipriani updated the task description. (Show Details)Mar 29 2017, 11:25 PM
Mvolz added a subscriber: Mvolz.Mar 29 2017, 11:35 PM

Mentioned in SAL (#wikimedia-operations) [2017-03-29T23:46:19Z] <reedy@tin> Synchronized php-1.29.0-wmf.18/extensions/Quiz: Fix undefined variable stateObject T161735 (duration: 00m 49s)

Reedy lowered the priority of this task from Unbreak Now! to High.Mar 29 2017, 11:48 PM

Dropping to High as it doesn't block the train now... Still wants fixing though :)

@cristianbaldi @Mvolz Per comments on https://gerrit.wikimedia.org/r/345476:

Patch https://gerrit.wikimedia.org/r/#/c/339941/ for T152293, was reverted in this week's branch due to the error it caused. If this isn't fixed in master by Tuesday morning PDT, the patch will need to be reverted in master as well.

Change 345476 had a related patch set uploaded (by Mvolz; owner: Reedy):
[mediawiki/extensions/Quiz@master] Revert "Generate questions HTML via TemplateParser"

https://gerrit.wikimedia.org/r/345476

Mvolz added a comment.Apr 3 2017, 1:07 PM

Unfortunately I am unable to reproduce the error locally, but I've submitted a patch that *should* fix it. I'm just unable to test it myself since the faulty patch doesn't throw any errors for me. https://gerrit.wikimedia.org/r/#/c/346140/

Any tips for replicating this locally? I'm using vagrant. When I see php errors they normally show up in the page but I'm not seeing any here. Standard debug settings error_reporting( -1 );
ini_set( 'display_errors', 1 ); is enabled.

Change 345476 abandoned by Reedy:
Revert "Generate questions HTML via TemplateParser"

Reason:
Hopefully not required now

https://gerrit.wikimedia.org/r/345476

Change 346140 merged by jenkins-bot:
[mediawiki/extensions/Quiz@master] Fix undefined variable stateObject error

https://gerrit.wikimedia.org/r/346140

Krinkle closed this task as Resolved.Apr 4 2017, 9:56 PM
Krinkle claimed this task.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:10 PM