Page MenuHomePhabricator

Badges are no longer shown next to interwiki links
Closed, ResolvedPublic

Description

Event Timeline

Srdjan_m created this task.Aug 5 2017, 10:23 AM
Restricted Application added subscribers: PokestarFan, Aklapper. · View Herald TranscriptAug 5 2017, 10:23 AM

I can't seem to add Wikidata to this project for some reason... adding Lydia in the hope she can put the task in the right project :)

Lydia_Pintscher triaged this task as High priority.Aug 5 2017, 11:29 AM
Lydia_Pintscher added a project: Wikidata.
Lydia_Pintscher added a subscriber: Ladsgroup.

I spot-checked a few other articles that should have badges on dewp and enwp. They don't show them either. A purge didn't seem to help.

I'm checking and it seems like a very stupid mistake in updating CSS. I'm on it.

Okay, Everything looks normal except that CSS of WikimediaBadges extension stopped being injected for a reason that's still unknown to me.

The fast fix is to add https://en.wikipedia.org/w/index.php?title=User:Ladsgroup/monobook.css&oldid=794035784 to Mediawiki:Monobook.css and https://en.wikipedia.org/w/index.php?title=User:Ladsgroup/vector.css&oldid=794035724 to Mediawiki:Vector.css

In the mean time, I will find out what's going on there.

Ladsgroup added a comment.EditedAug 5 2017, 1:12 PM

The only patch I was able to find that remotely can contribute to the problem is https://gerrit.wikimedia.org/r/#/c/368252.

On nowiki is working.

On nowiki is working.

Yeah, because they use a customized css and put it in the mediawiki:common.css so it gets injected.

Stryn added a subscriber: Stryn.Aug 6 2017, 7:57 AM
He7d3r added a subscriber: He7d3r.Aug 6 2017, 2:35 PM
Obsuser added a subscriber: Obsuser.Aug 6 2017, 6:00 PM

Change 370453 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[mediawiki/extensions/WikimediaBadges@master] Add autoload classes

https://gerrit.wikimedia.org/r/370453

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptAug 7 2017, 11:00 AM

Change 370462 had a related patch set uploaded (by Aude; owner: Aude):
[wikidata/build-resources@master] Explicitly load WikimediaBadges with wfLoadExtension

https://gerrit.wikimedia.org/r/370462

matej_suchanek moved this task from incoming to in progress on the Wikidata board.

We seem to be having the same problem on ro.wp

aude added a subscriber: aude.Aug 9 2017, 7:39 PM

I would like to fix this in swat tomorrow. I believe it only needs a change in the build, preferably i am able to verify locally + on beta

Arbnos added a subscriber: Arbnos.Aug 10 2017, 8:24 PM
Obsuser added a comment.EditedAug 15 2017, 11:26 AM

I hoped this task would have been resolved in one or two days max, because those badges are very important for both Wikipedians and readers when navigating articles... More than 10 days passed with no fixing attempt or direct response, even though problem as I see it should be easily resolvable.

I agree but all of the team were in Wikimania, it's hard to get things through around that time.

Change 370462 merged by jenkins-bot:
[wikidata/build-resources@master] Explicitly load WikimediaBadges with wfLoadExtension

https://gerrit.wikimedia.org/r/370462

aude added a comment.Aug 16 2017, 12:44 AM

this is enabled again on test wikis (https://test2.wikipedia.org/wiki/Special:Version) and the fix goes out everywhere else with the train this week (tomorrow/thursday)

It seems this has successfully been fixed for all Wikipedias, finally.

Yeah, RelEng deployed the fix last night. I'm calling this done.

Change 370453 abandoned by Ladsgroup:
Add autoload classes

Reason:
Not needed

https://gerrit.wikimedia.org/r/370453

Ladsgroup closed this task as Resolved.Aug 18 2017, 7:18 AM
Ladsgroup reassigned this task from Ladsgroup to aude.
Ladsgroup moved this task from Review to Done on the Wikidata-Former-Sprint-Board board.
Ladsgroup removed a project: Patch-For-Review.