Page MenuHomePhabricator

Enable MT for "Simple English" as if it was (regular) English
Closed, ResolvedPublic

Description

Content Translation integrates several Machine Translation (MT) services. Those services may provide support for English, but they do not provide specific support for Simple English.

Users of Simple English Wikipedia can benefit from the English MT as a starting point, but this is not always exposed to them. For example, when translating from Simple English to Spanish, both Apertium and Yandex support English-to-Spanish translations but only Apertium is shown as an option:

We should review the MT services that support English, and make sure that they are available as an option when using Simple English. This request is based on this comment on the project talk page.

Please, when making these adjustments make sure for MT not to be enabled for English Wikipedia by accident.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 4 2018, 11:15 AM
Pginer-WMF updated the task description. (Show Details)Jun 4 2018, 11:18 AM
Pginer-WMF triaged this task as Normal priority.Jun 4 2018, 11:43 AM
Pginer-WMF moved this task from Backlog to Maintenance backlog on the Language-2018-Apr-June board.
Jagwar added a subscriber: Jagwar.Jun 4 2018, 12:08 PM

One way to do this is to add simple -> en to the codemap of each service.

Amire80 added a subscriber: Amire80.Jun 4 2018, 1:48 PM

Duplicate of T124545? :)

Duplicate of T124545? :)

Thanks for pointing to that ticket. Although T124545 was created before, I decided to merge that one into the current one since it has a little bit more of detail and discussion. But feel free to add anything else that may be missing to the ticket description.

One way to do this is to add simple -> en to the codemap of each service.

That sounds like a good approach. I assume that this makes it a small/easy change.

I wonder if this change would make it hard to later enable MT for Simple English as a target language, while keeping MT disabled for English as a target. This is not part of the immediate plans but we can consider it for the future.

Change 441156 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/services/cxserver@master] Enable MT for "Simple English" as if it was (regular) English

https://gerrit.wikimedia.org/r/441156

Arrbee assigned this task to Nikerabbit.Jun 20 2018, 7:05 AM

Change 441156 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Enable MT for "Simple English" as if it was (regular) English

https://gerrit.wikimedia.org/r/441156

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-06-25T12:26:09Z] <kartik@deploy1001> Started deploy [cxserver/deploy@cc6dc61]: Update cxserver to ece5e7a (T191874, T196354, T195768, T195768)

Mentioned in SAL (#wikimedia-operations) [2018-06-25T12:29:42Z] <kartik@deploy1001> Finished deploy [cxserver/deploy@cc6dc61]: Update cxserver to ece5e7a (T191874, T196354, T195768, T195768) (duration: 03m 33s)

KartikMistry moved this task from QA to Done on the Language-2018-Apr-June board.Jun 25 2018, 12:36 PM
Pginer-WMF closed this task as Resolved.Jun 25 2018, 3:06 PM
Vvjjkkii renamed this task from Enable MT for "Simple English" as if it was (regular) English to 1obaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Nikerabbit as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from 1obaaaaaaa to Enable MT for "Simple English" as if it was (regular) English.Jul 2 2018, 7:39 AM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Nikerabbit.
CommunityTechBot lowered the priority of this task from High to Normal.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.
Petar.petkovic moved this task from Backlog to Done on the CX-deployments board.Aug 30 2018, 8:36 AM