Page MenuHomePhabricator

[LabeledSectionTransclusion] Use of LanguageGetMagic hook (used in LabeledSectionTransclusion::setupMagic) was deprecated in MediaWiki 1.16
Closed, ResolvedPublic

Description

With ProofReadpage installed and LabeledSectionTransclusion installed, reaching [[Special:JavascriptTest]] triggers a deprecation warning:

PHP Deprecated:  Use of LanguageGetMagic hook (used in LabeledSectionTransclusion::setupMagic) was deprecated in MediaWiki 1.16.
[Called from Hooks::run in /workspace/src/includes/Hooks.php at line 202]

Repro: comment check experimental on the dummy change https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/ProofreadPage/+/442028/

Event Timeline

hashar created this task.Jun 26 2018, 8:42 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 26 2018, 8:42 AM
Vvjjkkii renamed this task from [LabeledSectionTransclusion] Use of LanguageGetMagic hook (used in LabeledSectionTransclusion::setupMagic) was deprecated in MediaWiki 1.16 to iaaaaaaaaa.Jul 1 2018, 1:01 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
JJMC89 renamed this task from iaaaaaaaaa to [LabeledSectionTransclusion] Use of LanguageGetMagic hook (used in LabeledSectionTransclusion::setupMagic) was deprecated in MediaWiki 1.16.Jul 1 2018, 2:43 AM
JJMC89 raised the priority of this task from High to Needs Triage.
JJMC89 updated the task description. (Show Details)
JJMC89 added a subscriber: Aklapper.
hashar added a comment.Jul 2 2018, 2:01 PM

The hook deprecation is spaming the deprecated log bucket (215 million messages). That happens since June 28th 1.32.0-wmf.10.

Krinkle triaged this task as High priority.Jul 7 2018, 11:15 PM

Seems to happen on every web request.

It used to be until recently that when browsing a wiki with X-Wikimedia-Debug on for mwdebug1002, that the non-debug logs were empty by default, meaning any entry is a regression. But this has regressed now with this deprecation warning on every request.

Krinkle added a project: Editing-team.EditedJul 7 2018, 11:26 PM

Tagging Editing-team per Maintainers.

EDIT: Doesn't seem to have a workboard, tagging Contributors-Team instead.

Legoktm claimed this task.Jul 11 2018, 1:17 AM

Change 445059 had a related patch set uploaded (by Legoktm; owner: Legoktm):
[mediawiki/extensions/LabeledSectionTransclusion@master] Use modern i18n mechanisms for localization

https://gerrit.wikimedia.org/r/445059

Tgr added a subscriber: Tgr.Jul 14 2018, 9:48 AM

It seems like this has caused some errors in production (not sure how; and why is LabeledSectionTransclusion even enabled on all wikis?).

Tgr added a comment.Jul 14 2018, 10:00 AM

Ah, OK, apparently the public error message uses the webrequest ID and this just happened to be in the same request (presumably the real error was so bad it couldn't even be logged, even though it could generate an error page?). I thought we have unique exception IDs, but seems like they were killed in rMW5360a3497f31: Provide a unique request identifier. I filed T199607: Generate exception ID unique to the error (but not to the request) about that.

It spams every log I've seen in the past couple of weeks...

Change 445059 merged by jenkins-bot:
[mediawiki/extensions/LabeledSectionTransclusion@master] Use modern i18n mechanisms for localization

https://gerrit.wikimedia.org/r/445059

Jdforrester-WMF closed this task as Resolved.Jul 28 2018, 11:34 PM
Jdforrester-WMF removed a project: Patch-For-Review.

Change 449617 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/config@master] Migrate ProofreadPage to Quibble

https://gerrit.wikimedia.org/r/449617

Change 449617 merged by jenkins-bot:
[integration/config@master] Migrate ProofreadPage to Quibble

https://gerrit.wikimedia.org/r/449617

Change 449951 had a related patch set uploaded (by Legoktm; owner: Legoktm):
[mediawiki/extensions/LabeledSectionTransclusion@wmf/1.32.0-wmf.14] Use modern i18n mechanisms for localization

https://gerrit.wikimedia.org/r/449951

Change 449951 merged by jenkins-bot:
[mediawiki/extensions/LabeledSectionTransclusion@wmf/1.32.0-wmf.14] Use modern i18n mechanisms for localization

https://gerrit.wikimedia.org/r/449951

Mentioned in SAL (#wikimedia-operations) [2018-08-02T08:11:42Z] <legoktm@deploy1001> Started scap: LST: Use modern i18n mechanisms for localization (T198173, T200960)