Page MenuHomePhabricator

Verify that abuse-/spam-related extensions work with Wikibase MediaInfo
Closed, ResolvedPublic

Description

Before deploying the SDC baseline, we need to be sure that vandalism and spam is caught. Two important mechanisms for that are AbuseFilter and SpamBlacklist.

Wikibase should provide automatic integration with these via the EditFilterHookRunner class, which should work for all Wikibase edits, regardless of MCR. But this needs to be verified before deployment.

Related: T189220: Ensure that relevant extensions are MCR-aware

Event Timeline

daniel created this task.Sep 17 2018, 6:55 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptSep 17 2018, 6:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Doesn't this block T194750 ahead of T199352? Spammy or abusive edits in file caption slots need to get detected and caught too…

@Jdforrester-WMF You are right. I was mostly thinking of spam links, but dick jokes in file captions also suck (no pun intended). Changing.

Addshore moved this task from incoming to monitoring on the Wikidata board.Sep 18 2018, 2:33 PM
daniel updated the task description. (Show Details)Nov 6 2018, 1:11 PM
Ramsey-WMF closed this task as Resolved.Dec 17 2018, 5:38 PM
Ramsey-WMF claimed this task.

Tested on Beta, confirmed to work for both AbuseFilter and SpamBlacklist

greg added a project: Multimedia.Mar 7 2019, 10:59 PM