Page MenuHomePhabricator

Update “My contributions“
Closed, ResolvedPublic2 Story Points

Description

👉 Create “My contributions“ | T217326 on Zeplin

  • “My contributions“ lists all edits that have been made in the app (not only the ones via “Editor tasks“). The bigger picture here is that “Editor tasks“ will become a home of all sorts of edits within the app (Slide 27 in Android Edit Action Feed - Diary Study)
  • All types of contributions are expanded in the current designs
  • Functionality of “My contributions“ is limited in V1. The idea for the future is to incorporate a way to keep track of all edits that have been made, e.g. listing all articles that have been edited by the user. In the course of that we’d then also need to think about a way to indicate *what type* of edit’s been made by the user.

Event Timeline

cmadeo updated the task description. (Show Details)Oct 18 2018, 8:09 PM
Charlotte triaged this task as Normal priority.Jan 15 2019, 6:18 PM
Charlotte set the point value for this task to 2.

Change 485346 had a related patch set uploaded (by Cooltey; owner: Cooltey):
[apps/android/wikipedia@master] [WIP] Build my contributions page

https://gerrit.wikimedia.org/r/485346

Hi, @Charlotte and cc @schoenbaechler

Have a question about the screen.

Will it has more types in this screen in the future? For now, it only has the Added title descriptions, not sure if the other types will be included (e.g. counts of image captions?)

Yes @cooltey and thanks for checking back. I think it’s foreseen to include more types in the future, see Design brief: App Editor Tasks.

To my knowledge, we’re going to start with “Added title descriptions“ and “Translated title descriptions“. Please correct me if I’m wrong @Charlotte. I’m going to review the “My contributions“ concept/visuals hopefully by the end of the week and will post updates here.

Yes, @schoenbaechler is right, @cooltey - there will be more types in the future, for example "added image captions" as you've mentioned.

Change 485346 abandoned by Cooltey:
[HOLD] Build my contributions page

Reason:
Moved to Github

https://gerrit.wikimedia.org/r/485346

schoenbaechler renamed this task from Add a place for users to view a count of all their App Editor Task Contributions to Update “My contributions“.Feb 28 2019, 8:04 PM
schoenbaechler updated the task description. (Show Details)
Dbrant added a subscriber: Dbrant.Mar 6 2019, 7:20 PM

@Charlotte @schoenbaechler From our latest check-in with Reading Infrastructure, it will not be feasible to differentiate between "added descriptions" and "translated descriptions" for this first iteration of the endpoint. (It will require quite a bit more logic and careful thinking about how to do it properly). It will still differentiate between different languages of the edits, but everything will have to be under a single bucket of general "contributions" for now. Can we update the design to reflect this?

To add a little color: there's no concept of "translating a description" in MediaWiki or Wikibase; it's just setting a description on an item in all cases. So that's not a distinction I anticipated you'd want the counter extension to draw.

Since it's not a concept intrinsic to the wiki software, what we'd need in order to bucket a description edit as an "addition" vs. a "translation" is some additional signal of intent from the app, which could be a property of either the wiki revision (e.g., a specific edit summary string) or the HTTP request (e.g., a custom header).

Thanks @Dbrant for following up and @Mholloway for the thorough explanation. So @schoenbaechler let's please update the design to just say "N contributions" for v1. Cheers!

Thanks for the heads-up @Dbrant and @Mholloway, updated the screens on Zeplin and Overflow to reflect it.

Not really happy about the screen’s current state though, its usefulness was limited, now it became even more obsolete. We definitely need to have discussion on how to add value to it in upcoming releases.

CC: @Charlotte

The UI has been updated to the latest version of the design (Zeplin), and waiting for the API deployment to production.

Great @cooltey, is there a way to access the screen in the app so I could review it from a visual standpoint? Thanks!

I can send the APK to you directly before it got merged. :)

Thanks @cooltey, had a look at it – fine from a visual perspective!

Looks good @cooltey, moving it to QA signoff.

ABorbaWMF added a subscriber: ABorbaWMF.

Visually it looks pretty good to me on 2.7.276-alpha-2019-04-04

However, I did notice that it only counts the edits I've made since installing the app. I've made many edits via this account, but I'm not sure if they should reflect on the count. I'm not sure if this is by design. @cmadeo what do you think?

Yes @ABorbaWMF it is by design that this only counts the edits made since installing the app. So if that is the observed behaviour this ticket can be closed. :)

Dbrant closed this task as Resolved.Apr 8 2019, 1:45 PM