Page MenuHomePhabricator

Can't open the visual editor on MinervaNeue on desktop
Closed, ResolvedPublic

Description

Reported by User:Zitraum at https://www.mediawiki.org/wiki/Topic:Un0aidtdl7xgwbzc

Steps to reproduce:

  1. Enable two buttons for editing.
  2. Go to https://en.wikipedia.org/wiki/User:Whatamidoing_(WMF)/sandbox?useskin=minerva
    • Note that this is not the mobile site.
  3. Click the "Edit" (not the "Edit source") button.

There are two related issues:

  1. If you previously used the mobile visual editor on the mobile site, neither editor will open.
  2. After opening wikitext editor, dropdown to switch to visual editor does not work.

Also, @Deskana found a (probably) separate problem that suggested that the Edit buttons simply didn't work after making one edit. (??? needs clarification)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 26 2018, 5:09 PM

This is probably my fault related to changes in T198765 (https://gerrit.wikimedia.org/r/461855)… Looks like I've made the desktop Minerva skin's HTML "normal enough" (sufficiently similar to Vector) that both desktop VisualEditor and mobile editor decide to load at the same time, and then weird things happen. I'm not sure why it actually results in neither of them actually loading :)

Actually, never mind that… I could swear that desktop Minerva used to load mobile VE, but now I can't get it to happen after reverting some changes, and I can't figure out how it ever could have possibly worked, if some of the modules like 'mobile.editor.ve' can not load on desktop (have 'targets=>[mobile]').

I suppose the way forward here anyway is to use the desktop VE on desktop Minerva.

Oh, I'm silly, the mobile editor loaded on desktop Minerva, just not the mobile VE part.

The issue is actually caused by rEMFR9caee5e27453: Remove .always in rlModuleLoader, which made the loadModule() method always succeed even if it couldn't load the requested module.

Change 470084 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] mobile.startup/rlModuleLoader: Reject promise when loading fails

https://gerrit.wikimedia.org/r/470084

For me, no editor at all loads when following your steps. This patch fixes that (now the source editor will actually load).

Change 470087 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/skins/MinervaNeue@master] Disable mobile editor (skins.minerva.editor) on desktop

https://gerrit.wikimedia.org/r/470087

Change 470084 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] mobile.startup/rlModuleLoader: Reject promise when loading fails

https://gerrit.wikimedia.org/r/470084

matmarex updated the task description. (Show Details)Oct 28 2018, 2:47 PM
matmarex updated the task description. (Show Details)Oct 30 2018, 2:50 AM

Change 470087 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Disable mobile editor (skins.minerva.editor) on desktop

https://gerrit.wikimedia.org/r/470087

It should now be possible to open the visual editor, but the interface is still a bit funky in places. I filed T208102 about improving it.

matmarex renamed this task from Can't edit open the visual editor on MinervaNeue on desktop to Can't open the visual editor on MinervaNeue on desktop.Nov 14 2018, 4:28 PM
matmarex moved this task from Inbox to High Priority on the Editing QA board.Nov 14 2018, 4:32 PM

@matmarex: It seems like the part of this task about switch to VE not working after opening Wikitext editor is still broken, I see this error in the console:

mf.schemaEditAttemptStep: Unrecognized abort type switchnochange

I see this error in the console:

mf.schemaEditAttemptStep: Unrecognized abort type switchnochange

Looks like this was also noticed in T211603#4938584 and will be fixed soon; but I don't think this warning would cause editor switching to not work. I'll look into it.

matmarex removed a project: Editing QA.
matmarex added a subscriber: Jdlrobson.

Looks like my fixes for this task have been very precisely unfixed, and the mobile editor loads on desktop again, bringing back the problems. I'm not sure which particular patch caused it, maybe rEMFR2309260e78b0: mobile.editor module merged into mobile.init? I will try to fix it again and hope it sticks.

Change 491386 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] Do not load mobile editor on desktop, again

https://gerrit.wikimedia.org/r/491386

Change 491386 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Do not load mobile editor on desktop, again

https://gerrit.wikimedia.org/r/491386

@matmarex: Checked on test wiki, still not working. Has it been pulled through?

What do you mean by "test wiki"? It is not yet live on https://test.wikipedia.org/, it will go out with the train next week. It is live on Beta (e.g. https://en.wikipedia.beta.wmflabs.org/wiki/User:RYasmeen_(WMF)/sandbox?useskin=minerva) and this functionality works as expected there for me (other than the "read-only mode" and not being able to save changes, which is apparently an unrelated ongoing issue).

What do you mean by "test wiki"? It is not yet live on https://test.wikipedia.org/, it will go out with the train next week. It is live on Beta (e.g. https://en.wikipedia.beta.wmflabs.org/wiki/User:RYasmeen_(WMF)/sandbox?useskin=minerva) and this functionality works as expected there for me (other than the "read-only mode" and not being able to save changes, which is apparently an unrelated ongoing issue).

Sorry @matmarex , I meant test.wiki. I thought this is going to production this week. I skipped testing on Beta this week thinking it's probably unreliable in other ways too.

I checked this on the "read only" Beta now . It seems if you open Wikitext editor and then switch to VE it does switch to VE. However, when I tried to switch from VE to Wikitext, I am getting Error loading data from server: readonly. So, I can't test if this is passing for the case in which the switch workflow is VE->WE->VE.

I am going to leave it as unverified until I test it either on a working Beta cluster or on test.wiki when it does make it there.

ppelberg closed this task as Resolved.Feb 28 2019, 11:48 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptFeb 28 2019, 11:48 PM