Page MenuHomePhabricator

Upload fails at Wikimedia Commons "Internal error: Server failed to store temporary file."
Closed, ResolvedPublic

Description

I'm was monitoring the Commons Help Desk, and several volunteers reported the same error, they tried to upload a file, and they received this massage "Internal error: Server failed to store temporary file." i.e,

One of they reported that he tried to upload a .SVG file, and in another moment a .JPG file. And other that he tried in different dates, 9 May, and 11.

Do you have any light here?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2019, 3:40 AM
Restricted Application added a project: Multimedia. · View Herald TranscriptMay 11 2019, 2:51 PM

It's been happening to me as well, except the message I get is "Unknown server Error".

Framawiki triaged this task as High priority.May 12 2019, 1:17 PM
Framawiki added a subscriber: Framawiki.

Same problem here, mayber from 10 May or later
I was uploading some satellite photos through wizard. Usually they're big files larger than 100MB. Everytime when almost done, I got this message.
Yesterday I tried a another java tool, it succeeded. But it's unconvinient for me.

I reboot my router and cable modem. I cleaned my Chrome data. But it doesn't work.

Yann added a subscriber: Yann.May 15 2019, 1:15 PM

Priority of this should be raised. It is happening to several users, and it prevents them the basic functionality of Commons: uploading files.

The problem is solved now, only for me and my JPG files. Those JPG files are non color managed/do not contain embedded ICC profiles.

In my Photoshop CC, these files are marked with "RGB/8#"

After assigning profile (I use sRGB) in Photoshop, I successfully upload my JPG files.
(Choose Edit > Assign Profile > sRGB Profile)

I ran into the same issue when I tried to upload File:Healthy Pescetarian Meal.jpg. I did not use the Upload Wizard, though. I tried it with the script BigChunkedUpload. The file is so small that it was uploaded as one chunk, but could this nethertheless be the reason for the issue? I subsequently did successfully upload with the Special:Upload page which is not able to do chunked uploads. Note that there is another task with the same error message and chunked uploads, but this have been for bigger images: T89197.

Hi guys, I have the exactly same problem :(((((((

SAD:(( It is back again.
And now, the method I mentioned above doesn't work anymore.

Now getting this suprememly unhelpful and tech-oriented message: An error was encountered when opening the file for ZIP checks. Related?

(No need for adding more "me too" comments without providing any further information that would allow others to investigate - thanks!)

I don't know if that was addressed to me, but I gave all the information I was given. (and I have spent many hours of my life debugging real time safety-critical software, without the benefit of any error message whatsoever).

Now getting this suprememly unhelpful and tech-oriented message: An error was encountered when opening the file for ZIP checks. Related?

Now covered in T223446: Cannot upload larger JPG/WEBM/GIF files: "An error was encountered when opening the file for ZIP checks"

I witnessed the same error for .jpg files, but only with files larger than 10mb.

hashar added a subscriber: hashar.

I am pretty sure that is related to the server side exception filled at: T223448 I will try to get more details on that task and maybe get it fixed.

Change 510893 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/core@master] Don't attempt to perform complete verification on async uploads

https://gerrit.wikimedia.org/r/510893

Mentioned in SAL (#wikimedia-operations) [2019-05-17T15:20:50Z] <hashar@deploy1001> Synchronized php-1.34.0-wmf.5/includes/api/ApiUpload.php: Revert "Always validate uploads over api" - T223448 (T222994 T223446) (duration: 01m 00s)

If you tried to uploaded a file larger than 10MBytes, it is uploaded in small parts and a bug in MediaWiki would cause each parts to be rejected. That prevented upload of the file. It should be fixed now.

Aklapper closed this task as Resolved.May 20 2019, 3:14 PM

Closing this task per last comment and as T223448 and T223446 are also closed.
Please reopen this task if this still happens in the next days.

Speravir removed a subscriber: Speravir.May 20 2019, 9:17 PM