Page MenuHomePhabricator

[Pre-deployment testing] Same reply can get posted multiple times if you click on "Reply" button multiple times
Closed, ResolvedPublic

Description

Same reply can get posted multiple times if you click on "Reply" button multiple times.

Event Timeline

Ryasmeen created this task.Dec 4 2019, 9:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 4 2019, 9:51 PM
ppelberg added subscribers: APerson, TheDJ.

Provisionally merging T239861 in as a duplicate of this task. Per our discussion in today's stand: let's see if resolving this task (T239865) also takes care of T239861.

Ryasmeen added a comment.EditedDec 5 2019, 9:56 PM

@ppelberg: did you mean to merge T239861 to T239864 instead. Because this one seems like a different issue to me. T239864 is about not being able to post a comment and this one is about it being posted multiple times.

ppelberg added a comment.EditedDec 5 2019, 11:12 PM

@ppelberg: did you mean to merge T239861 to T239864 instead. Because this one seems like a different issue to me. T239864 is about not being able to post a comment and this one is about it being posted multiple times.

Yikes. You're right. Good catch! This should now be fixed. See: T239864#5717015

Change 555939 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/DiscussionTools@master] Disable buttons while posting

https://gerrit.wikimedia.org/r/555939

Change 555939 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Disable buttons while posting

https://gerrit.wikimedia.org/r/555939

This is still not fixed on protoype server, please move it to QA column when it's ready to test.

ppelberg closed this task as Resolved.Dec 24 2019, 6:15 PM
ppelberg claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptDec 24 2019, 6:15 PM