Page MenuHomePhabricator

Bug: Not able to post comment on beta
Closed, ResolvedPublic

Description

Expected behavior

  1. Click "Reply" link
  2. Type contents of comment
  3. Click "Reply" button
  4. The contents of the comment "I" just composed are published to the talk page

Actual behavior

  1. ⚠️ Load prototype, the following console error appears: Failed to load resource: the server responded with a status of 503 () VM36:203 RESTBase load failed: error
  2. Click "Reply" link
  3. Type contents of comment
  4. Click "Reply" button

⚠️ 5. No reply is posted [1]

Configuration

  • Browser: Chrome Version 78.0.3904.108
  • Platform: desktop
  • OS: Mac

  1. Per @kaldari's comments here, this issue might stem from the fact that https://en.wikipedia.beta.wmflabs.org/api/rest_v1/page/html/Talk%3ACats/407862?redirect=false&stash=true returns a server error.

Event Timeline

ppelberg created this task.Dec 4 2019, 9:19 PM
ppelberg added a subscriber: Esanders.

I seem to be able to post multiple replies. Is there are specific thread where this happens? Are you logged in? Can you reproduce with the developer console open and see if there are any errors or warnings in the console?

ppelberg renamed this task from Bug: Not able to post comment to Bug: Not able to post comment on beta.EditedDec 20 2019, 12:30 AM
ppelberg reopened this task as Open.
ppelberg updated the task description. (Show Details)
ppelberg added a subscriber: kaldari.

Prompted by @kaldari's findings here (thank you), I am re-opening this task and updating the task description to include the details Ed mentioned here: T239861#5715774

Is there are specific thread where this happens?

@Esanders - I tried multiple threads. The error is consistent for me. I can reload the page and still get the same error. Also tried in Firefox and got a similar error: "RESTBase load failed: Service Unavailable".

Are you logged in?

No. The instructions don't say anything about logging in, so I didn't.

Can you reproduce with the developer console open and see if there are any errors or warnings in the console?

None other than the ones reported in the description. Note that the errors occur at load time, not at posting time.

kaldari added a comment.EditedDec 20 2019, 3:21 AM

When I try to load the page, the ext.discussionTools.parser module makes a call to RESTBase for https://en.wikipedia.beta.wmflabs.org/api/rest_v1/page/html/Talk%3ACats/407862?redirect=false&stash=true which returns a 503 server error.

It looks like the RESTBase api service just isn't running on that server. https://en.wikipedia.beta.wmflabs.org/api/rest_v1/?doc also gives me a server error.

It definitely should be (and was until recently). Not sure who is responsible for keeping those services up...

DLynch added a subscriber: DLynch.Dec 20 2019, 6:04 PM

It's happening to other edits as well, so restbase is just down in general on beta, not in a talk-specific manner. E.g. https://en.wikipedia.beta.wmflabs.org/api/rest_v1/page/html/Cats/407373?redirect=false&stash=true

It definitely should be (and was until recently). Not sure who is responsible for keeping those services up...

I think @mobrovac was in charge, but he left the WMF last week. Maybe @cicalese knows.

CCicalese_WMF added a subscriber: CCicalese_WMF.

What is the severity of this? We are looking into it. In the future, please feel free to tag Core Platform Team for RESTBase issues.

cicalese removed a subscriber: cicalese.Dec 20 2019, 6:25 PM

I've fixed it. A restart was needed. What happened was that metrics was configured to be sent to labmon1001 domain which apparently got reconfigured and disappeared. Puppet rerendered the config, but the service didn't get restarted and started crashing not being able to resolve a monitoring domain. This is a whole collection of bugs and misconfiguration, I'll file followup tickets.

I've fixed it. A restart was needed. What happened was that metrics was configured to be sent to labmon1001 domain which apparently got reconfigured and disappeared. Puppet rerendered the config, but the service didn't get restarted and started crashing not being able to resolve a monitoring domain. This is a whole collection of bugs and misconfiguration, I'll file followup tickets.

Thank you for your quick help on this, @Pchelolo – the issue appears to be resolved...are you seeing the same on your end, @kaldari?

And @CCicalese_WMF, tagging Core Platform Team and communicating priority upfront...noted, we'll make sure to do both next time we encounter an issue like this.

So y'all are aware, this is/would have been a high priority issue for us as we are directing contributors to beta.wmflabs to test an early version of a prototype we intend to start iterating on in January. See: https://www.mediawiki.org/wiki/Talk_pages_project/replying/prototype_testing#Version_1.0_prototype_test

kaldari closed this task as Resolved.Dec 20 2019, 7:02 PM

@ppelberg - It's working for me now.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptDec 20 2019, 7:02 PM