Page MenuHomePhabricator

Make config change to enable Reply Tool as Beta Feature on fi.wiki
Closed, ResolvedPublic

Description

This task is about enabling the relevant config flag(s) to make The Reply Tool available to contributors at the Finnish Wikipedia.

Implementation details

  • To use the Reply Tool, all logged in editors at the Finnish Wikipedia, who DO NOT have the Automatically enable most beta features preference enabled, will need to do the following:
  • To use the Reply Tool, all logged in editors at the Finnish Wikipedia, who DO have the Automatically enable most beta features preference enabled, will need to do the following:
    • 1. Visit any talk page or talk-like page (e.g. a page where __NEWSECTIONLINK__ is present), observe [ reply ] links are appended to each comment

Deployment timing

⚠️ Exact timing is TBD. The Reply Tool being made available as a Beta Feature depends on deciding on an approach to resolving T265291.

Testing instructions

  1. Visit Special:Preferences > Beta features (read: mw-prefsection-betafeatures) at the Finnish Wikipedia and confirm DiscussionTools is available as a Beta feature
  2. Visit this page [i] and file a task if [ reply ] links are NOT appearing where and/or how they should be
  3. Copy the contents of this this page [i] to a sandbox page and:
    • A) Document the text input mode – source or visual – is shown when a logged in user uses the Reply Tool for the first time on a given wiki
    • B) Document if the Reply Tool does NOT "remember" [i] the text input mode – source or visual – you used in your previous edit
    • C) File a task if you encounter cases where you are unable to post comments [ii] and/or if the Reply Tool behaves in any ways you deem to be unexpected

Text input mode behavior

WikiInput mode shown by default (logged in)Tool remembers last input mode used (y/n)

Done

  • Reply Tool is available in the way described in the "Implementation details" section above
  • "Testing instructions" are completed

i. Test page: https://fi.wikipedia.org/wiki/Wikipedia:Kahvihuone_(tekniikka)

Event Timeline

Zache added a subscriber: Zache.Oct 14 2020, 6:02 AM

When we do our next deploy, can we merge this no-op config cleanup left over from wmf7: https://gerrit.wikimedia.org/r/c/operations/mediawiki-config/+/620958

Lens0021 removed a subscriber: Lens0021.Oct 18 2020, 4:10 PM

When we do our next deploy, can we merge this no-op config cleanup left over from wmf7: https://gerrit.wikimedia.org/r/c/operations/mediawiki-config/+/620958

(already done)

ppelberg added a comment.EditedOct 21 2020, 12:26 AM

Deployment timing
Note, the Reply Tool was not made available as a Beta Feature at fi.wiki today, 20-October, as previously planned.

This happening is blocked on us, the Editing Team and volunteers at fi.wiki, coming up with what – if anything – we will do to resolve T265291.

cc @Stryn + @Zache

I've updated the task description to reflect the above.

ppelberg updated the task description. (Show Details)Oct 21 2020, 12:26 AM
ppelberg added a subscriber: Stryn.
Zache added a comment.Oct 21 2020, 2:20 PM

Deployment timing
Note, the Reply Tool was not made available as a Beta Feature at fi.wiki today, 20-October, as previously planned.

This happening is blocked on us, the Editing Team and volunteers at fi.wiki, coming up with a way resolution to T265291.

Your comment was a little unclear. Does this mean that you are actually doing something for the problem with ETA or that fiwiki should change the policy before you are ready to deploy?

ppelberg added a comment.EditedOct 21 2020, 3:46 PM

Deployment timing
Note, the Reply Tool was not made available as a Beta Feature at fi.wiki today, 20-October, as previously planned.

This happening is blocked on us, the Editing Team and volunteers at fi.wiki, coming up with a way resolution to T265291.

Your comment was a little unclear. Does this mean that you are actually doing something for the problem with ETA or that fiwiki should change the policy before you are ready to deploy?

Ah, I'm sorry about that. [i]

I meant to communicate: "1. We are not yet sure the approach we're going to take with T265291 (e.g. do nothing for now, come up with a new solution to achieve the intended effect, etc.). 2. Making the tool available as a Beta Feature at fi.wiki depends on us having talking about and reached a rough consensus on said 'approach.'"


i. I'm now seeing how the word "resolution" in T265446#6566619 was not clear.

Zache added a comment.Oct 27 2020, 4:45 PM

Is it possible to configure reply tools so that it would add [ reply ] link only when line starts with :? I think that there is newer such a case in Finnish Wikipedia when line starts with # or * when user should reply. All of those are either votes OR participants lists and actual discussion is in separated section.

Example

There should be reply links for lines

: something  --Zache (keskustelu) 27. lokakuuta 2020 kello 18.25 (EET)

There should not be reply links for lines

# something  --Zache (keskustelu) 27. lokakuuta 2020 kello 18.25 (EET)

* something  --Zache (keskustelu) 27. lokakuuta 2020 kello 18.25 (EET)

Is it possible to configure reply tools so that it would add [ reply ] link only when line starts with :? I think that there is newer such a case in Finnish Wikipedia when line starts with # or * when user should reply. All of those are either votes OR participants lists and actual discussion is in separated section.

Oh interesting, @Zache – does this Wikipedia:Poistoäänestykset/Katariina Räikkönen discussion [i] show what you are describing above?

Also, are you able to share what inspired you to ask this question? Is there a particular policy/guideline that describes how people should/should not engage with votes? After a quick read, I didn't see anything mentioned here. [ii]


i. https://fi.wikipedia.org/wiki/Wikipedia:Poisto%C3%A4%C3%A4nestykset/Katariina_R%C3%A4ikk%C3%B6nen
ii. https://fi.wikipedia.org/wiki/Wikipedia:%C3%84%C3%A4nestys

Zache added a comment.Oct 28 2020, 7:42 AM

Oh interesting, @Zache – does this Wikipedia:Poistoäänestykset/Katariina Räikkönen discussion [i] show what you are describing above?

Yes, though these could be better as there is also discussion
https://fi.wikipedia.org/wiki/Wikipedia:Poisto%C3%A4%C3%A4nestykset/Lydia_Yl%C3%B6stalo

Also, are you able to share what inspired you to ask this question?

Replying to votes looked as a potential point of conflict in comments here.

Is there a particular policy/guideline that describes how people should/should not engage with votes? After a quick read, I didn't see anything mentioned here. [ii]

Official written guidelines are very minimal

However, in practice i think the rule is defined by templates which are used to generate the basic layout of the vote page and format of the new votepages are following the older ones based on custom.

Zache added a comment.Oct 28 2020, 8:05 AM

There was also comment [1] that Reply-tool currently adds [ reply ] to archived parts of the discussion which should not be changed. These links can be hided even by local CSS so it is not blocker but just FYI that it is something which needs to be solved somehow.

Example of the archived discussion

[1] https://fi.wikipedia.org/w/index.php?title=Wikipedia%3AKahvihuone_%28sekalaista%29&type=revision&diff=19264222&oldid=19264160

Is it possible to configure reply tools so that it would add [ reply ] link only when line starts with :? I think that there is newer such a case in Finnish Wikipedia when line starts with # or * when user should reply. All of those are either votes OR participants lists and actual discussion is in separated section.

We've had other requests for similar functionality (T260066). We should add some way to do this. For me the main difficulty here is in implementing it in such a way that we won't have to support hundreds of different configurations on different wikis (and also, such a way that the tool doesn't have to be tediously configured on each wiki).

There was also comment [1] that Reply-tool currently adds [ reply ] to archived parts of the discussion which should not be changed. These links can be hided even by local CSS so it is not blocker but just FYI that it is something which needs to be solved somehow.

I think this is covered by T249293. The current proposal there is to remove reply links on pages containing the __NONEWSECTIONLINK__ magic word somewhere on the page (or in a template). This is commonly used on archived discussion pages to remove the "Add topic" link ("Lisää aihe") in the tabs, although the page you linked doesn't do that.

Zache added a comment.Oct 28 2020, 8:36 PM

There was also comment [1] that Reply-tool currently adds [ reply ] to archived parts of the discussion which should not be changed. These links can be hided even by local CSS so it is not blocker but just FYI that it is something which needs to be solved somehow.

I think this is covered by T249293. The current proposal there is to remove reply links on pages containing the __NONEWSECTIONLINK__ magic word somewhere on the page (or in a template). This is commonly used on archived discussion pages to remove the "Add topic" link ("Lisää aihe") in the tabs, although the page you linked doesn't do that.

The problem is that the talk page can be only partially archived so __NONEWSECTIONLINK_ wont work with those cases.

ppelberg added a comment.EditedThu, Nov 5, 12:13 AM

@Zache, the additional context you shared in T265446#6583858 is helpful – thank you.

I've added [i] the fi.wiki-specific use cases for "suppressing" [ reply ] links you are bringing to our attention to the ticket where we will consider implementing something like this.


i. T249293#6604678

Deployment timing
Assuming no blocking issues are raised in response to the comment @Whatamidoing-WMF and I posted at fi.wiki [i], the Reply Tool should be made available as a Beta Feature at fi.wiki.

I will comment the exact timing of when the Reply Tool should be made available before EOD Friday, 6-Nov.


i. https://w.wiki/k8f

Change 640088 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[operations/mediawiki-config@master] Enable DiscussionTools as a beta feature on fiwiki

https://gerrit.wikimedia.org/r/640088

Change 640088 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable DiscussionTools as a beta feature on fiwiki

https://gerrit.wikimedia.org/r/640088

Mentioned in SAL (#wikimedia-operations) [2020-11-09T12:05:58Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: 87b3eede24fb407ddd226ad65817ab8adf44aeb8: Enable DiscussionTools as a beta feature on fiwiki (T265446) (duration: 01m 06s)

Esanders assigned this task to matmarex.Sat, Nov 14, 2:38 PM
ppelberg closed this task as Resolved.Tue, Nov 17, 2:44 AM