Page MenuHomePhabricator

"Add data" step of Upload Wizard broken
Open, Unbreak Now!PublicBUG REPORT

Description

Bug report copied from Commons: "This used to show a search field for entry of Wikidata items. It now just has a link to "depicts" in Wikidata and if you click the "Add statement" field and enter a search term, even for one you know exists, its says "no results found"."

I confirmed that the bug report is accurate and the "Add data" step no longer works.

Event Timeline

Confirmed, looks like this. (“Add a statement” finds no results because it’s searching for properties for other statements, not items as the “depicts” value, but I also fell for this before realizing that there must be an input field missing.)

Screenshot 2021-06-26 at 21-01-30 Upload Wizard - Wikimedia Commons.png (2×1 px, 834 KB)

Change 702105 had a related patch set uploaded (by Matthias Mullie; author: Matthias Mullie):

[mediawiki/extensions/WikibaseMediaInfo@master] Seperate between <submit> and <edit> controls

https://gerrit.wikimedia.org/r/702105

Change 702105 merged by jenkins-bot:

[mediawiki/extensions/WikibaseMediaInfo@master] Seperate between <submit> and <edit> controls

https://gerrit.wikimedia.org/r/702105

Etonkovidova added a subscriber: Etonkovidova.

Checked in betalabs - the depicts field is displayed:

Screen Shot 2021-07-01 at 3.05.08 PM.png (1×1 px, 443 KB)

Note: it seems that "No results found" for Add statement field works in commons wmf.12:

Screen Shot 2021-07-01 at 2.59.35 PM.png (1×2 px, 623 KB)

Change 702810 had a related patch set uploaded (by Matthias Mullie; author: Matthias Mullie):

[mediawiki/extensions/WikibaseMediaInfo@wmf/1.37.0-wmf.12] Seperate between <submit> and <edit> controls

https://gerrit.wikimedia.org/r/702810

Jdforrester-WMF triaged this task as Unbreak Now! priority.Fri, Jul 2, 9:48 AM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Proposed for emergency deployment.

I can deploy it if anyone from the team is around to verify the fix and check for further issues. Just ping me in IRC (Amir1) or here.

Change 702810 merged by jenkins-bot:

[mediawiki/extensions/WikibaseMediaInfo@wmf/1.37.0-wmf.12] Seperate between <submit> and <edit> controls

https://gerrit.wikimedia.org/r/702810

Mentioned in SAL (#wikimedia-operations) [2021-07-02T10:33:11Z] <jforrester@deploy1002> Synchronized php-1.37.0-wmf.12/extensions/WikibaseMediaInfo: UploadWizard/WikibaseMediaInfo fix 3fd2873 for [[phab:T285579|T285579]] (duration: 00m 59s)

Not sure if this is part of this task, but the Add Meta-Data Step is in the UploadWizard is still not working as it was. Previously it asked which features were prominent in the image. It no longer appears to do that.

Not sure if this is part of this task, but the Add Meta-Data Step is in the UploadWizard is still not working as it was. Previously it asked which features were prominent in the image. It no longer appears to do that.

"Add data" step doesn't have an option to "Mark as prominent" until depicts would be saved, e.g.

depicts are not added yetdepicts added but not publisheddepicts published, "Mark as prominent" is displayed
Screen Shot 2021-07-12 at 12.34.02 PM.png (1×1 px, 1 MB)
Screen Shot 2021-07-12 at 12.36.16 PM.png (1×1 px, 1 MB)
Screen Shot 2021-07-12 at 12.36.54 PM.png (1×1 px, 1 MB)

@Kerry_Raymond - Did "Mark as prominent" feature previously appear before publishing?

Yes. You were asked to add a "depicts". Once you had chosen one, it showed it with "Mark as prominent". You could either mark it as prominent at the point, or you could add further depicts and then mark the prominent ones later, prior to the final Publish. Since the problem that triggered this bug report, I do not see any "Mark as prominent" appearing any more. See this screen shot for the uploading I just did https://commons.wikimedia.org/wiki/File:Kuranda_Fig_Tree_Avenue,_Species_Map,_2018.jpg

Previously I would have seen the "Mark as prominent" option available on both "map" and "Kuranda". In this case I would have "marked as prominent" the "map" depicts.

image.png (1×1 px, 94 KB)

Thanks @Kerry_Raymond - reopening since "Mark as prominent' should appear before depicts get published.

There is some inconsistency in displaying "Mark as prominent" between two cases: (1) when depicts are added to previously published depicts - then, "Mark as prominent" will be displayed before publishing and (2) when depicts are initially added (a file doesn't have previously published depicts) - "Mark as prominent" will be displayed only after some depicts are saved.

(1) when depicts are added to previously published depicts - then, "Mark as prominent" will be displayed before publishing, as soon as a depicts is selected (click yo see the animated gif below).

depicts_added.gif (788×1 px, 274 KB)

(2) when depicts are initially added (a file doesn't have previously published depicts) - "Mark as prominent" will be displayed only after some depicts are saved (click yo see the animated gif below).

depicts_added2.gif (788×1 px, 764 KB)