Page MenuHomePhabricator

MediaWiki-Vagrant install party
Closed, ResolvedPublic

Description

Introduction to using MediaWiki-Vagrant to manage a development environment for hacking on MediaWiki. We'll do a really quick high level look at what Vagrant is and how MediaWiki-Vagrant uses and extends it. Then we'll get hands on by installing MediaWiki-Vagrant on everyone's laptops.

Session accomplishments

Event Timeline

bd808 created this task.Jan 8 2015, 5:01 PM
bd808 raised the priority of this task from to Medium.
bd808 updated the task description. (Show Details)
bd808 added a subscriber: bd808.
bd808 added a comment.Jan 8 2015, 5:05 PM

I don't think we have any USB keys this time, so hopefully there will be good wifi at the venue.

bd808 claimed this task.Jan 8 2015, 5:28 PM

It would be great to have @dduvall's help with this session.

The wiki page says that @Yurik, @KartikMistry, @Isarra, @Mglaser and @MZMcBride were at least preliminarily interested in attending. Hopefully we can round up a few more folks who either haven't tried to get MW-Vagrant setup yet or have hit some roadblock and could use a bit of help.

I'm definitely down to help. What did you use the USB keys for last time, base images?

Reedy added a subscriber: Reedy.Jan 8 2015, 8:18 PM

I'm definitely down to help. What did you use the USB keys for last time, base images?

Yeah, it was installs of vagrant and virtual box for various distros (etc), so people didn't have to overload the hackathon wifi to grab them all.. I've still got one somewhere, so could run tree or something if you wanted

Yeah, it was installs of vagrant and virtual box for various distros (etc), so people didn't have to overload the hackathon wifi to grab them all.. I've still got one somewhere, so could run tree or something if you wanted

Ah, makes sense. I have a spare 802.11n router with USB that we could host the files on—if we can gather up four ethernet cables it can even be a gigabit Vagrant hookah. :)

Reedy added a comment.Jan 8 2015, 8:54 PM

P200 is the file list

bd808 added a comment.Jan 8 2015, 9:04 PM

I'm definitely down to help. What did you use the USB keys for last time, base images?

I have an instance in labs that used to know how to build the USB iso image. I can see if it still works. I haven't poked it since Wikimania.

dduvall moved this task from Backlog to In Progress on the MediaWiki-Vagrant board.Jan 9 2015, 8:36 PM
dduvall added a subscriber: greg.Jan 9 2015, 11:53 PM

@bd808, if you can get that iso built, I can try out a setup with the standalone fileserver and run through the README (and write a Windows version; see T71208).

Also, how many participants do you anticipate and would it make more sense to just try and procure some cheap USB sticks? (Maybe @greg can help make it rain.)

bd808 added a subscriber: ori.Jan 10 2015, 12:05 AM

@bd808, if you can get that iso built, I can try out a setup with the standalone fileserver and run through the README (and write a Windows version; see T71208).

I'll poke at it this weekend. I should be pretty easy to get running again. I can probably update a few of the packages it uses too. I think I have another open task besides the one you linked to add git installer for Windows and OSX. I have some updated notes for the README at https://www.mediawiki.org/wiki/User:BDavis_%28WMF%29/Projects/Hackathon_Vagrant_install too that need to be committed.

Also, how many participants do you anticipate and would it make more sense to just try and procure some cheap USB sticks? (Maybe @greg can help make it rain.)

I don't remember if @ori still has some that we used at the Zürich hackathon or not. Even if we have a bunch of people we can get by with a smallish number of sticks because the easiest thing to do it copy all the files off the stick and then hand it to the next person. I think I have two left from that batch that was made for Wikimania. The most annoying part is actually populating the sicks from the iso image. :)

greg added a comment.Jan 10 2015, 1:28 AM

OIT has about 8 usb drives available (8 gig versions). That should be enough, yes? With the 2 @bd808 and possibly 2 @ori has? If not, I bet we can get some if we ask (OIT) nicely soon.

greg added a comment.Jan 12 2015, 6:59 PM

Should I reserve those 8 from OIT and hand to Dan?

@greg, yes please. I also have a drive on my keychain with about 7.6G available on one of the partitions.

Reedy added a comment.Jan 12 2015, 7:11 PM

I've got a couple of these sticks too...

You can buy usb duplicators, and/or do it via a usb hub from memory...

Qgil added a subscriber: Qgil.Jan 14 2015, 10:33 AM

Please confirm whether you want to run this session at MediaWiki-Developer-Summit-2015 by placing this task in the most appropriate column at the workboard and scheduling it at https://www.mediawiki.org/wiki/MediaWiki_Developer_Summit_2015#Schedule

bd808 added a comment.Jan 14 2015, 4:20 PM
In T86206#975509, @Qgil wrote:

Please confirm whether you want to run this session at MediaWiki-Developer-Summit-2015 by placing this task in the most appropriate column at the workboard and scheduling it at https://www.mediawiki.org/wiki/MediaWiki_Developer_Summit_2015#Schedule

Blerg. It was on the schedule https://www.mediawiki.org/w/index.php?title=MediaWiki_Developer_Summit_2015&oldid=1347591 but then apparently removed.

bd808 added a comment.Jan 14 2015, 4:27 PM
In T86206#975509, @Qgil wrote:

Please confirm whether you want to run this session at MediaWiki-Developer-Summit-2015 by placing this task in the most appropriate column at the workboard and scheduling it at https://www.mediawiki.org/wiki/MediaWiki_Developer_Summit_2015#Schedule

I re-added it to the schedule at the same time slot as before (2015-01-26T11:15PST) in a 50 seat classroom. I would gladly switch with T85280: Using EventLogging and Dashboards which is in the same timeslot in the smaller classroom space.

I have 6 USB sticks (7 counting my own) with fresh git bundles ready to go for tomorrow.

Reedy added a comment.Jan 26 2015, 7:30 PM

I've still got a few extra sticks that can be reused if necessary

bd808 added a subscriber: Joe.Jan 26 2015, 11:48 PM

We had ~6 folks show up to get help.

Most were stuck on a new problem caused by the latest hhvm package. It is creating an /etc/hhvm/php.ini/ directory which contains a php.ini file rather than the expected /etc/hhvm/php.ini file. This looks to me to be a bug in the Wikimedia HHVM package. Maybe @Joe can look at this an see what's going on?

Most were stuck on a new problem caused by the latest hhvm package. It is creating an /etc/hhvm/php.ini/ directory which contains a php.ini file rather than the expected /etc/hhvm/php.ini file. This looks to me to be a bug in the Wikimedia HHVM package. Maybe @Joe can look at this an see what's going on?

Confirmed via irc conversation that this is a known bug in the package. A fixed version will be pushed to our apt repo soon. The short term fix is

vagrant ssh; sudo rm -rf /etc/hhvm/php.ini; exit; vagrant provision

This will remove the problematic directory and then run puppet again to provision the correct file.

Qgil added a comment.Jan 27 2015, 6:57 AM

Please update the description with the achievements of this session. Thank you in advance.

bd808 added a comment.Jan 27 2015, 7:18 AM

Most were stuck on a new problem caused by the latest hhvm package. It is creating an /etc/hhvm/php.ini/ directory which contains a php.ini file rather than the expected /etc/hhvm/php.ini file. This looks to me to be a bug in the Wikimedia HHVM package. Maybe @Joe can look at this an see what's going on?

Confirmed via irc conversation that this is a known bug in the package. A fixed version will be pushed to our apt repo soon. The short term fix is good for now I think.

vagrant ssh; sudo rm -rf /etc/hhvm/php.ini; exit; vagrant provision

This will remove the problematic directory and then run puppet again to provision the correct file.

bd808 updated the task description. (Show Details)Jan 27 2015, 7:40 AM
bd808 set Security to None.
dduvall closed this task as Resolved.Jan 29 2015, 9:19 PM

See T87478 for the php.ini bug.

Overall, I liked how this went down. There weren't very many people that had to rely on the USB stick, but those that did had a fairly smooth experience (other than running into the reported bug).

bd808 moved this task from In Progress to Done on the MediaWiki-Vagrant board.Feb 26 2015, 12:51 AM