Page MenuHomePhabricator

Convert ConfirmEdit extension to use extension registration
Closed, ResolvedPublic

Description

The ConfirmEdit extension needs to be converted to use the new extension registration system. More details are available on T87875.

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

Change 212571 merged by jenkins-bot:
Move QuestyCaptcha to its own place

https://gerrit.wikimedia.org/r/212571

Change 212844 had a related patch set uploaded (by Florianschmidtwelzow):
Move i18n to Captcha modules own directory

https://gerrit.wikimedia.org/r/212844

Change 212844 merged by jenkins-bot:
Move i18n to Captcha modules own directory

https://gerrit.wikimedia.org/r/212844

Change 212845 had a related patch set uploaded (by Legoktm):
Clean up ConfirmEdit.php entry point and move common files to common places

https://gerrit.wikimedia.org/r/212845

Change 212847 had a related patch set uploaded (by Legoktm):
Move FancyCaptcha to its own location

https://gerrit.wikimedia.org/r/212847

Change 212848 had a related patch set uploaded (by Legoktm):
Move MathCaptcha to it's own place

https://gerrit.wikimedia.org/r/212848

Change 212849 had a related patch set uploaded (by Legoktm):
Move ReCaptcha to it's own place

https://gerrit.wikimedia.org/r/212849

Change 212851 had a related patch set uploaded (by Legoktm):
Move QuestyCaptcha to its own place

https://gerrit.wikimedia.org/r/212851

Change 212845 merged by jenkins-bot:
Clean up ConfirmEdit.php entry point and move common files to common places

https://gerrit.wikimedia.org/r/212845

Change 212847 merged by jenkins-bot:
Move FancyCaptcha to its own location

https://gerrit.wikimedia.org/r/212847

Change 212848 merged by jenkins-bot:
Move MathCaptcha to it's own place

https://gerrit.wikimedia.org/r/212848

Change 212849 merged by jenkins-bot:
Move ReCaptcha to it's own place

https://gerrit.wikimedia.org/r/212849

Change 212851 merged by jenkins-bot:
Move QuestyCaptcha to its own place

https://gerrit.wikimedia.org/r/212851

Change 212853 had a related patch set uploaded (by Florianschmidtwelzow):
Add extension.json and clear PHP entry point

https://gerrit.wikimedia.org/r/212853

Change 212853 merged by jenkins-bot:
Add extension.json and clear PHP entry point

https://gerrit.wikimedia.org/r/212853

Change 212860 had a related patch set uploaded (by Legoktm):
Add extension.json and clear PHP entry point

https://gerrit.wikimedia.org/r/212860

Change 212860 merged by jenkins-bot:
Add extension.json and clear PHP entry point

https://gerrit.wikimedia.org/r/212860

Change 212862 had a related patch set uploaded (by Florianschmidtwelzow):
Remove PHP entry point and use extension.json for QuestyCaptcha

https://gerrit.wikimedia.org/r/212862

Change 212863 had a related patch set uploaded (by Florianschmidtwelzow):
Use extension.json and clear PHP entry point for MathCaptcha

https://gerrit.wikimedia.org/r/212863

Change 212864 had a related patch set uploaded (by Florianschmidtwelzow):
Clear PHP entry point and use extension.json for ReCaptcha

https://gerrit.wikimedia.org/r/212864

Change 212862 merged by jenkins-bot:
Remove PHP entry point and use extension.json for QuestyCaptcha

https://gerrit.wikimedia.org/r/212862

Change 212863 merged by jenkins-bot:
Use extension.json and clear PHP entry point for MathCaptcha

https://gerrit.wikimedia.org/r/212863

Change 212864 merged by jenkins-bot:
Clear PHP entry point and use extension.json for ReCaptcha

https://gerrit.wikimedia.org/r/212864

Change 212904 had a related patch set uploaded (by Florianschmidtwelzow):
Remove PHP entry point and use extension.json for ConfirmEdit

https://gerrit.wikimedia.org/r/212904

Change 212910 had a related patch set uploaded (by Legoktm):
Remove PHP entry point and use extension.json for QuestyCaptcha

https://gerrit.wikimedia.org/r/212910

Change 212911 had a related patch set uploaded (by Legoktm):
Use extension.json and clear PHP entry point for MathCaptcha

https://gerrit.wikimedia.org/r/212911

Change 212912 had a related patch set uploaded (by Legoktm):
Clear PHP entry point and use extension.json for ReCaptcha

https://gerrit.wikimedia.org/r/212912

Change 212912 merged by jenkins-bot:
Clear PHP entry point and use extension.json for ReCaptcha

https://gerrit.wikimedia.org/r/212912

Change 212910 merged by jenkins-bot:
Remove PHP entry point and use extension.json for QuestyCaptcha

https://gerrit.wikimedia.org/r/212910

Change 212911 merged by jenkins-bot:
Use extension.json and clear PHP entry point for MathCaptcha

https://gerrit.wikimedia.org/r/212911

Legoktm closed this task as Resolved.May 23 2015, 1:35 PM

Change 213825 had a related patch set uploaded (by Paladox):
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/213825

Paladox reopened this task as Open.EditedJun 14 2015, 11:21 PM
Paladox added a subscriber: Paladox.

Reopened since the main ConfirmEdit php entry point still hasn't been done it yet.

Change 201499 abandoned by Legoktm:
Prepare and use ExtensionRegistration to install ConfirmEdit Captchas

https://gerrit.wikimedia.org/r/201499

Pennth added a subscriber: Pennth.Sep 15 2015, 6:31 PM

While this patch is still in development, please note in the 1.25 changelog/readme that ConfirmEdit must be called using the old require_once syntax.

Attempting to use wfLoadExtension( 'ConfirmEdit' ) produces a showstopper from maintenance/update.php:

Fatal error: Uncaught exception 'Exception' with message '/home/wiki/web_docs/mediawiki-1.25.2/extensions/ConfirmEdit/extension.json does not exist!'

Hi I have a patch that is the final migration for extension.json and will fix your problem. Just need someone to review it.

While this patch is still in development, please note in the 1.25 changelog/readme that ConfirmEdit must be called using the old require_once syntax.
Attempting to use wfLoadExtension( 'ConfirmEdit' ) produces a showstopper from maintenance/update.php:

Fatal error: Uncaught exception 'Exception' with message '/home/wiki/web_docs/mediawiki-1.25.2/extensions/ConfirmEdit/extension.json does not exist!'

The Extension page is up-to-date and the installation method for ConfirmEdit is still mentioned in the Php style only. There are probably a lot of other extensions with the same problem, so the best idea would be to read the extension page before moving to extension registration. I think noting it in the changelog/readme of MediaWiki core would be a huge amount of work and notices about extensions (bundled or not) shouldn't be in the changelog/readme, in my opinion :)

Looks like this is the only task left to also solve the tracking task T94758...

Change 213825 merged by jenkins-bot:
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/213825

Paladox closed this task as Resolved.Oct 31 2015, 7:45 PM
Paladox claimed this task.

Assigned to also Florian.

Change 250275 had a related patch set uploaded (by Florianschmidtwelzow):
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250275

Change 250275 abandoned by Florianschmidtwelzow:
Add extension.json, empty PHP entry point

Reason:
really cool, cherry picking to REL1_26 and then pushing to REL1_25...

https://gerrit.wikimedia.org/r/250275

Change 250276 had a related patch set uploaded (by Paladox):
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250276

Change 250277 had a related patch set uploaded (by Florianschmidtwelzow):
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250277

Change 250278 had a related patch set uploaded (by Paladox):
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250278

Reedy added a subscriber: Reedy.Oct 31 2015, 9:45 PM

Why are we backporting things that aren't bugfixes?

Change 250275 restored by Florianschmidtwelzow:
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250275

Change 250278 abandoned by Paladox:
Add extension.json, empty PHP entry point

Reason:
Abandoning florian did the patches.

https://gerrit.wikimedia.org/r/250278

Change 250276 abandoned by Paladox:
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250276

Change 250277 merged by jenkins-bot:
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250277

Change 250275 merged by Hashar:
Add extension.json, empty PHP entry point

https://gerrit.wikimedia.org/r/250275

Change 212904 abandoned by Florianschmidtwelzow:
Remove PHP entry point and use extension.json for ConfirmEdit

Reason:
oha, why is this change still alive? :D

https://gerrit.wikimedia.org/r/212904