Page MenuHomePhabricator

Phabricator project auto-complete is arbitrary (in a bad way)
Closed, ResolvedPublic

Description

We have a collection of related projects:

Search-and-Discovery
Search-and-Discovery-Cirrus-Sprint
Search-and-Discovery-OpenStreetMap-Sprint
...etc.

When typing into the Search bar at the top of phab, things work reasonably. Typing "Discovery", for example, lists about 7 projects, and one of them is Search-and-Discovery.

However, when typing into the Projects field, such as when creating a task, entering "Discovery" only lists 5 projects. That is a known issue, and wouldn't be a problem, except that it lists all the Sprint projects, and not the main Search-and-Discovery. I tried renaming it to Search-and-Discovery-Department, hoping that it would be sorted alphabetically near the top, and thus be in 5 that are shown. Sadly, that did not work.

Fixing T76732 (Exact matches should win) would improve the situation slightly, but would not fix it. In this case, having to type "Search-and-Discovery" before it would hit the exact match is silly. There should be a way to just type "Sear" or "Discov" and have the main project in the short list of 5.

If phabricator uses a known rule to pick which 5 projects are shown, such as "first 5 alphabetically", then we can name our projects to get the results we want. Without that, we will have to set up weird hashtag aliases, and then enter strings not related to the actual project names, in order to autocomplete quickly.

The bug is made worse by the fact that there is no way to exclude a project you do not want. For instance, when selecting multiple projects with a similar name for a search, projects which already were selected keep being displayed in the options. This doesn't make any sense and is inconsistent with standard selectors all over the web; there is a report but due to T75854 it's impossible to find.

(I reopened this because I do not believe it is a duplicate of T76732, and I have updated this description to clarify that.)


Workaround: As described in T75737 by valhallasw, to get more proposals displayed, execute

JX.TypeaheadSource.prototype.setMaximumResultCount(100)

in the javascript console (or a userscript).

Workaround: If there is a magnifying glass icon next to the field, clicking it will pop up a dialog which displays all search results, not only top 5. Not all fields affected by this problem have the option, though.

Related Objects

Event Timeline

ksmith raised the priority of this task from to Needs Triage.
ksmith updated the task description. (Show Details)
ksmith added a project: Phabricator.
ksmith added a subscriber: ksmith.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 19 2015, 10:14 PM

Confirming - there are six projects that include "Search-and-Discovery" in their name and by default Phab shows five.

Dup of T76732 and reopen that ticket?

Qgil set Security to None.

@Aklapper It certainly does seem that T76732 is broken again, and should be reopened.

However, upon further reflection, fixing that wouldn't really solve this issue. I don't want to have to type the entire string "Search-and-Discovery" before it would hit the exact match. Note that this will be a problem for any large team that uses the team name or feature area as a prefix for 6 or more projects.

So I think the results should be predictable. If we always got the first 5 *ordered* results, then we could name our projects to ensure the results we want. Unpredictable results are a recipe for ongoing frustration.

As a side note, our workaround for now is that our main project has a very different hashtag, and anyone who knows that secret can use that to bring up the project quickly and unambiguously. So it's not a showstopper, but it is pretty annoying.

ksmith reopened this task as Open.May 21 2015, 3:24 PM
ksmith updated the task description. (Show Details)
Qgil triaged this task as Low priority.Jul 28 2015, 9:49 AM
Qgil moved this task from Backlog to Ready To Go on the Phabricator (Upstream) board.
Qgil added subscribers: scfc, Capt_Swing.
Qgil added a subscriber: Qgil.
Aklapper updated the task description. (Show Details)Jul 28 2015, 10:26 AM

This is extra special broken for Design Research. Typing "design research" into the project field for a new task doesn't even pull up our primary board as an option, even though that board is called Design-Research. I'm not sure where to go from here. Any advice?

If you click the magnifying glass icon next to the "Projects" field, it will pop up a dialog with less broken search (and which displays all search results, not only top 5).


@Capt_Swing: Another (poor) workaround is to find one of the hashtag aliases for your destination, and type that in instead (or some fragment of it which happens to be unique). In this case, typing "usab" is enough to match the #usability alias and suggest only the Design-Research project.

I really wish this would be fixed.

Thank you both for the tips! Sounds like this isn't something we can fix in-house though. Is that correct?

If you click the magnifying glass icon next to the "Projects" field, it will pop up a dialog with less broken search (and which displays all search results, not only top 5).

Whoa. Neat!

It might be nice if the sixth option (below the top five) were "see all results" or similar. I think clicking the magnifying glass icon is non-obvious.

matmarex updated the task description. (Show Details)Dec 24 2015, 12:15 AM
Ltrlg added a subscriber: Ltrlg.Jan 17 2016, 9:34 AM
Nemo_bis updated the task description. (Show Details)Mar 13 2016, 9:47 AM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 23 2016, 6:02 PM

I think this is mostly fixed now?

@mmodell I can confirm that typing "design-re" now delivers "design-research" as the top result. So my particular complaint has been addressed :)

ksmith closed this task as Resolved.Nov 29 2016, 7:54 PM
ksmith claimed this task.

Closing, since I can't find any remaining cases with terrible behavior. It's not perfect, but seems to be good enough, at least for now.