Page MenuHomePhabricator

Put beta eswiki to read-only mode
Closed, ResolvedPublic

Description

Hello, beta eswiki was used for the ContentTranslation Project, but there was no activity by mebers of this project for over three (or six?) months. That is of course no problem. The problem is, that this wiki is very strongly affected by spambots. Me and others deleted there over 5000 pages of spam and there were still 1-3 hits at the abuselogs every day, and always from changing IPs, so I got no chance to block them. If nobody from the CTT project wants to uses this project at the near future, we could put this wiki easily to read only mode, via siteadmin, this affects only this wiki, and this wiki could not be affected by spambots anymore. If someone wants to use this wiki for something after locking the eswiki database, this lock can be removed by stewards and developers easily, so there is no problem I think. Whats your opinion on that?

Event Timeline

Luke081515 raised the priority of this task from to Needs Triage.
Luke081515 updated the task description. (Show Details)
Luke081515 added a subscriber: Luke081515.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 14 2015, 11:44 PM
Luke081515 triaged this task as High priority.Aug 14 2015, 11:45 PM
Restricted Application added subscribers: Dereckson, Matanya. · View Herald TranscriptAug 16 2015, 8:19 AM
Amire80 added a subscriber: Arrbee.Aug 16 2015, 8:21 AM
Glaisher lowered the priority of this task from High to Medium.Aug 27 2015, 10:58 AM
Glaisher added subscribers: greg, Glaisher.

http://es.wikipedia.beta.wmflabs.org/w/index.php?title=Especial:CambiosRecientes&days=30&from= Nothing but spam.

Should we just do this now or should we wait until ...? Or should this be declined? Someone from Release-Engineering-Team can probably answer. (@greg?)

A temporary hack would be to add .* to the titleblacklist and then nobody but users with tboverride will be able to create anything. The other way around is to add it to the closeddb.list. If the second solution is preferred, I can submit a patch.

I think you'd need to create a closed-labs.dblist and add eswiki as the contents.

Can't someone in the developer group lock the db through the special page? http://es.wikipedia.beta.wmflabs.org/wiki/Especial:Usuarios_globales/developer

Yep, locked. Looks like it's stored the lock at /data/project/upload7/wikipedia/es/lock_yBgMBwiR

First time I see Special:LockDB working :D I'll see if I can work the closed-labs.dbilist, if it's still needed. It's just creating the file and adding the project, right?

Change 234594 had a related patch set uploaded (by MarcoAurelio):
Creating closed-labs.dblist and closing eswikibeta

https://gerrit.wikimedia.org/r/234594

First time I see Special:LockDB working :D

Yeah, I was kind of surprised it worked in our setup, interesting.

I'll see if I can work the closed-labs.dbilist, if it's still needed. It's just creating the file and adding the project, right?

That's certainly the preferred way to do this on an indefinite basis (Special:Lockdb is supposed to be for temporary maintenance), yup.

Actually I have no idea why that works in our setup. We set $wgReadOnlyFile = false;.

Change 234594 merged by jenkins-bot:
Creating closed-labs.dblist and closing es.wikipedia.beta.wmflabs.org

https://gerrit.wikimedia.org/r/234594

Doesn't seem to have taken effect. The closed tag is applied, but it doesn't get the right settings for closed wikis in groupOverrides:

krenair@deployment-bastion:/srv/mediawiki-staging$ git diff
diff --git a/wmf-config/CommonSettings.php b/wmf-config/CommonSettings.php
index 9874348..d15d624 100755
--- a/wmf-config/CommonSettings.php
+++ b/wmf-config/CommonSettings.php
@@ -140,7 +140,7 @@ if ( @filemtime( $filename ) >= filemtime( "$wmfConfigDir/InitialiseSettings.php
 if ( !$globals ) {
        # Get configuration from SiteConfiguration object
        require( "$wmfConfigDir/InitialiseSettings.php" );
-
+}//
        $wikiTags = array();
        foreach ( array( 'private', 'fishbowl', 'special', 'closed', 'flaggedrevs', 'small', 'medium',
                        'large', 'wikimania', 'wikidata', 'wikidataclient', 'visualeditor-default',
@@ -152,7 +152,7 @@ if ( !$globals ) {
                        $wikiTags[] = $tag;
                }
        }
-
+if ( !$globals ) { //
        $dbSuffix = ( $site === 'wikipedia' ) ? 'wiki' : $site;
        $globals = $wgConf->getAll( $wgDBname, $dbSuffix,
                array(
krenair@deployment-bastion:/srv/mediawiki-staging$ mwscript eval.php eswiki
> var_dump( $wikiTags );
array(6) {
  [0]=>
  string(6) "closed"
  [1]=>
  string(5) "large"
  [2]=>
  string(14) "wikidataclient"
  [3]=>
  string(9) "wikipedia"
  [4]=>
  string(15) "arbitraryaccess"
  [5]=>
  string(13) "usagetracking"
}

> var_dump( $groupOverrides );
array(5) {
  ["rollbacker"]=>
  array(2) {
    ["rollback"]=>
    bool(true)
    ["abusefilter-log-detail"]=>
    bool(true)
  }
  ["*"]=>
  array(1) {
    ["patrolmarks"]=>
    bool(true)
  }
  ["autopatrolled"]=>
  array(1) {
    ["autopatrol"]=>
    bool(true)
  }
  ["patroller"]=>
  array(3) {
    ["patrol"]=>
    bool(true)
    ["autopatrol"]=>
    bool(true)
    ["abusefilter-log-detail"]=>
    bool(true)
  }
  ["flood"]=>
  array(1) {
    ["bot"]=>
    bool(true)
  }
}
Luke081515 lowered the priority of this task from Medium to Low.Aug 31 2015, 5:04 PM

I added so .* to the titleblacklist, so it is not important to do this lock fast.

I figured out the issue. eswiki's own explicit entry in groupOverrides will override the 'closed' tag. Needs the '+' added.

Krenair claimed this task.Sep 3 2015, 2:50 AM

Change 235666 had a related patch set uploaded (by Alex Monk):
Make eswiki groupOverrides inherit overrides from relevant tags

https://gerrit.wikimedia.org/r/235666

Change 235666 merged by jenkins-bot:
Make eswiki groupOverrides inherit overrides from relevant tags

https://gerrit.wikimedia.org/r/235666

Krenair closed this task as Resolved.Sep 3 2015, 3:08 PM
Luke081515 moved this task from Backlog to Done on the ContentTranslation-Deployments board.
Luke081515 reopened this task as Open.EditedOct 15 2015, 12:38 PM
08:43, 15 October 2015‎ 23.105.150.137 (Talk | block)‎ . . (3,405 bytes) (+3,405)‎ . . (Página creada con ...

I can't explain why, but an anonymous user created a page again. I will delete this page now, because it is spam, but, we need to find the problem.

Luke081515 added a comment.EditedOct 15 2015, 12:41 PM

There are account creations too

(I restored the titleblacklist, which contains ".*", till the problem is fixed, so no one can create new pages)

hashar reopened this task as Open.Oct 19 2015, 9:38 AM
hashar added a subscriber: hashar.

Please reopen the eswiki on beta cluster. It is used for content translation testing.

Please reopen the eswiki on beta cluster. It is used for content translation testing.

From the opening description of the task:

Hello, beta eswiki was used for the ContentTranslation Project, but there was no activity by mebers of this project for over three (or six?) months.

Is there somewhere more active in labs that could be used?

Please note:
It is possible to write at eswiki at the moment, till T115584 is fixed, but I would revert the change as soon as possible (not possible at the moment, I would set up a patch in a few hours)

NOTE: http://es.wikipedia.beta.wmflabs.org/wiki/Especial:FiltroAntiAbusos/2 is active now, he would block spambots. Logged in users are not affected by this filter, so I guess this would not be a problem, because you have to login to use the CTT.
hashar closed this task as Resolved.Oct 19 2015, 9:54 AM

Hello, beta eswiki was used for the ContentTranslation Project, but there was no activity by mebers of this project for over three (or six?) months.

Ah sorry I have paid attention to the task detail :-} So that is probably good for now, we can always reopen it later on if needed. Sorry!

@Peachey88: simplewiki, enwiki (these are the most actives). But there are others too: http://deployment.wikimedia.beta.wmflabs.org/wiki/Special:SiteMatrix

bmansurov added a subscriber: bmansurov.EditedDec 7 2018, 8:12 PM

Can we unlock this wiki for registered users? I need to create some pages for testing the recommendation API: T211397: Recommendation API in beta labs doesn't work.

Hi,

I also want to test the ContentTranslation tool, specially due the bug affecting blocked users from translating.

hashar removed a subscriber: hashar.Sep 11 2019, 9:35 AM

Change 608249 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[operations/mediawiki-config@master] multiversion: Fix 'closed-labs' reading as 'closed' for static config

https://gerrit.wikimedia.org/r/c/operations/mediawiki-config/ /608249

Change 608249 merged by jenkins-bot:
[operations/mediawiki-config@master] multiversion: Fix 'closed-labs' reading as 'closed' for static config

https://gerrit.wikimedia.org/r/c/operations/mediawiki-config/ /608249