Update instances of Wikimedia Foundation logo
Closed, ResolvedPublic

Description

The Wikimedia Foundation has updated our logo: https://meta.wikimedia.org/wiki/Brand

As such, the Communications Department would like to request that it be updated on Foundation wikis using it or variations. The new logo itself is already ready, variations for other wikis are not.

Updating in gerrit:

Updating in GitHub:

Must be done by FR Tech:

Lower priority (new variation not yet ready):

  • operations/mediawiki-config/static/favicon/office.ico
    • Addresses: Office-Wiki
  • operations/mediawiki-config/static/images/project-logos/officewiki.png
    • Addresses: Office-Wiki

Lowest priority - we are aware they use a variation - but are not updating at this time:

  • operations/mediawiki-config/static/images/project-logos/advisorywiki.png
    • Addresses: Advisory Board's wiki
  • operations/mediawiki-config/static/images/project-logos/internalwiki.png
    • Addresses: Internal Wiki
  • operations/mediawiki-config/static/images/project-logos/boardwiki.png
    • Addresses: Board Wiki
  • operations/mediawiki-config/static/images/project-logos/chapcomwiki.png
    • Addresses: AffCom Wiki
  • operations/mediawiki-config/static/images/project-logos/fdcwiki.png
    • Addresses: FDC Wiki
  • operations/mediawiki-config/static/images/project-logos/iegcomwiki.png
    • Addresses: IEG Wiki
  • operations/mediawiki-config/static/images/project-logos/ombudsmenwiki.png
    • Addresses: Ombuds Committee Wiki
There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptAug 30 2016, 6:03 AM
Urbanecm moved this task from Backlog to Working on on the User-Urbanecm board.Aug 30 2016, 6:30 AM

Change 307475 had a related patch set uploaded (by Urbanecm):
Update instances of Wikimedia Foundation logo #1

https://gerrit.wikimedia.org/r/307475

@Varnent Hi, the patch I've uploaded contains the higher priority logos. Do you want all logos to be deployed at once (I mean the higher and lower priority logos) or do you prefer we deploy logos as soon they are ready?

I can schedule this patch to be deployed today between 13:00-14:00 UTC if you want.

Varnent updated the task description. (Show Details)Aug 30 2016, 6:42 AM

I am checking with @Heather on the priority of ones we will need variations for, and if they are ready to be designed now or will come later. I apologize, but I realize I made a typo. The WMF favicon is ready, the officewiki one is not, and internal one is lowest priority.

@Urbanecm - also - thank you! That was quick! :)

You're welcome @Varnent .

Ad typo) Nothing happened, I've fixed it in my patch.
Ad priorities) Okay, I won't schedule it until the discussion with @Heather will be completed.

@Urbanecm - great thank you! That was faster than I was expecting - lol - so I just need to verify a couple things first and touch base with FR. :) Should be back to you later today.

@Urbanecm - Okay - we are talking with FR about timing and should have an update relatively soon.

In the meantime, I've made a couple of small edits - including removing default.png for now as I'm not 100% sure if that also sometimes appears for a few days on new community wikis as well.

Will likely also be adding payments wiki to the list once we finalize things with FR.

On that note - thank you to @Pcoombe for working with us on this. :)

Varnent updated the task description. (Show Details)Aug 31 2016, 3:57 PM

@Varnent Okay. I've removed default.png from my patch too. I think default.png will be shown at all wikis that aren't in any of the following families.

  • wikibooks
  • wikinews
  • wikipedia
  • wikiquote
  • wikisource
  • wikiversity
  • wiktionary
  • wikivoyage

So default.png should be showed in special and chapter wikis without it own logo.

I guess the patch is not ready for deployment now. Can you confirm it?

@Varnent Are there any updates on this? Can I deploy my partial now or should I wait till all logos will be ready?

DStrine added a subscriber: DStrine.

fr-tech will update payments wiki within the next month or two. Our task: T141921

Urbanecm lowered the priority of this task from Normal to Low.Sep 12 2016, 7:26 PM

Any updates?

Seems like it's okay if these changes go ahead, and fundraising will catch up when they have the chance.

Varnent added a comment.EditedSep 30 2016, 4:30 PM

Comms goal is to wait until FR Tech is ready with the update on Payments Wiki so that donors do not see a different logo at some point in the donation process.

I am waiting on that exact timeline - but was told originally in the next few weeks.

Just for clarify. Should I do something with this request or not?

Urbanecm changed the task status from Open to Stalled.Oct 10 2016, 11:47 AM

Stalled till reply...

@DStrine Can you clarify if this should go ahead?

Urbanecm lowered the priority of this task from Low to Lowest.Nov 7 2016, 4:29 PM

For two months there isn't any update and last request for it was about a month ago. There isn't nothing actionable from my side before long time...

Please get a consensus on meta. for login./vote., there are as much Wikimedia movement than WMF.

Please also check the quality of the original SVG, the version submitted doesn't look as good as the current ones

Varnent added a comment.EditedNov 15 2016, 9:19 PM

@Urbanecm - we are delaying until January 2017 at FR Tech's request.

@Dereckson - fair point - we will hold off on those for now.

Varnent updated the task description. (Show Details)Nov 15 2016, 9:22 PM

There is no consensus to change the footer and the black version doesn't fit well with the project logos. It was designed for offline/off-wiki consumption, clearly, not for usage on the actual Wikimedia wikis.

Varnent updated the task description. (Show Details)Feb 8 2017, 11:49 PM
Varnent updated the task description. (Show Details)Feb 9 2017, 12:22 AM
Varnent updated the task description. (Show Details)Feb 9 2017, 3:32 AM
Varnent updated the task description. (Show Details)Feb 9 2017, 3:40 AM
Varnent updated the task description. (Show Details)
Varnent updated the task description. (Show Details)Feb 9 2017, 3:45 AM
Urbanecm removed Urbanecm as the assignee of this task.Mar 14 2017, 12:02 PM
Urbanecm added a subscriber: Urbanecm.
Ejegg added a subscriber: Ejegg.Apr 12 2017, 7:30 PM

OK, the new logo is uploaded to payments-wiki and is ready to switch over with a settings update. I've got new versions of the logo for the login and popup pages on Amazon Pay, and the hosted checkout at d-Local. Doesn't look like we show a 3rd-party-hosted logo in the current PayPal integration, or in the Ingenico or Adyen credit card iframes.

Donatewiki would use the same logo as foundationwiki, so whatever mw-config change updates foundationwiki should copy the image to /static/images/project-logos/donatewiki.png, or better yet just point to the same files, including HD.

Ejegg added subscribers: CaitVirtue, CCogdill_WMF.EditedApr 12 2017, 7:51 PM

Other FR people to coordinate with: @Pcoombe will need to update the logo in the footer of the thank you page. @CCogdill_WMF , what sizes do you need the new logo in for emails? @CaitVirtue , what does MG need for the logo update?

@Ejegg I don't use the logo in fundraising emails. Is it in the TY email? That would be nice to include... but I don't have ownership over that one.

Our thank you mail is text-only, so I guess we're covered email-wise.

@Ejegg Please connect with @LeanneS and @RLewis for any logo needs. Thanks!

@Ejegg Thanks! For reference here's the checklist we came up with previously: https://docs.google.com/spreadsheets/d/14ytKoS8Oho0xDAhPCSLZQ4QtrD7HBMbFMXzUnrh0ujI/edit#gid=0

Thank you pages are now done, as is the matching gifts search.

Only other thing I can think of is the email unsubscribe page, is that for tech or @CCogdill_WMF to change?

Oops, good call... Thanks, Peter. That's my change. I may not be able to do
this until Brian is back from vacation next week.

Ejegg added a comment.Apr 13 2017, 5:15 PM

@Varnent Fundraising is all set to move forward with this. Looks like @Urbanecm has a patch to make the updates on the main cluster. The patch might need a couple of changes, including adding a new version of the 'a wikimedia project' button. Would comms create that pic?

@Varnent Fundraising is all set to move forward with this. Looks like @Urbanecm has a patch to make the updates on the main cluster. The patch might need a couple of changes, including adding a new version of the 'a wikimedia project' button. Would comms create that pic?

It looks like the patch may need to be updated according to the info above under "Updating in gerrit". This patch appears to be based on info from the original request, some of the files have moved, and others we have decided to hold off on for now as only the Wikimedia Foundation logo icon is changing, and not the Wikimedia community logos.

Ejegg added a comment.Apr 18 2017, 5:44 AM

@Varnent OK, does this look like the places it needs to change now?

All of these wikis have the logo with 'Wikimedia Foundation'
wikimediafoundation.org - favicon and wiki logo
donate.wm.o - favicon and wiki logo
payments.wm.o - favicon and wiki logo
vote.wikimedia.org - favicon and wiki logo

There are little versions of the icon without text that are used in the notification box. The patch currently changes those to black and white as well, I believe just for the foundation wiki.

We do not need to do vote.wikimedia.org - the list in top of ticket should be accurate:

Updating in gerrit:

Updating in GitHub:

Must be done by FR Tech:

Ejegg added a comment.Apr 28 2017, 7:19 PM

OK, I've got the mediawiki-config patch updated to just touch the donatewiki and foundationwiki logos & favicon. Any reason to hold off, or should we deploy this now?

This week was a little busy for Comms - so let's wait until next week (we will ping back) - just in case there are questions from folks once this happens. :)

spatton added a subscriber: spatton.May 8 2017, 7:24 PM

Hi @Varnent and thread, a couple random places still using the old logo - apologies if these are known:

  1. In the CultureAmp Wikimedia Foundation Engagement Survey that just went out
  2. https://blog.wikimedia.org/
Varnent added a comment.EditedMay 10 2017, 12:58 AM

Hi @Varnent and thread, a couple random places still using the old logo - apologies if these are known:

  1. In the CultureAmp Wikimedia Foundation Engagement Survey that just went out
  2. https://blog.wikimedia.org/

Thank you, @spatton, for the ping and info! :)

  1. I will let T&C know about the CultureAmp logo - it looks like something on CultureAmp's servers.
  2. I am checking on the logo for blog, but holding off for this moment. May have answer very soon.
Jdforrester-WMF changed the task status from Stalled to Open.Jun 8 2017, 1:01 AM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

AFAIAA this isn't Stalled on anything in particular currently, right?

Change 307475 merged by jenkins-bot:
[operations/mediawiki-config@master] Update instances of Wikimedia Foundation logo #1

https://gerrit.wikimedia.org/r/307475

Change 360652 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[operations/mediawiki-config@master] static/images: Restore dimensions of wmf.png

https://gerrit.wikimedia.org/r/360652

Change 360652 merged by jenkins-bot:
[operations/mediawiki-config@master] static/images: Restore dimensions of wmf.png

https://gerrit.wikimedia.org/r/360652

Nemo_bis changed the task status from Open to Stalled.Jun 29 2017, 10:28 AM

AFAIAA this isn't Stalled on anything in particular currently, right?

Wrong: https://meta.wikimedia.org/w/index.php?title=Talk:Brand&diff=15821232&oldid=15821225

AFAIAA this isn't Stalled on anything in particular currently, right?

Wrong: https://meta.wikimedia.org/w/index.php?title=Talk:Brand&diff=15821232&oldid=15821225

Can you explain what you think that link indicates, and in particular how that means this is Stalled? I've read it twice now and I can't see what you're getting at, sorry.

Varnent closed this task as Resolved.Jun 29 2017, 3:56 PM
Varnent claimed this task.

We can safely close this ticket. This set of updates is done. We will have another set soon. On behalf of the Foundation's Communications department, including @Heather (who made that post and I just spoke with), this is the official logo of the Wikimedia Foundation and these were approved changes. :)

Varnent changed the status of subtask T164786: Update mark on Wikimedia Blog from Open to Stalled.Oct 16 2017, 9:59 PM